summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-02-06 13:41:27 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-02-06 13:41:27 +0000
commitc3a0b58aeb0d92036b122bee862a5c68d704709d (patch)
tree735d6d5d3fdeda6b6bdcca0de92a66d1e883d81e /dev-lang
parentBump to 10.0, from overlay (diff)
downloadgentoo-2-c3a0b58aeb0d92036b122bee862a5c68d704709d.tar.gz
gentoo-2-c3a0b58aeb0d92036b122bee862a5c68d704709d.tar.bz2
gentoo-2-c3a0b58aeb0d92036b122bee862a5c68d704709d.zip
Fixed compile fail against libpcre. Bug 402357
Non-fixed versions block libpcre-8.30+ (Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/ChangeLog10
-rw-r--r--dev-lang/php/php-5.3.10-r1.ebuild (renamed from dev-lang/php/php-5.4.0_rc6.ebuild)48
-rw-r--r--dev-lang/php/php-5.3.10.ebuild3
-rw-r--r--dev-lang/php/php-5.3.9.ebuild3
-rw-r--r--dev-lang/php/php-5.4.0_rc7.ebuild3
5 files changed, 39 insertions, 28 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index 29fe5d09da60..01d0934811ed 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.551 2012/02/06 01:15:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.552 2012/02/06 13:41:27 olemarkus Exp $
+
+*php-5.3.10-r1 (06 Feb 2012)
+
+ 06 Feb 2012; Ole Markus With <olemarkus@gentoo.org> +php-5.3.10-r1.ebuild,
+ -php-5.4.0_rc6.ebuild, php-5.3.10.ebuild, php-5.3.9.ebuild,
+ php-5.4.0_rc7.ebuild:
+ Fixed compile fail against libpcre. Bug 402357 Non-fixed versions block
+ libpcre-8.30+
06 Feb 2012; Jeroen Roovers <jer@gentoo.org> php-5.3.10.ebuild:
Stable for HPPA (bug #401997).
diff --git a/dev-lang/php/php-5.4.0_rc6.ebuild b/dev-lang/php/php-5.3.10-r1.ebuild
index 106649e71477..0d8b4a086de8 100644
--- a/dev-lang/php/php-5.4.0_rc6.ebuild
+++ b/dev-lang/php/php-5.3.10-r1.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.4.0_rc6.ebuild,v 1.1 2012/01/20 14:40:05 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.10-r1.ebuild,v 1.1 2012/02/06 13:41:27 olemarkus Exp $
EAPI=4
+PHPCONFUTILS_MISSING_DEPS="adabas birdstep db2 dbmaker empress empress-bcs esoob interbase oci8 sapdb solid"
+
inherit eutils autotools flag-o-matic versionator depend.apache apache-module db-use libtool
-SUHOSIN_VERSION=""
+SUHOSIN_VERSION="5.3.9-0.9.10"
FPM_VERSION="builtin"
EXPECTED_TEST_FAILURES=""
@@ -15,9 +17,6 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
function php_get_uri ()
{
case "${1}" in
- "php-stas")
- echo "http://downloads.php.net/stas/${2}"
- ;;
"php-pre")
echo "http://downloads.php.net/johannes/${2}"
;;
@@ -44,16 +43,14 @@ PHP_MV="$(get_major_version)"
# alias, so we can handle different types of releases (finals, rcs, alphas,
# betas, ...) w/o changing the whole ebuild
PHP_PV="${PV/_rc/RC}"
-PHP_PV="${PHP_PV/_alpha/alpha}"
-PHP_PV="${PHP_PV/_beta/beta}"
-PHP_RELEASE="php-stas"
+PHP_RELEASE="php"
PHP_P="${PN}-${PHP_PV}"
PHP_PATCHSET_LOC="olemarkus"
PHP_SRC_URI="$(php_get_uri "${PHP_RELEASE}" "${PHP_P}.tar.bz2")"
-PHP_PATCHSET="0"
+PHP_PATCHSET="1"
PHP_PATCHSET_URI="
$(php_get_uri "${PHP_PATCHSET_LOC}" "php-patchset-${PV}-r${PHP_PATCHSET}.tar.bz2")"
@@ -63,7 +60,7 @@ PHP_FPM_CONF_VER="1"
if [[ ${SUHOSIN_VERSION} == *-gentoo ]]; then
# in some cases we use our own suhosin patch (very recent version,
# patch conflicts, etc.)
- SUHOSIN_TYPE="gentoo"
+ SUHOSIN_TYPE="olemarkus"
else
SUHOSIN_TYPE="suhosin"
fi
@@ -108,7 +105,7 @@ IUSE="${IUSE} bcmath berkdb bzip2 calendar cdb cjk
mssql mysql mysqlnd mysqli nls
oci8-instant-client odbc pcntl pdo +phar pic +posix postgres qdbm
readline recode +session sharedmem
- +simplexml snmp soap sockets spell sqlite3 ssl
+ +simplexml snmp soap sockets spell sqlite sqlite3 ssl
sybase-ct sysvipc tidy +tokenizer truetype unicode wddx
+xml xmlreader xmlwriter xmlrpc xpm xsl zip zlib"
@@ -165,7 +162,8 @@ DEPEND="!dev-lang/php:5
snmp? ( >=net-analyzer/net-snmp-5.2 )
soap? ( >=dev-libs/libxml2-2.6.8 )
spell? ( >=app-text/aspell-0.50 )
- sqlite3? ( >=dev-db/sqlite-3.7.6.3 )
+ sqlite? ( =dev-db/sqlite-2* pdo? ( >=dev-db/sqlite-3.7.7.1 ) )
+ sqlite3? ( >=dev-db/sqlite-3.7.7.1 )
ssl? ( >=dev-libs/openssl-0.9.7 )
sybase-ct? ( dev-db/freetds )
tidy? ( app-text/htmltidy )
@@ -197,7 +195,7 @@ php="=${CATEGORY}/${PF}"
REQUIRED_USE="
truetype? ( gd )
cjk? ( gd )
- exif? ( gd )
+ exif? ( gd )
xpm? ( gd )
gd? ( zlib )
@@ -225,16 +223,18 @@ REQUIRED_USE="
!cli? ( !cgi? ( !fpm? ( !apache2? ( !embed? ( cli ) ) ) ) )"
DEPEND="${DEPEND}
- enchant? ( !dev-php/pecl-enchant )
- fileinfo? ( !<dev-php/pecl-fileinfo-1.0.4-r2 )
- filter? ( !dev-php/pecl-filter )
- json? ( !dev-php/pecl-json )
- phar? ( !dev-php/pecl-phar )
- zip? ( !dev-php/pecl-zip )"
+ enchant? ( !dev-php5/pecl-enchant )
+ fileinfo? ( !<dev-php5/pecl-fileinfo-1.0.4-r2 )
+ filter? ( !dev-php5/pecl-filter )
+ json? ( !dev-php5/pecl-json )
+ phar? ( !dev-php5/pecl-phar )
+ zip? ( !dev-php5/pecl-zip )"
[[ -n $SUHOSIN_VERSION ]] && RDEPEND="${RDEPEND} suhosin? (
=${CATEGORY}/${PN}-${SLOT}*[unicode] )"
+RDEPEND="${DEPEND}"
+
DEPEND="${DEPEND}
sys-devel/flex
>=sys-devel/m4-1.4.3
@@ -307,7 +307,7 @@ eblit-run-maybe() {
# Usage: <function> [version]
# Runs a function defined in an eblit
eblit-run() {
- eblit-include --skip common v2
+ eblit-include --skip common "v2"
eblit-include "$@"
eblit-run-maybe eblit-$1-pre
eblit-${PN}-$1
@@ -324,9 +324,9 @@ eblit-pkg() {
eblit-pkg pkg_setup v3
-src_prepare() { eblit-run src_prepare v4 ; }
-src_configure() { eblit-run src_configure v54 ; }
-src_compile() { eblit-run src_compile v2 ; }
+src_prepare() { eblit-run src_prepare v3 ; }
+src_configure() { eblit-run src_configure v53 ; }
+src_compile() { eblit-run src_compile v1 ; }
src_install() { eblit-run src_install v3 ; }
src_test() { eblit-run src_test v1 ; }
@@ -384,7 +384,7 @@ pkg_postinst() {
if ( [[ -z SUHOSIN_VERSION ]] && use suhosin && version_is_at_least 5.3.6_rc1 ) ; then
ewarn "The suhosin USE flag now only installs the suhosin patch!"
ewarn "If you want the suhosin extension, make sure you install"
- ewarn " dev-php/suhosin"
+ ewarn " dev-php5/suhosin"
ewarn
fi
}
diff --git a/dev-lang/php/php-5.3.10.ebuild b/dev-lang/php/php-5.3.10.ebuild
index 49f80d18123e..73731d5cacb5 100644
--- a/dev-lang/php/php-5.3.10.ebuild
+++ b/dev-lang/php/php-5.3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.10.ebuild,v 1.4 2012/02/06 01:15:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.10.ebuild,v 1.5 2012/02/06 13:41:27 olemarkus Exp $
EAPI=4
@@ -115,6 +115,7 @@ IUSE="${IUSE} bcmath berkdb bzip2 calendar cdb cjk
DEPEND="!dev-lang/php:5
>=app-admin/eselect-php-0.6.2
>=dev-libs/libpcre-8.12[unicode]
+ <dev-libs/libpcre-8.30[unicode]
apache2? ( www-servers/apache[threads=] )
berkdb? ( =sys-libs/db-4* )
bzip2? ( app-arch/bzip2 )
diff --git a/dev-lang/php/php-5.3.9.ebuild b/dev-lang/php/php-5.3.9.ebuild
index 53b8a9751c97..9775bf078bff 100644
--- a/dev-lang/php/php-5.3.9.ebuild
+++ b/dev-lang/php/php-5.3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.9.ebuild,v 1.8 2012/01/17 05:18:51 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.9.ebuild,v 1.9 2012/02/06 13:41:27 olemarkus Exp $
EAPI=4
@@ -115,6 +115,7 @@ IUSE="${IUSE} bcmath berkdb bzip2 calendar cdb cjk
DEPEND="!dev-lang/php:5
>=app-admin/eselect-php-0.6.2
>=dev-libs/libpcre-8.12[unicode]
+ <dev-libs/libpcre-8.30[unicode]
apache2? ( www-servers/apache[threads=] )
berkdb? ( =sys-libs/db-4* )
bzip2? ( app-arch/bzip2 )
diff --git a/dev-lang/php/php-5.4.0_rc7.ebuild b/dev-lang/php/php-5.4.0_rc7.ebuild
index 7abca97c0071..08688ce85ca4 100644
--- a/dev-lang/php/php-5.4.0_rc7.ebuild
+++ b/dev-lang/php/php-5.4.0_rc7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.4.0_rc7.ebuild,v 1.1 2012/02/03 09:51:09 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.4.0_rc7.ebuild,v 1.2 2012/02/06 13:41:27 olemarkus Exp $
EAPI=4
@@ -118,6 +118,7 @@ IUSE="${IUSE} bcmath berkdb bzip2 calendar cdb cjk
DEPEND="!dev-lang/php:5
>=app-admin/eselect-php-0.6.2
>=dev-libs/libpcre-8.12[unicode]
+ <dev-libs/libpcre-8.30[unicode]
apache2? ( www-servers/apache[threads=] )
berkdb? ( =sys-libs/db-4* )
bzip2? ( app-arch/bzip2 )