summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-06-02 20:05:54 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-06-02 20:05:54 +0000
commit8a7656851dc89d28dcc3803eba0405c21bb8db0e (patch)
treec372221254df8b3e2f4a9a503ae42cc3d04c6fe9 /dev-lang
parentamd64 stable wrt bug #551010 (diff)
downloadgentoo-2-8a7656851dc89d28dcc3803eba0405c21bb8db0e.tar.gz
gentoo-2-8a7656851dc89d28dcc3803eba0405c21bb8db0e.tar.bz2
gentoo-2-8a7656851dc89d28dcc3803eba0405c21bb8db0e.zip
remove old version
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/ChangeLog6
-rw-r--r--dev-lang/go/files/go-1.2-no-Werror.patch10
-rw-r--r--dev-lang/go/go-1.4.1.ebuild120
3 files changed, 5 insertions, 131 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index ca590cc027a2..0cbd438f5845 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.73 2015/06/02 15:37:10 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.74 2015/06/02 20:05:54 williamh Exp $
+
+ 02 Jun 2015; William Hubbs <williamh@gentoo.org>
+ -files/go-1.2-no-Werror.patch, -go-1.4.1.ebuild:
+ remove old version
02 Jun 2015; William Hubbs <williamh@gentoo.org> go-9999.ebuild:
Remove include directory for #549814 thanks to Bohdan Trach
diff --git a/dev-lang/go/files/go-1.2-no-Werror.patch b/dev-lang/go/files/go-1.2-no-Werror.patch
deleted file mode 100644
index 01f183edb078..000000000000
--- a/dev-lang/go/files/go-1.2-no-Werror.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/cmd/dist/build.c
-+++ b/src/cmd/dist/build.c
-@@ -384,7 +384,6 @@ static char *proto_gccargs[] = {
- "-Wno-switch",
- "-Wno-comment",
- "-Wno-missing-field-initializers",
-- "-Werror",
- "-fno-common",
- "-ggdb",
- "-pipe",
diff --git a/dev-lang/go/go-1.4.1.ebuild b/dev-lang/go/go-1.4.1.ebuild
deleted file mode 100644
index 5c51626bf60d..000000000000
--- a/dev-lang/go/go-1.4.1.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.4.1.ebuild,v 1.4 2015/02/17 21:03:49 maekke Exp $
-
-EAPI=5
-
-export CTARGET=${CTARGET:-${CHOST}}
-
-inherit eutils toolchain-funcs
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="git://github.com/golang/go.git"
- inherit git-r3
-else
- SRC_URI="https://storage.googleapis.com/golang/go${PV}.src.tar.gz"
- # Upstream only supports go on amd64, arm and x86 architectures.
- KEYWORDS="-* amd64 arm x86 ~amd64-fbsd ~x86-fbsd ~x64-macos ~x86-macos"
-fi
-
-DESCRIPTION="A concurrent garbage collected and typesafe programming language"
-HOMEPAGE="http://www.golang.org"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
-QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
-
-# The go language uses *.a files which are _NOT_ libraries and should not be
-# stripped.
-STRIP_MASK="/usr/lib/go/pkg/linux*/*.a /usr/lib/go/pkg/freebsd*/*.a /usr/lib/go/pkg/darwin*/*.a"
-
-if [[ ${PV} != 9999 ]]; then
- S="${WORKDIR}"/go
-fi
-
-src_prepare()
-{
- if [[ ${PV} != 9999 ]]; then
- epatch "${FILESDIR}"/${PN}-1.2-no-Werror.patch
- fi
- epatch_user
-}
-
-src_compile()
-{
- export GOROOT_FINAL="${EPREFIX}"/usr/lib/go
- export GOROOT="$(pwd)"
- export GOBIN="${GOROOT}/bin"
- if [[ $CTARGET = armv5* ]]
- then
- export GOARM=5
- fi
- tc-export CC
-
- cd src
- ./make.bash || die "build failed"
-}
-
-src_test()
-{
- cd src
- PATH="${GOBIN}:${PATH}" \
- ./run.bash --no-rebuild --banner || die "tests failed"
-}
-
-src_install()
-{
- dobin bin/*
- dodoc AUTHORS CONTRIBUTORS PATENTS README
-
- dodir /usr/lib/go
- insinto /usr/lib/go
-
- # There is a known issue which requires the source tree to be installed [1].
- # Once this is fixed, we can consider using the doc use flag to control
- # installing the doc and src directories.
- # [1] https://golang.org/issue/2775
- doins -r doc include lib pkg src
- fperms -R +x /usr/lib/go/pkg/tool
-}
-
-pkg_preinst()
-{
- has_version '<dev-lang/go-1.4' &&
- export had_support_files=true ||
- export had_support_files=false
-}
-
-pkg_postinst()
-{
- # If the go tool sees a package file timestamped older than a dependancy it
- # will rebuild that file. So, in order to stop go from rebuilding lots of
- # packages for every build we need to fix the timestamps. The compiler and
- # linker are also checked - so we need to fix them too.
- ebegin "fixing timestamps to avoid unnecessary rebuilds"
- tref="usr/lib/go/pkg/*/runtime.a"
- find "${EROOT}"usr/lib/go -type f \
- -exec touch -r "${EROOT}"${tref} {} \;
- eend $?
-
- if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} &&
- ${REPLACING_VERSIONS} != ${PV} ]]; then
- elog "Release notes are located at http://golang.org/doc/go${PV}"
- fi
-
- if $had_support_files; then
- ewarn
- ewarn "All editor support, IDE support, shell completion"
- ewarn "support, etc has been removed from the go package"
- ewarn "upstream."
- ewarn "For more information on which support is available, see"
- ewarn "the following URL:"
- ewarn "https://github.com/golang/go/wiki/IDEsAndTextEditorPlugins"
- fi
-}