summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2004-12-04 20:14:30 +0000
committerRobert Coie <rac@gentoo.org>2004-12-04 20:14:30 +0000
commit76627f584ba7c9c8bea35ae7c421a6ac617474de (patch)
tree1b27d157b166b89b1289289ad04f34980feeb82b /dev-lang
parentNew release from archetypes-1.3.1 tree. (Manifest recommit) (diff)
downloadgentoo-2-76627f584ba7c9c8bea35ae7c421a6ac617474de.tar.gz
gentoo-2-76627f584ba7c9c8bea35ae7c421a6ac617474de.tar.bz2
gentoo-2-76627f584ba7c9c8bea35ae7c421a6ac617474de.zip
some bug 66360 patches, keywording x86/amd64/ppc for 5.8.5-r2
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog9
-rw-r--r--dev-lang/perl/files/digest-perl-5.8.41
-rw-r--r--dev-lang/perl/files/digest-perl-5.8.5-r21
-rw-r--r--dev-lang/perl/files/digest-perl-5.8.6-r11
-rw-r--r--dev-lang/perl/files/perl-5.8.5-tempfiles.patch60
-rw-r--r--dev-lang/perl/files/perl-5.8.6-tempfiles.patch60
-rw-r--r--dev-lang/perl/perl-5.8.5-r2.ebuild (renamed from dev-lang/perl/perl-5.8.4.ebuild)119
-rw-r--r--dev-lang/perl/perl-5.8.6-r1.ebuild383
8 files changed, 588 insertions, 46 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index 206a291e561b..e8aa9c7fb7bb 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/perl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.95 2004/12/01 22:50:49 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.96 2004/12/04 20:14:30 rac Exp $
+
+*perl-5.8.5-r2 (04 Dec 2004)
+
+ 04 Dec 2004; Robert Coie <rac@gentoo.org>
+ +files/perl-5.8.5-tempfiles.patch, +files/perl-5.8.6-tempfiles.patch,
+ -perl-5.8.4.ebuild, +perl-5.8.5-r2.ebuild, +perl-5.8.6-r1.ebuild:
+ Add the few relevant bits from bug 66360, keyword 5.8.5-r2 x86, amd64 and ppc
01 Dec 2004; Robert Coie <rac@gentoo.org> perl-5.8.6.ebuild:
back makemaker block to 6.17
diff --git a/dev-lang/perl/files/digest-perl-5.8.4 b/dev-lang/perl/files/digest-perl-5.8.4
deleted file mode 100644
index a13f719f8c75..000000000000
--- a/dev-lang/perl/files/digest-perl-5.8.4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 912050a9cb6b0f415b76ba56052fb4cf perl-5.8.4.tar.gz 12094233
diff --git a/dev-lang/perl/files/digest-perl-5.8.5-r2 b/dev-lang/perl/files/digest-perl-5.8.5-r2
new file mode 100644
index 000000000000..a774272cdab6
--- /dev/null
+++ b/dev-lang/perl/files/digest-perl-5.8.5-r2
@@ -0,0 +1 @@
+MD5 49baa8d7d29b4a9713c06edeb81e6b1b perl-5.8.5.tar.gz 11930764
diff --git a/dev-lang/perl/files/digest-perl-5.8.6-r1 b/dev-lang/perl/files/digest-perl-5.8.6-r1
new file mode 100644
index 000000000000..666169141e1e
--- /dev/null
+++ b/dev-lang/perl/files/digest-perl-5.8.6-r1
@@ -0,0 +1 @@
+MD5 3d030b6ff2a433840edb1a407d18dc0a perl-5.8.6.tar.bz2 9693085
diff --git a/dev-lang/perl/files/perl-5.8.5-tempfiles.patch b/dev-lang/perl/files/perl-5.8.5-tempfiles.patch
new file mode 100644
index 000000000000..be0d64effe09
--- /dev/null
+++ b/dev-lang/perl/files/perl-5.8.5-tempfiles.patch
@@ -0,0 +1,60 @@
+diff -ur perl-5.8.5.orig/lib/ExtUtils/instmodsh perl-5.8.5/lib/ExtUtils/instmodsh
+--- perl-5.8.5.orig/lib/ExtUtils/instmodsh Tue Sep 30 17:10:47 2003
++++ perl-5.8.5/lib/ExtUtils/instmodsh Mon Jan 19 20:14:11 2004
+@@ -2,6 +2,7 @@
+
+ use strict;
+ use IO::File;
++use File::Temp;
+ use ExtUtils::Packlist;
+ use ExtUtils::Installed;
+
+@@ -58,16 +59,12 @@
+ $reply =~ /^t\s*/ and do
+ {
+ my $file = (split(' ', $reply))[1];
+- my $tmp = "/tmp/inst.$$";
+- if (my $fh = IO::File->new($tmp, "w"))
+- {
+- $fh->print(join("\n", $Inst->files($module)));
+- $fh->close();
+- system("tar cvf $file -I $tmp");
+- unlink($tmp);
+- last CASE;
+- }
+- else { print("Can't open $file: $!\n"); }
++ my ($fh, $tmp) = File::Temp::tempfile(UNLINK => 1);
++ $fh->print(join("\n", $Inst->files($module)));
++ $fh->close();
++ # This used to use -I which is wrong for GNU tar.
++ system("tar cvf $file -T $tmp");
++ unlink($tmp);
+ last CASE;
+ };
+ $reply eq 'v' and do
+
+diff -ur perl-5.8.5.orig/lib/perl5db.pl perl-5.8.5/lib/perl5db.pl
+--- perl-5.8.5.orig/lib/perl5db.pl Mon Jan 19 18:46:25 2004
++++ perl-5.8.5/lib/perl5db.pl Mon Jan 19 20:14:11 2004
+@@ -206,7 +206,7 @@
+ =item * noTTY
+
+ if set, goes in NonStop mode. On interrupt, if TTY is not set,
+-uses the value of noTTY or "/tmp/perldbtty$$" to find TTY using
++uses the value of noTTY or "/var/run/perldbtty$$" to find TTY using
+ Term::Rendezvous. Current variant is to have the name of TTY in this
+ file.
+
+@@ -5689,8 +5689,8 @@
+ else {
+ eval "require Term::Rendezvous;" or die;
+ # See if we have anything to pass to Term::Rendezvous.
+- # Use /tmp/perldbtty$$ if not.
+- my $rv = $ENV{PERLDB_NOTTY} || "/tmp/perldbtty$$";
++ # Use /var/run/perldbtty$$ if not.
++ my $rv = $ENV{PERLDB_NOTTY} || "/var/run/perldbtty$$";
+
+ # Rendezvous and get the filehandles.
+ my $term_rv = new Term::Rendezvous $rv;
+
+
diff --git a/dev-lang/perl/files/perl-5.8.6-tempfiles.patch b/dev-lang/perl/files/perl-5.8.6-tempfiles.patch
new file mode 100644
index 000000000000..a9dab03e2979
--- /dev/null
+++ b/dev-lang/perl/files/perl-5.8.6-tempfiles.patch
@@ -0,0 +1,60 @@
+diff -ur perl-5.8.6.orig/lib/ExtUtils/instmodsh perl-5.8.6/lib/ExtUtils/instmodsh
+--- perl-5.8.6.orig/lib/ExtUtils/instmodsh Tue Sep 30 17:10:47 2003
++++ perl-5.8.6/lib/ExtUtils/instmodsh Mon Jan 19 20:14:11 2004
+@@ -2,6 +2,7 @@
+
+ use strict;
+ use IO::File;
++use File::Temp;
+ use ExtUtils::Packlist;
+ use ExtUtils::Installed;
+
+@@ -58,16 +59,12 @@
+ $reply =~ /^t\s*/ and do
+ {
+ my $file = (split(' ', $reply))[1];
+- my $tmp = "/tmp/inst.$$";
+- if (my $fh = IO::File->new($tmp, "w"))
+- {
+- $fh->print(join("\n", $Inst->files($module)));
+- $fh->close();
+- system("tar cvf $file -I $tmp");
+- unlink($tmp);
+- last CASE;
+- }
+- else { print("Can't open $file: $!\n"); }
++ my ($fh, $tmp) = File::Temp::tempfile(UNLINK => 1);
++ $fh->print(join("\n", $Inst->files($module)));
++ $fh->close();
++ # This used to use -I which is wrong for GNU tar.
++ system("tar cvf $file -T $tmp");
++ unlink($tmp);
+ last CASE;
+ };
+ $reply eq 'v' and do
+
+diff -ur perl-5.8.6.orig/lib/perl5db.pl perl-5.8.6/lib/perl5db.pl
+--- perl-5.8.6.orig/lib/perl5db.pl Mon Jan 19 18:46:25 2004
++++ perl-5.8.6/lib/perl5db.pl Mon Jan 19 20:14:11 2004
+@@ -206,7 +206,7 @@
+ =item * noTTY
+
+ if set, goes in NonStop mode. On interrupt, if TTY is not set,
+-uses the value of noTTY or F</tmp/perldbtty$$> to find TTY using
++uses the value of noTTY or F</var/run/perldbtty$$> to find TTY using
+ Term::Rendezvous. Current variant is to have the name of TTY in this
+ file.
+
+@@ -5689,8 +5689,8 @@
+ else {
+ eval "require Term::Rendezvous;" or die;
+ # See if we have anything to pass to Term::Rendezvous.
+- # Use /tmp/perldbtty$$ if not.
+- my $rv = $ENV{PERLDB_NOTTY} || "/tmp/perldbtty$$";
++ # Use /var/run/perldbtty$$ if not.
++ my $rv = $ENV{PERLDB_NOTTY} || "/var/run/perldbtty$$";
+
+ # Rendezvous and get the filehandles.
+ my $term_rv = new Term::Rendezvous $rv;
+
+
diff --git a/dev-lang/perl/perl-5.8.4.ebuild b/dev-lang/perl/perl-5.8.5-r2.ebuild
index ac9dc8121638..9364a97c271b 100644
--- a/dev-lang/perl/perl-5.8.4.ebuild
+++ b/dev-lang/perl/perl-5.8.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.4.ebuild,v 1.27 2004/10/25 11:41:36 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.5-r2.ebuild,v 1.1 2004/12/04 20:14:30 rac Exp $
inherit eutils flag-o-matic gcc
@@ -14,14 +14,16 @@ S="${WORKDIR}/${MY_P}"
SRC_URI="ftp://ftp.perl.org/pub/CPAN/src/${MY_P}.tar.gz"
HOMEPAGE="http://www.perl.org/"
LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
+
LICENSE="Artistic GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc sparc ~mips alpha ~arm hppa amd64 ~ia64 ~ppc64 s390"
+KEYWORDS="x86 ppc ~sparc ~mips ~alpha ~arm ~hppa amd64 ~ia64 ~ppc64 ~s390 ~sh"
IUSE="berkdb debug doc gdbm ithreads perlsuid uclibc"
+PERL_OLDVERSEN="5.8.2 5.8.4"
DEPEND="!uclibc? ( sys-apps/groff )
berkdb? ( sys-libs/db )
- gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ gdbm? ( >=sys-libs/gdbm-1.8.3 )
>=sys-apps/portage-2.0.48-r4
>=sys-devel/libperl-${PV}
!<dev-perl/ExtUtils-MakeMaker-6.17
@@ -29,7 +31,7 @@ DEPEND="!uclibc? ( sys-apps/groff )
!<dev-perl/Test-Simple-0.47-r1"
RDEPEND=">=sys-devel/libperl-${PV}
berkdb? ( sys-libs/db )
- gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+ gdbm? ( >=sys-libs/gdbm-1.8.3 )"
pkg_setup() {
# I think this should rather be displayed if you *have* 'ithreads'
@@ -102,9 +104,26 @@ src_unpack() {
# uclibc support
epatch ${FILESDIR}/perl-5.8.2-uclibc.patch
+ # this one only affects sparc64, as best weeve and rac can tell,
+ # but seems sane for all linux. we don't have to worry about
+ # drifting into obscure SysV non-posix semantics, and the current
+ # code in IO.xs that checks for this sort of thing dies in LDAP on
+ # sparc64.
+
+ epatch ${FILESDIR}/${P}-nonblock.patch
+
+ # since we build in non-world-writeable portage directories, none
+ # of the .t sections of the original version of this patch matter
+ # much. the PPPort section is apparently obsolete, because i see
+ # no /tmp in there now. ditto on perlbug.SH, which has secure
+ # tempfile handling if resources are present. originally from bug
+ # 66360.
+
+ epatch ${FILESDIR}/${P}-tempfiles.patch
}
-src_compile() {
+src_configure() {
+
# some arches and -O do not mix :)
use arm && replace-flags -O? -O1
use ppc && replace-flags -O? -O1
@@ -127,28 +146,27 @@ src_compile() {
myarch="${CHOST%%-*}-linux"
fi
+ local inclist=$(for v in $PERL_OLDVERSEN; do echo -n "$v $v/$myarch "; done)
+
+ # allow either gdbm to provide ndbm (in <gdbm/ndbm.h>) or db1
+
+ myndbm='U'
+ mygdbm='U'
+ mydb='U'
+
if use gdbm
then
- myconf="${myconf} -Di_gdbm"
+ mygdbm='D'
+ myndbm='D'
fi
if use berkdb
then
- myconf="${myconf} -Di_db"
-
- # ndbm.h is only provided by db1 (and perhaps by gdbm in
- # error). an alternate approach here would be to check for the
- # presence (or some string therein) of /usr/include/ndbm.h
- # itself.
-
- if has_version '=sys-libs/db-1*'
- then
- myconf="${myconf} -Di_ndbm"
- else
- myconf="${myconf} -Ui_ndbm"
- fi
- else
- myconf="${myconf} -Ui_db -Ui_ndbm"
+ mydb='D'
+ has_version '=sys-libs/db-1*' && myndbm='D'
fi
+
+ myconf="${myconf} -${myndbm}i_ndbm -${mygdbm}i_gdbm -${mydb}i_db"
+
if use mips
then
# this is needed because gcc 3.3-compiled kernels will hang
@@ -181,13 +199,6 @@ src_compile() {
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
- # These are temporary fixes. Need to edit the build so that that libraries created
- # only get compiled with -fPIC, since they get linked into shared objects, they
- # must be compiled with -fPIC. Don't have time to parse through the build system
- # at this time.
-# [ "${ARCH}" = "hppa" ] && append-flags -fPIC
-# [ "${ARCH}" = "amd64" ] && append-flags -fPIC
-
sh Configure -des \
-Darchname="${myarch}" \
-Dcccdlflags='-fPIC' \
@@ -201,17 +212,31 @@ src_compile() {
-Duselargefiles \
-Dd_semctl_semun \
-Dscriptdir=/usr/bin \
+ -Dman1dir=/usr/share/man/man1 \
+ -Dman3dir=/usr/share/man/man3 \
+ -Dinstallman1dir=${D}/usr/share/man/man1 \
+ -Dinstallman3dir=${D}/usr/share/man/man3 \
+ -Dman1ext='1' \
-Dman3ext='3pm' \
+ -Dinc_version_list="$inclist" \
-Dcf_by='Gentoo' \
-Ud_csh \
${myconf} || die "Unable to configure"
+}
- MAKEOPTS="${MAKEOPTS} -j1" emake || die "Unable to make"
+src_compile() {
- if ! hasq maketest $RESTRICT; then
- use uclibc && export MAKEOPTS="${MAKEOPTS} -j1"
- emake -i test CCDLFLAGS=
- fi
+ # would like to bracket this with a test for the existence of a
+ # dotfile, but can't clean it automatically now.
+
+ src_configure
+
+ emake -j1 || die "Unable to make"
+}
+
+src_test() {
+ use uclibc && export MAKEOPTS="${MAKEOPTS} -j1"
+ emake -i test CCDLFLAGS= || die "test failed"
}
src_install() {
@@ -229,10 +254,23 @@ src_install() {
# Fix for "stupid" modules and programs
dodir /usr/lib/perl5/site_perl/${PV}/${myarch}${mythreading}
- make DESTDIR="${D}" \
- INSTALLMAN1DIR="${D}/usr/share/man/man1" \
- INSTALLMAN3DIR="${D}/usr/share/man/man3" \
- install || die "Unable to make install"
+ make DESTDIR="${D}" install || die "Unable to make install"
+
+ # 2004.07.28 rac
+
+ # suidperl has had a history of security trouble, and the
+ # perldelta has recommended against using it for a while. genone
+ # alerted me to the fact that the hardlinks aren't carrying
+ # through the staging directory, and we end up with four copies of
+ # perl, basically. two normal, two suid. fix this up here, and
+ # delete suidperl entirely. if this causes outrage, here's where
+ # to fix.
+
+ # Moved to a use flag enablement - bug 64823 - mcummings
+ #rm ${D}/usr/bin/sperl${PV}
+ #rm ${D}/usr/bin/suidperl
+ rm ${D}/usr/bin/perl
+ ln -s perl${PV} ${D}/usr/bin/perl
cp -f utils/h2ph utils/h2ph_patched
epatch ${FILESDIR}/perl-5.8.0-RC2-special-h2ph-not-failing-on-machine_ansi_header.patch
@@ -263,13 +301,6 @@ EOF
dosed 's:./miniperl:/usr/bin/perl:' /usr/bin/xsubpp
fperms 0755 /usr/bin/xsubpp
- if ! hasq noman $FEATURES; then
- # executing a binary we just built is not very cross
- # compiler friendly.
- ./perl installman \
- --destdir="${D}" --man1ext='1' --man3ext='3'
- fi
-
# This removes ${D} from Config.pm and .packlist
for i in `find ${D} -iname "Config.pm"` `find ${D} -iname ".packlist"`;do
einfo "Removing ${D} from ${i}..."
diff --git a/dev-lang/perl/perl-5.8.6-r1.ebuild b/dev-lang/perl/perl-5.8.6-r1.ebuild
new file mode 100644
index 000000000000..506a0eeefecb
--- /dev/null
+++ b/dev-lang/perl/perl-5.8.6-r1.ebuild
@@ -0,0 +1,383 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.6-r1.ebuild,v 1.1 2004/12/04 20:14:30 rac Exp $
+
+inherit eutils flag-o-matic gcc
+
+# The slot of this binary compat version of libperl.so
+PERLSLOT="1"
+
+SHORT_PV="${PV%.*}"
+MY_P="perl-${PV/_rc/-RC}"
+DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="ftp://ftp.perl.org/pub/CPAN/src/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.perl.org/"
+LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390 ~sh"
+IUSE="berkdb debug doc gdbm ithreads perlsuid uclibc"
+PERL_OLDVERSEN="5.8.2 5.8.4 5.8.5"
+
+DEPEND="!uclibc? ( sys-apps/groff )
+ berkdb? ( sys-libs/db )
+ gdbm? ( >=sys-libs/gdbm-1.8.3 )
+ >=sys-apps/portage-2.0.48-r4
+ >=sys-devel/libperl-${PV}
+ !<dev-perl/ExtUtils-MakeMaker-6.17
+ !<dev-perl/File-Spec-0.87
+ !<dev-perl/Test-Simple-0.47-r1"
+RDEPEND=">=sys-devel/libperl-${PV}
+ berkdb? ( sys-libs/db )
+ gdbm? ( >=sys-libs/gdbm-1.8.3 )"
+
+pkg_setup() {
+ # I think this should rather be displayed if you *have* 'ithreads'
+ # in USE if it could break things ...
+ if use ithreads
+ then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
+ ewarn "interpreter-level threading enabled."
+ ewarn "Threading is not supported by all applications "
+ ewarn "that compile against perl. You use threading at "
+ ewarn "your own discretion. "
+ ewarn ""
+ epause 10
+ else
+ ewarn ""
+ ewarn "PLEASE NOTE: If you want to compile perl-5.8 with"
+ ewarn "threading enabled , you must restart this emerge"
+ ewarn "with USE=ithreads emerge...."
+ ewarn "Threading is not supported by all applications "
+ ewarn "that compile against perl. You use threading at "
+ ewarn "your own discretion. "
+ ewarn ""
+ fi
+
+ if [ ! -f "${ROOT}/usr/lib/${LIBPERL}" ]
+ then
+ # Make sure we have libperl installed ...
+ eerror "Cannot find ${ROOT}/usr/lib/${LIBPERL}! Make sure that you"
+ eerror "have sys-libs/libperl installed properly ..."
+ die "Cannot find /usr/lib/${LIBPERL}!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Get -lpthread linked before -lc. This is needed
+ # when using glibc >= 2.3, or else runtime signal
+ # handling breaks. Fixes bug #14380.
+ # <rac@gentoo.org> (14 Feb 2003)
+ # reinstated to try to avoid sdl segfaults 03.10.02
+ cd ${S}; epatch ${FILESDIR}/${P}-prelink-lpthread.patch
+
+ # Patch perldoc to not abort when it attempts to search
+ # nonexistent directories; fixes bug #16589.
+ # <rac@gentoo.org> (28 Feb 2003)
+
+ cd ${S}; epatch ${FILESDIR}/${P}-perldoc-emptydirs.patch
+
+ # this lays the groundwork for solving the issue of what happens
+ # when people (or ebuilds) install different versiosn of modules
+ # that are in the core, by rearranging the @INC directory to look
+ # site -> vendor -> core.
+ cd ${S}; epatch ${FILESDIR}/${P}-reorder-INC.patch
+
+ # some well-intentioned stuff in http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&selm=Pine.SOL.4.10.10205231231200.5399-100000%40maxwell.phys.lafayette.edu
+ # attempts to avoid bringing cccdlflags to bear on static
+ # extensions (like DynaLoader). i believe this is
+ # counterproductive on a Gentoo system which has both a shared
+ # and static libperl, so effectively revert this here.
+ cd ${S}; epatch ${FILESDIR}/${P}-picdl.patch
+
+ # Configure makes an unwarranted assumption that /bin/ksh is a
+ # good shell. This patch makes it revert to using /bin/sh unless
+ # /bin/ksh really is executable. Should fix bug 42665.
+ # rac 2004.06.09
+ cd ${S}; epatch ${FILESDIR}/${P}-noksh.patch
+
+ # uclibc support
+ epatch ${FILESDIR}/perl-5.8.2-uclibc.patch
+
+ # this one only affects sparc64, as best weeve and rac can tell,
+ # but seems sane for all linux. we don't have to worry about
+ # drifting into obscure SysV non-posix semantics, and the current
+ # code in IO.xs that checks for this sort of thing dies in LDAP on
+ # sparc64.
+
+ #epatch ${FILESDIR}/${P}-nonblock.patch
+
+ # since we build in non-world-writeable portage directories, none
+ # of the .t sections of the original version of this patch matter
+ # much. the PPPort section is apparently obsolete, because i see
+ # no /tmp in there now. ditto on perlbug.SH, which has secure
+ # tempfile handling if resources are present. originally from bug
+ # 66360.
+
+ epatch ${FILESDIR}/${P}-tempfiles.patch
+}
+
+src_configure() {
+
+ # some arches and -O do not mix :)
+ use arm && replace-flags -O? -O1
+ use ppc && replace-flags -O? -O1
+ use ia64 && replace-flags -O? -O1
+ # Perl has problems compiling with -Os in your flags with glibc
+ use uclibc || replace-flags "-Os" "-O2"
+ # This flag makes compiling crash in interesting ways
+ filter-flags -malign-double
+
+ export LC_ALL="C"
+ local myconf=""
+
+ if use ithreads
+ then
+ einfo "using ithreads"
+ mythreading="-multi"
+ myconf="-Dusethreads ${myconf}"
+ myarch="${CHOST%%-*}-linux-thread"
+ else
+ myarch="${CHOST%%-*}-linux"
+ fi
+
+ local inclist=$(for v in $PERL_OLDVERSEN; do echo -n "$v $v/$myarch "; done)
+
+ # allow either gdbm to provide ndbm (in <gdbm/ndbm.h>) or db1
+
+ myndbm='U'
+ mygdbm='U'
+ mydb='U'
+
+ if use gdbm
+ then
+ mygdbm='D'
+ myndbm='D'
+ fi
+ if use berkdb
+ then
+ mydb='D'
+ has_version '=sys-libs/db-1*' && myndbm='D'
+ fi
+
+ myconf="${myconf} -${myndbm}i_ndbm -${mygdbm}i_gdbm -${mydb}i_db"
+
+ if use mips
+ then
+ # this is needed because gcc 3.3-compiled kernels will hang
+ # the machine trying to run this test - check with `Kumba
+ # <rac@gentoo.org> 2003.06.26
+ myconf="${myconf} -Dd_u32align"
+ fi
+
+ if use perlsuid
+ then
+ myconf="${myconf} -Dd_dosuid"
+ ewarn "You have enabled Perl's suid compile. Please"
+ ewarn "read http://perldoc.com/perl5.8.2/INSTALL.html#suidperl"
+ epause 3
+ fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
+ if use sparc
+ then
+ myconf="${myconf} -Ud_longdbl"
+ fi
+
+ if use alpha && "$(gcc-getCC)" == "ccc"
+ then
+ ewarn "Perl will not be built with berkdb support, use gcc if you needed it..."
+ myconf="${myconf} -Ui_db -Ui_ndbm"
+ fi
+
+ sh Configure -des \
+ -Darchname="${myarch}" \
+ -Dcccdlflags='-fPIC' \
+ -Dccdlflags='-rdynamic' \
+ -Dcc="${CC:-gcc}" \
+ -Dprefix='/usr' \
+ -Dvendorprefix='/usr' \
+ -Dsiteprefix='/usr' \
+ -Dlocincpth=' ' \
+ -Doptimize="${CFLAGS}" \
+ -Duselargefiles \
+ -Dd_semctl_semun \
+ -Dscriptdir=/usr/bin \
+ -Dman1dir=/usr/share/man/man1 \
+ -Dman3dir=/usr/share/man/man3 \
+ -Dinstallman1dir=${D}/usr/share/man/man1 \
+ -Dinstallman3dir=${D}/usr/share/man/man3 \
+ -Dman1ext='1' \
+ -Dman3ext='3pm' \
+ -Dinc_version_list="$inclist" \
+ -Dcf_by='Gentoo' \
+ -Ud_csh \
+ ${myconf} || die "Unable to configure"
+}
+
+src_compile() {
+
+ # would like to bracket this with a test for the existence of a
+ # dotfile, but can't clean it automatically now.
+
+ src_configure
+
+ emake -j1 || die "Unable to make"
+}
+
+src_test() {
+ use uclibc && export MAKEOPTS="${MAKEOPTS} -j1"
+ emake -i test CCDLFLAGS= || die "test failed"
+}
+
+src_install() {
+
+ export LC_ALL="C"
+
+ # Need to do this, else apps do not link to dynamic version of
+ # the library ...
+ local coredir="/usr/lib/perl5/${PV}/${myarch}${mythreading}/CORE"
+ dodir ${coredir}
+ dosym ../../../../${LIBPERL} ${coredir}/${LIBPERL}
+ dosym ../../../../${LIBPERL} ${coredir}/libperl.so.${PERLSLOT}
+ dosym ../../../../${LIBPERL} ${coredir}/libperl.so
+
+ # Fix for "stupid" modules and programs
+ dodir /usr/lib/perl5/site_perl/${PV}/${myarch}${mythreading}
+
+ make DESTDIR="${D}" install || die "Unable to make install"
+
+ # 2004.07.28 rac
+
+ # suidperl has had a history of security trouble, and the
+ # perldelta has recommended against using it for a while. genone
+ # alerted me to the fact that the hardlinks aren't carrying
+ # through the staging directory, and we end up with four copies of
+ # perl, basically. two normal, two suid. fix this up here, and
+ # delete suidperl entirely. if this causes outrage, here's where
+ # to fix.
+
+ # Moved to a use flag enablement - bug 64823 - mcummings
+ #rm ${D}/usr/bin/sperl${PV}
+ #rm ${D}/usr/bin/suidperl
+ rm ${D}/usr/bin/perl
+ ln -s perl${PV} ${D}/usr/bin/perl
+
+ cp -f utils/h2ph utils/h2ph_patched
+ epatch ${FILESDIR}/perl-5.8.0-RC2-special-h2ph-not-failing-on-machine_ansi_header.patch
+
+ LD_LIBRARY_PATH=. ./perl -Ilib utils/h2ph_patched \
+ -a -d ${D}/usr/lib/perl5/${PV}/${myarch}${mythreading} <<EOF
+asm/termios.h
+syscall.h
+syslimits.h
+syslog.h
+sys/ioctl.h
+sys/socket.h
+sys/time.h
+wait.h
+EOF
+
+ # This is to fix a missing c flag for backwards compat
+ for i in `find ${D}/usr/lib/perl5 -iname "Config.pm"`;do
+ sed -e "s:ccflags=':ccflags='-DPERL5 :" \
+ -e "s:cppflags=':cppflags='-DPERL5 :" \
+ ${i} > ${i}.new &&\
+ mv ${i}.new ${i} || die "Sed failed"
+ done
+
+ # A poor fix for the miniperl issues
+ dosed 's:./miniperl:/usr/bin/perl:' /usr/lib/perl5/${PV}/ExtUtils/xsubpp
+ fperms 0444 /usr/lib/perl5/${PV}/ExtUtils/xsubpp
+ dosed 's:./miniperl:/usr/bin/perl:' /usr/bin/xsubpp
+ fperms 0755 /usr/bin/xsubpp
+
+ # This removes ${D} from Config.pm and .packlist
+ for i in `find ${D} -iname "Config.pm"` `find ${D} -iname ".packlist"`;do
+ einfo "Removing ${D} from ${i}..."
+ sed -e "s:${D}::" ${i} > ${i}.new &&\
+ mv ${i}.new ${i} || die "Sed failed"
+ done
+
+ # Note: find out from psm why we would need/want this.
+ # ( use berkdb && has_version '=sys-libs/db-1*' ) ||
+ # find ${D} -name "*NDBM*" | xargs rm -f
+
+ dodoc Changes* Artistic Copying README Todo* AUTHORS
+
+ if use doc
+ then
+ # HTML Documentation
+ # We expect errors, warnings, and such with the following.
+
+ dodir /usr/share/doc/${PF}/html
+ ./perl installhtml \
+ --podroot='.' \
+ --podpath='lib:ext:pod:vms' \
+ --recurse \
+ --htmldir="${D}/usr/share/doc/${PF}/html" \
+ --libpods='perlfunc:perlguts:perlvar:perlrun:perlop'
+ fi
+}
+
+pkg_postinst() {
+
+ # Make sure we do not have stale/invalid libperl.so 's ...
+ if [ -f "${ROOT}usr/lib/libperl.so" -a ! -L "${ROOT}usr/lib/libperl.so" ]
+ then
+ mv -f ${ROOT}usr/lib/libperl.so ${ROOT}usr/lib/libperl.so.old
+ fi
+
+ local perllib="`readlink -f ${ROOT}usr/lib/libperl.so | sed -e 's:^.*/::'`"
+
+ # If we are installing perl, we need the /usr/lib/libperl.so symlink to
+ # point to the version of perl we are running, else builing something
+ # against libperl.so will break ...
+ if [ "${perllib}" != "${LIBPERL}" ]
+ then
+ # Delete stale symlinks
+ rm -f ${ROOT}usr/lib/libperl.so
+ rm -f ${ROOT}usr/lib/libperl.so.${PERLSLOT}
+ # Regenerate libperl.so.${PERLSLOT}
+ ln -snf ${LIBPERL} ${ROOT}usr/lib/libperl.so.${PERLSLOT}
+ # Create libperl.so (we use the *soname* versioned lib here ..)
+ ln -snf libperl.so.${PERLSLOT} ${ROOT}usr/lib/libperl.so
+ fi
+
+ if [ "${ROOT}" = "/" ]
+ then
+ ebegin "Converting C header files to the corresponding Perl format"
+ cd /usr/include; h2ph * sys/* arpa/* netinet/* bits/* security/* asm/*
+ fi
+
+ eerror ""
+ eerror "If this is an upgrade to a perl 5.6.1 system,"
+ eerror "~OR~ an upgrade to a previous Gentoo release"
+ eerror "of perl 5.8.0, prior to -r8 "
+ eerror "you may need to recompile applications that"
+ eerror "were emerged against the old libperl.so"
+ eerror ""
+ eerror "${FILESDIR}/libperl_rebuilder "
+ eerror "is provided to assist with this. "
+ eerror "PLEASE DO NOT INTERRUPT THE RUNNING OF THIS SCRIPT."
+ eerror "Part of the rebuilding of applications compiled against "
+ eerror "your old libperl involves temporarily unmerging"
+ eerror "them - interruptions could leave you with unmerged"
+ eerror "packages before they can be remerged."
+ eerror ""
+ eerror "If you have run the rebuilder and a package still gives"
+ eerror "you trouble, and re-emerging it fails to correct"
+ eerror "the problem, please check http://bugs.gentoo.org/"
+ eerror "for more information or to report a bug."
+ eerror ""
+ eerror ""
+}