summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2006-12-01 10:38:55 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2006-12-01 10:38:55 +0000
commit26a9db059753e7e50468e73f8f26bfe48eddd58a (patch)
tree14153b2ff6ccad0aa359d062b8543250ec8b1817 /dev-lang
parentAdd extra slmodemd options (#156457). (diff)
downloadgentoo-2-26a9db059753e7e50468e73f8f26bfe48eddd58a.tar.gz
gentoo-2-26a9db059753e7e50468e73f8f26bfe48eddd58a.tar.bz2
gentoo-2-26a9db059753e7e50468e73f8f26bfe48eddd58a.zip
tweaking a bit bug #17808
(Portage version: 2.1.2_rc2-r3)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gnu-smalltalk/ChangeLog6
-rw-r--r--dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.1.122
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.12.ebuild11
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-2.2-r1.ebuild11
4 files changed, 13 insertions, 17 deletions
diff --git a/dev-lang/gnu-smalltalk/ChangeLog b/dev-lang/gnu-smalltalk/ChangeLog
index 24f6e6ce279f..932e9d42e5b3 100644
--- a/dev-lang/gnu-smalltalk/ChangeLog
+++ b/dev-lang/gnu-smalltalk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/gnu-smalltalk
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.19 2006/11/29 15:47:50 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.20 2006/12/01 10:38:55 araujo Exp $
+
+ 01 Dec 2006; Luis F. Araujo <araujo@gentoo.org>
+ gnu-smalltalk-2.1.12.ebuild, gnu-smalltalk-2.2-r1.ebuild:
+ Tweaking a bit the tcltk -> tcl, tk use flag bug #17808
29 Nov 2006; Christian Faulhammer <opfer@gentoo.org>
gnu-smalltalk-2.1.12.ebuild, gnu-smalltalk-2.2-r1.ebuild:
diff --git a/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.1.12 b/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.1.12
index 276964978ea5..c6181b441016 100644
--- a/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.1.12
+++ b/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.1.12
@@ -1 +1,3 @@
MD5 209219aea25b11d516256f24af97e5ad smalltalk-2.1.12.tar.gz 3336852
+RMD160 2ede388e0ce5e463b00f24a23b3c9f423729f2fa smalltalk-2.1.12.tar.gz 3336852
+SHA256 4201a9803036c12b8e7d0432c418ee0f778f7e93130d36f4f4b6a3f68d3183a0 smalltalk-2.1.12.tar.gz 3336852
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.12.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.12.ebuild
index c369e05d674d..c4748ad51abf 100644
--- a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.12.ebuild
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.12.ebuild,v 1.5 2006/11/29 15:47:50 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.12.ebuild,v 1.6 2006/12/01 10:38:55 araujo Exp $
inherit elisp-common flag-o-matic eutils toolchain-funcs
@@ -32,19 +32,14 @@ src_unpack() {
}
src_compile() {
- local myconf=""
- if use tk; then
- myconf="
- `use_with tcltk tcl=/usr/lib` \
- `use_with tcltk tk=/usr/lib`"
- fi
replace-flags '-O3' '-O2'
./configure --prefix=/usr \
`use_with emacs emacs` \
`use_with readline readline` \
`use_with gmp gmp` \
+ `use_with tk tcl=/usr/lib` \
+ `use_with tk tk=/usr/lib` \
`use_enable gtk gtk` \
- ${myconf} \
|| die
emake || die "emake failed"
use emacs && elisp-compile *.el
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.2-r1.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.2-r1.ebuild
index 48fd922d73e7..01e8c5c5b05f 100644
--- a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.2-r1.ebuild
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.2-r1.ebuild,v 1.2 2006/11/29 15:47:50 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.2-r1.ebuild,v 1.3 2006/12/01 10:38:55 araujo Exp $
inherit elisp-common flag-o-matic eutils toolchain-funcs
@@ -34,19 +34,14 @@ src_unpack() {
}
src_compile() {
- local myconf=""
- if use tk; then
- myconf="
- `use_with tcltk tcl=/usr/lib` \
- `use_with tcltk tk=/usr/lib`"
- fi
replace-flags '-O3' '-O2'
./configure --prefix=/usr \
`use_with emacs emacs` \
`use_with readline readline` \
`use_with gmp gmp` \
+ `use_with tk tcl=/usr/lib` \
+ `use_with tk tk=/usr/lib` \
`use_enable gtk gtk` \
- ${myconf} \
|| die
emake || die "emake failed"
use emacs && elisp-compile *.el