summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-10 17:18:13 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-10 17:18:13 +0000
commit8bedf199980508cf27dabcac687636c0885a613e (patch)
treeee8af6f8aa6d65aa4648e6ef293162323cdd8fee /dev-lang/tk
parentStable for ppc, wrt bug #455870 (diff)
downloadgentoo-2-8bedf199980508cf27dabcac687636c0885a613e.tar.gz
gentoo-2-8bedf199980508cf27dabcac687636c0885a613e.tar.bz2
gentoo-2-8bedf199980508cf27dabcac687636c0885a613e.zip
dev-lang/tk: Drop old fixes #280934
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'dev-lang/tk')
-rw-r--r--dev-lang/tk/ChangeLog6
-rw-r--r--dev-lang/tk/tk-8.4.19-r1.ebuild117
-rw-r--r--dev-lang/tk/tk-8.5.11-r1.ebuild129
-rw-r--r--dev-lang/tk/tk-8.5.13.ebuild133
4 files changed, 5 insertions, 380 deletions
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index 341a09fe6fcc..a468ef6bc3dd 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/tk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.181 2013/01/13 21:54:44 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.182 2013/02/10 17:18:13 jlec Exp $
+
+ 10 Feb 2013; Justin Lecher <jlec@gentoo.org> -tk-8.4.19-r1.ebuild,
+ -tk-8.5.11-r1.ebuild, -tk-8.5.13.ebuild:
+ Drop old fixes #280934
13 Jan 2013; Fabian Groffen <grobian@gentoo.org> tk-8.6.0.ebuild:
Fix building on Darwin (or other platforms that have -Os in tcl.m4), bug
diff --git a/dev-lang/tk/tk-8.4.19-r1.ebuild b/dev-lang/tk/tk-8.4.19-r1.ebuild
deleted file mode 100644
index 46a042780e95..000000000000
--- a/dev-lang/tk/tk-8.4.19-r1.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.19-r1.ebuild,v 1.6 2012/12/05 08:51:37 ulm Exp $
-
-inherit autotools eutils multilib toolchain-funcs
-
-DESCRIPTION="Tk Widget Set"
-HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
-SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
-
-LICENSE="tcltk"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug threads"
-
-RDEPEND="x11-libs/libX11
- ~dev-lang/tcl-${PV}"
-DEPEND="${RDEPEND}
- x11-libs/libXt
- >=x11-proto/xproto-7.0.13"
-
-S=${WORKDIR}/${PN}${PV}
-
-pkg_setup() {
- if use threads ; then
- ewarn ""
- ewarn "PLEASE NOTE: You are compiling ${P} with"
- ewarn "threading enabled."
- ewarn "Threading is not supported by all applications"
- ewarn "that compile against tcl. You use threading at"
- ewarn "your own discretion."
- ewarn ""
- epause 5
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/remove-control-v-8.4.9.diff
- epatch "${FILESDIR}"/${PN}-8.4.9-man.patch
- epatch "${FILESDIR}"/${PN}-8.4.11-multilib.patch
-
- # Bug 125971
- epatch "${FILESDIR}"/${PN}-8.4.15-tclm4-soname.patch
-
- # Bug 225999
- epatch "${FILESDIR}"/${PN}-8.4-lastevent.patch
-
- local d
- for d in */configure ; do
- cd "${S}"/${d%%/*}
- EPATCH_SINGLE_MSG="Patching nls cruft in ${d}" \
- epatch "${FILESDIR}"/tk-configure-LANG.patch
- done
-
- cd "${S}"/unix
- eautoreconf
-}
-
-src_compile() {
- tc-export CC
- cd "${S}"/unix
-
- local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
-
- econf \
- --with-tcl=/usr/${mylibdir} \
- $(use_enable threads) \
- $(use_enable debug symbols)
-
- emake || die
-}
-
-src_install() {
- #short version number
- local v1
- v1=${PV%.*}
-
- cd "${S}"/unix
- make DESTDIR="${D}" install || die
-
- # fix the tkConfig.sh to eliminate refs to the build directory
- local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
- sed -i \
- -e "s,^\(TK_BUILD_LIB_SPEC='-L\)${S}/unix,\1/usr/${mylibdir}," \
- -e "s,^\(TK_SRC_DIR='\)${S}',\1/usr/${mylibdir}/tk${v1}/include'," \
- -e "s,^\(TK_BUILD_STUB_LIB_SPEC='-L\)${S}/unix,\1/usr/${mylibdir}," \
- -e "s,^\(TK_BUILD_STUB_LIB_PATH='\)${S}/unix,\1/usr/${mylibdir}," \
- -e "s,^\(TK_CC_SEARCH_FLAGS='.*\)',\1:/usr/${mylibdir}'," \
- -e "s,^\(TK_LD_SEARCH_FLAGS='.*\)',\1:/usr/${mylibdir}'," \
- "${D}"/usr/${mylibdir}/tkConfig.sh || die
-
- # install private headers
- insinto /usr/${mylibdir}/tk${v1}/include/unix
- doins "${S}"/unix/*.h || die
- insinto /usr/${mylibdir}/tk${v1}/include/generic
- doins "${S}"/generic/*.h || die
- rm -f "${D}"/usr/${mylibdir}/tk${v1}/include/generic/tk.h
- rm -f "${D}"/usr/${mylibdir}/tk${v1}/include/generic/tkDecls.h
- rm -f "${D}"/usr/${mylibdir}/tk${v1}/include/generic/tkPlatDecls.h
-
- # install symlink for libraries
- #dosym libtk${v1}.a /usr/${mylibdir}/libtk.a
- if use debug ; then
- dosym libtk${v1}g.so /usr/${mylibdir}/libtk${v1}.so
- dosym libtkstub${v1}g.a /usr/${mylibdir}/libtkstub${v1}.a
- dosym ../tk${v1}g/pkgIndex.tcl /usr/${mylibdir}/tk${v1}/pkgIndex.tcl
- fi
- dosym libtk${v1}.so /usr/${mylibdir}/libtk.so
- dosym libtkstub${v1}.a /usr/${mylibdir}/libtkstub.a
-
- dosym wish${v1} /usr/bin/wish
-
- cd "${S}"
- dodoc ChangeLog README changes license.terms
-}
diff --git a/dev-lang/tk/tk-8.5.11-r1.ebuild b/dev-lang/tk/tk-8.5.11-r1.ebuild
deleted file mode 100644
index e68c46c00101..000000000000
--- a/dev-lang/tk/tk-8.5.11-r1.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.11-r1.ebuild,v 1.4 2012/12/05 08:51:37 ulm Exp $
-
-EAPI=4
-
-inherit autotools eutils multilib toolchain-funcs prefix
-
-MY_P="${PN}${PV/_beta/b}"
-
-DESCRIPTION="Tk Widget Set"
-HOMEPAGE="http://www.tcl.tk/"
-SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
-
-LICENSE="tcltk"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug threads truetype aqua xscreensaver"
-
-RDEPEND="
- !aqua? (
- media-libs/fontconfig
- x11-libs/libX11
- x11-libs/libXt
- truetype? ( x11-libs/libXft )
- xscreensaver? ( x11-libs/libXScrnSaver )
- )
- ~dev-lang/tcl-${PV}"
-DEPEND="${RDEPEND}
- !aqua? ( x11-proto/xproto )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-fedora-xft.patch
- epatch "${FILESDIR}"/${PN}-8.4.11-multilib.patch
-
- epatch "${FILESDIR}"/${PN}-8.4.15-aqua.patch
- eprefixify unix/Makefile.in
-
- # Bug 125971
- epatch "${FILESDIR}"/${PN}-8.5_alpha6-tclm4-soname.patch
-
- # Bug 354067 : the same applies to tk, since the patch is about tcl.m4, just
- # copy the tcl patch
- epatch "${FILESDIR}"/tcl-8.5.9-gentoo-fbsd.patch
-
- # Bug 441630
- epatch "${FILESDIR}"/${PN}-8.5.11-fix-name-collision-uclibc.patch
-
- # Make sure we use the right pkg-config, and link against fontconfig
- # (since the code base uses Fc* functions).
- sed -i \
- -e 's/FT_New_Face/XftFontOpen/g' \
- -e "s:\<pkg-config\>:$(tc-getPKG_CONFIG):" \
- -e 's:xft freetype2:xft freetype2 fontconfig:' \
- unix/configure.in || die
-
- cd "${S}"/unix
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- cd "${S}"/unix
-
- local mylibdir=$(get_libdir)
-
- econf \
- --with-tcl="${EPREFIX}/usr/${mylibdir}" \
- $(use_enable threads) \
- $(use_enable aqua) \
- $(use_enable truetype xft) \
- $(use_enable xscreensaver xss) \
- $(use_enable debug symbols)
-}
-
-src_compile() {
- cd "${S}"/unix && emake
-}
-
-src_install() {
- #short version number
- local v1
- v1=${PV%.*}
-
- cd "${S}"/unix
- S= emake DESTDIR="${D}" install
-
- # normalize $S path, bug #280766 (pkgcore)
- local nS="$(cd "${S}"; pwd)"
-
- # fix the tkConfig.sh to eliminate refs to the build directory
- local mylibdir=$(get_libdir); mylibdir=${mylibdir//\/}
- sed -i \
- -e "s,^TK_BUILD_LIB_SPEC='-L.*/unix ,TK_BUILD_LIB_SPEC='," \
- -e "s,^TK_SRC_DIR='.*',TK_SRC_DIR='${EPREFIX}/usr/${mylibdir}/tk${v1}/include'," \
- -e "s,^TK_BUILD_STUB_LIB_SPEC='-L.*/unix ,TK_BUILD_STUB_LIB_SPEC='," \
- -e "s,^TK_BUILD_STUB_LIB_PATH='.*/unix,TK_BUILD_STUB_LIB_PATH='${EPREFIX}/usr/${mylibdir}," \
- -e "s,^TK_LIB_FILE='libtk${v1}..TK_DBGX..so',TK_LIB_FILE=\"libtk${v1}\$\{TK_DBGX\}.so\"," \
- -e "s,^TK_STUB_LIB_SPEC='-L${EPREFIX}/usr/${mylibdir} ,TK_STUB_LIB_SPEC='," \
- -e "s,^TK_LIB_SPEC='-L${EPREFIX}/usr/${mylibdir} ,TK_LIB_SPEC='," \
- "${ED}"/usr/${mylibdir}/tkConfig.sh || die
- if [[ ${CHOST} != *-darwin* && ${CHOST} != *-mint* ]] ; then
- sed -i \
- -e "s,^\(TK_CC_SEARCH_FLAGS='.*\)',\1:${EPREFIX}/usr/${mylibdir}'," \
- -e "s,^\(TK_LD_SEARCH_FLAGS='.*\)',\1:${EPREFIX}/usr/${mylibdir}'," \
- "${ED}"/usr/${mylibdir}/tkConfig.sh || die
- fi
-
- # install private headers
- insinto /usr/${mylibdir}/tk${v1}/include/unix
- doins "${S}"/unix/*.h
- insinto /usr/${mylibdir}/tk${v1}/include/generic
- doins "${S}"/generic/*.h
- rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tk.h
- rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tkDecls.h
- rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tkPlatDecls.h
-
- # install symlink for libraries
- #dosym libtk${v1}.a /usr/${mylibdir}/libtk.a
- dosym libtk${v1}$(get_libname) /usr/${mylibdir}/libtk$(get_libname)
- dosym libtkstub${v1}.a /usr/${mylibdir}/libtkstub.a
-
- dosym wish${v1} /usr/bin/wish
-
- cd "${S}"
- dodoc ChangeLog* README changes
-}
diff --git a/dev-lang/tk/tk-8.5.13.ebuild b/dev-lang/tk/tk-8.5.13.ebuild
deleted file mode 100644
index d49444ea8367..000000000000
--- a/dev-lang/tk/tk-8.5.13.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.13.ebuild,v 1.4 2013/01/09 16:36:07 jlec Exp $
-
-EAPI=4
-
-inherit autotools eutils multilib prefix toolchain-funcs virtualx
-
-MY_P="${PN}${PV/_beta/b}"
-
-DESCRIPTION="Tk Widget Set"
-HOMEPAGE="http://www.tcl.tk/"
-SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
-
-LICENSE="tcltk"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug threads truetype aqua xscreensaver"
-
-RDEPEND="
- !aqua? (
- media-libs/fontconfig
- x11-libs/libX11
- x11-libs/libXt
- truetype? ( x11-libs/libXft )
- xscreensaver? ( x11-libs/libXScrnSaver )
- )
- ~dev-lang/tcl-${PV}"
-DEPEND="${RDEPEND}
- !aqua? ( x11-proto/xproto )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- tc-export CC
-
- epatch \
- "${FILESDIR}"/${PN}-8.5.11-fedora-xft.patch \
- "${FILESDIR}"/${P}-multilib.patch
-
- epatch "${FILESDIR}"/${PN}-8.4.15-aqua.patch
- eprefixify unix/Makefile.in
-
- # Bug 125971
- epatch "${FILESDIR}"/${PN}-8.5.10-conf.patch
-
- # Bug 354067 : the same applies to tk, since the patch is about tcl.m4, just
- # copy the tcl patch
- epatch "${FILESDIR}"/tcl-8.5.9-gentoo-fbsd.patch
-
- # Make sure we use the right pkg-config, and link against fontconfig
- # (since the code base uses Fc* functions).
- sed \
- -e 's/FT_New_Face/XftFontOpen/g' \
- -e "s:\<pkg-config\>:$(tc-getPKG_CONFIG):" \
- -e 's:xft freetype2:xft freetype2 fontconfig:' \
- -i unix/configure.in || die
- rm -f unix/configure || die
-
- cd "${S}"/unix
- eautoreconf
-}
-
-src_configure() {
- cd "${S}"/unix
-
- local mylibdir=$(get_libdir)
-
- econf \
- --with-tcl="${EPREFIX}/usr/${mylibdir}" \
- $(use_enable threads) \
- $(use_enable aqua) \
- $(use_enable truetype xft) \
- $(use_enable xscreensaver xss) \
- $(use_enable debug symbols)
-}
-
-src_compile() {
- cd "${S}"/unix && emake
-}
-
-src_test() {
- cd "${S}"/unix && Xemake test
-}
-
-src_install() {
- #short version number
- local v1
- v1=${PV%.*}
-
- cd "${S}"/unix
- S= emake DESTDIR="${D}" install
-
- # normalize $S path, bug #280766 (pkgcore)
- local nS="$(cd "${S}"; pwd)"
-
- # fix the tkConfig.sh to eliminate refs to the build directory
- local mylibdir=$(get_libdir); mylibdir=${mylibdir//\/}
- sed -i \
- -e "s,^TK_BUILD_LIB_SPEC='-L.*/unix ,TK_BUILD_LIB_SPEC='," \
- -e "s,^TK_SRC_DIR='.*',TK_SRC_DIR='${EPREFIX}/usr/${mylibdir}/tk${v1}/include'," \
- -e "s,^TK_BUILD_STUB_LIB_SPEC='-L.*/unix ,TK_BUILD_STUB_LIB_SPEC='," \
- -e "s,^TK_BUILD_STUB_LIB_PATH='.*/unix,TK_BUILD_STUB_LIB_PATH='${EPREFIX}/usr/${mylibdir}," \
- -e "s,^TK_LIB_FILE='libtk${v1}..TK_DBGX..so',TK_LIB_FILE=\"libtk${v1}\$\{TK_DBGX\}.so\"," \
- -e "s,^TK_STUB_LIB_SPEC='-L${EPREFIX}/usr/${mylibdir} ,TK_STUB_LIB_SPEC='," \
- -e "s,^TK_LIB_SPEC='-L${EPREFIX}/usr/${mylibdir} ,TK_LIB_SPEC='," \
- "${ED}"/usr/${mylibdir}/tkConfig.sh || die
- if [[ ${CHOST} != *-darwin* && ${CHOST} != *-mint* ]] ; then
- sed -i \
- -e "s,^\(TK_CC_SEARCH_FLAGS='.*\)',\1:${EPREFIX}/usr/${mylibdir}'," \
- -e "s,^\(TK_LD_SEARCH_FLAGS='.*\)',\1:${EPREFIX}/usr/${mylibdir}'," \
- "${ED}"/usr/${mylibdir}/tkConfig.sh || die
- fi
-
- # install private headers
- insinto /usr/${mylibdir}/tk${v1}/include/unix
- doins "${S}"/unix/*.h
- insinto /usr/${mylibdir}/tk${v1}/include/generic
- doins "${S}"/generic/*.h
- rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tk.h
- rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tkDecls.h
- rm -f "${ED}"/usr/${mylibdir}/tk${v1}/include/generic/tkPlatDecls.h
-
- # install symlink for libraries
- #dosym libtk${v1}.a /usr/${mylibdir}/libtk.a
- dosym libtk${v1}$(get_libname) /usr/${mylibdir}/libtk$(get_libname)
- dosym libtkstub${v1}.a /usr/${mylibdir}/libtkstub.a
-
- dosym wish${v1} /usr/bin/wish
-
- cd "${S}"
- dodoc ChangeLog* README changes
-}