summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-05-18 02:12:11 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-05-18 02:12:11 +0000
commit615c74affa9056b4fb8c9ab0bf07b400299219bc (patch)
tree6fe60bd5cb6cc6551821b90ed0a8235b6584e2c8 /dev-lang/parrot
parentSet the ssp_nonshared LDADD in its bootstrapping function. Add it only with U... (diff)
downloadgentoo-2-615c74affa9056b4fb8c9ab0bf07b400299219bc.tar.gz
gentoo-2-615c74affa9056b4fb8c9ab0bf07b400299219bc.tar.bz2
gentoo-2-615c74affa9056b4fb8c9ab0bf07b400299219bc.zip
Bump
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/parrot')
-rw-r--r--dev-lang/parrot/ChangeLog7
-rw-r--r--dev-lang/parrot/parrot-4.4.0.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
index 5ee983dfced6..02ff6e623f62 100644
--- a/dev-lang/parrot/ChangeLog
+++ b/dev-lang/parrot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/parrot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.53 2012/04/20 08:52:36 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.54 2012/05/18 02:12:11 patrick Exp $
+
+*parrot-4.4.0 (18 May 2012)
+
+ 18 May 2012; Patrick Lauer <patrick@gentoo.org> +parrot-4.4.0.ebuild:
+ Bump
*parrot-4.3.0 (20 Apr 2012)
diff --git a/dev-lang/parrot/parrot-4.4.0.ebuild b/dev-lang/parrot/parrot-4.4.0.ebuild
new file mode 100644
index 000000000000..e19a10ce9e13
--- /dev/null
+++ b/dev-lang/parrot/parrot-4.4.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-4.4.0.ebuild,v 1.1 2012/05/18 02:12:11 patrick Exp $
+
+EAPI=3
+
+# There's multiple small issues at the moment, so ...
+RESTRICT="test"
+
+inherit eutils multilib
+
+DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
+HOMEPAGE="http://www.parrot.org/"
+SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
+
+RDEPEND="sys-libs/readline
+ opengl? ( media-libs/freeglut )
+ nls? ( sys-devel/gettext )
+ unicode? ( >=dev-libs/icu-2.6 )
+ gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
+ gmp? ( >=dev-libs/gmp-4.1.4 )
+ ssl? ( dev-libs/openssl )
+ pcre? ( dev-libs/libpcre )"
+
+DEPEND="dev-lang/perl[doc?]
+ ${RDEPEND}"
+
+src_prepare() {
+ # Fix for #404195 - pcre detection is wonky
+ sed -i 's:libpcre.so.0:libpcre.so.1:' runtime/parrot/library/pcre.pir || die "Couldn't fix pcre location"
+}
+
+src_configure() {
+ myconf="--disable-rpath"
+ use unicode || myconf+=" --without-icu"
+ use ssl || myconf+=" --without-crypto"
+ use gdbm || myconf+=" --without-gdbm"
+ use nls || myconf+=" --without-gettext"
+ use gmp || myconf+=" --without-gmp"
+ use opengl || myconf+=" --without-opengl"
+ use pcre || myconf+=" --without-pcre"
+
+ perl Configure.pl \
+ --ccflags="${CFLAGS}" \
+ --linkflags="${LDFLAGS}" \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --mandir="${EPREFIX}"/usr/share/man \
+ --sysconfdir="${EPREFIX}"/etc \
+ --sharedstatedir="${EPREFIX}"/var/lib/parrot \
+ $myconf || die
+}
+
+src_compile() {
+ export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
+ # occasionally dies in parallel make
+ emake -j1 || die
+ if use doc ; then
+ emake -j1 html || die
+ fi
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
+ dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins -r examples/* || die
+ fi
+ if use doc; then
+ insinto "/usr/share/doc/${PF}/editor"
+ doins -r editor || die
+ cd docs/html
+ dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
+ pmc.html tools.html docs src tools || die
+ fi
+}