summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-09-14 22:52:42 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-09-14 22:52:42 +0000
commit0512a298bec71db70badfea88f0caecdcd31c749 (patch)
tree1d22f24f5df08b13958aeb38ea376137eb2a7ef0 /dev-lang/ocaml
parentAdd -fno-strict-aliasing for python2. (diff)
downloadgentoo-2-0512a298bec71db70badfea88f0caecdcd31c749.tar.gz
gentoo-2-0512a298bec71db70badfea88f0caecdcd31c749.tar.bz2
gentoo-2-0512a298bec71db70badfea88f0caecdcd31c749.zip
remove old
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/ocaml-4.00.0.ebuild127
-rw-r--r--dev-lang/ocaml/ocaml-4.00.1.ebuild122
-rw-r--r--dev-lang/ocaml/ocaml-4.01.0_beta1.ebuild125
-rw-r--r--dev-lang/ocaml/ocaml-4.01.0_rc1.ebuild125
5 files changed, 5 insertions, 500 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 1b156dc17ffd..2b0b56880b6a 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.216 2013/09/14 22:49:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.217 2013/09/14 22:52:42 aballier Exp $
+
+ 14 Sep 2013; Alexis Ballier <aballier@gentoo.org> -ocaml-4.00.0.ebuild,
+ -ocaml-4.00.1.ebuild, -ocaml-4.01.0_beta1.ebuild, -ocaml-4.01.0_rc1.ebuild:
+ remove old
*ocaml-4.01.0 (14 Sep 2013)
diff --git a/dev-lang/ocaml/ocaml-4.00.0.ebuild b/dev-lang/ocaml/ocaml-4.00.0.ebuild
deleted file mode 100644
index a0f99c48623c..000000000000
--- a/dev-lang/ocaml/ocaml-4.00.0.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-4.00.0.ebuild,v 1.1 2012/07/27 00:27:01 aballier Exp $
-
-EAPI="1"
-
-inherit flag-o-matic eutils multilib versionator toolchain-funcs
-
-PATCHLEVEL="4"
-MY_P="${P/_/+}"
-DESCRIPTION="Fast modern type-inferring functional programming language descended from the ML family"
-HOMEPAGE="http://www.ocaml.org/"
-SRC_URI="ftp://ftp.inria.fr/INRIA/Projects/cristal/ocaml/ocaml-$(get_version_component_range 1-2)/${MY_P}.tar.bz2
- mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
-
-LICENSE="QPL-1.0 LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="emacs latex ncurses +ocamlopt tk X xemacs"
-
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
- ncurses? ( sys-libs/ncurses )
- X? ( x11-libs/libX11 x11-proto/xproto )"
-RDEPEND="${DEPEND}"
-
-PDEPEND="emacs? ( app-emacs/ocaml-mode )
- xemacs? ( app-xemacs/ocaml )"
-
-S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- # dev-lang/ocaml creates its own objects but calls gcc for linking, which will
- # results in relocations if gcc wants to create a PIE executable
- if gcc-specs-pie ; then
- append-ldflags -nopie
- ewarn "Ocaml generates its own native asm, you're using a PIE compiler"
- ewarn "We have appended -nopie to ocaml build options"
- ewarn "because linking an executable with pie while the objects are not pic will not work"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
-}
-
-src_compile() {
- export LC_ALL=C
- local myconf=""
-
- # Causes build failures because it builds some programs with -pg,
- # bug #270920
- filter-flags -fomit-frame-pointer
- # Bug #285993
- filter-mfpmath sse
-
- # It doesn't compile on alpha without this LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- use tk || myconf="${myconf} -no-tk"
- use ncurses || myconf="${myconf} -no-curses"
- use X || myconf="${myconf} -no-graph"
-
- # ocaml uses a home-brewn configure script, preventing it to use econf.
- RAW_LDFLAGS="$(raw-ldflags)" ./configure -prefix /usr \
- --bindir /usr/bin \
- --libdir /usr/$(get_libdir)/ocaml \
- --mandir /usr/share/man \
- -host "${CHOST}" \
- -cc "$(tc-getCC)" \
- -as "$(tc-getAS)" \
- -aspp "$(tc-getCC) -c" \
- -partialld "$(tc-getLD) -r" \
- --with-pthread ${myconf} || die "configure failed!"
-
- emake -j1 world || die "make world failed!"
-
- # Native code generation can be disabled now
- if use ocamlopt ; then
- # bug #279968
- emake -j1 opt || die "make opt failed!"
- emake -j1 opt.opt || die "make opt.opt failed!"
- fi
-}
-
-src_install() {
- make BINDIR="${D}"/usr/bin \
- LIBDIR="${D}"/usr/$(get_libdir)/ocaml \
- MANDIR="${D}"/usr/share/man \
- install || die "make install failed!"
-
- # Install the compiler libs
- dodir /usr/$(get_libdir)/ocaml/compiler-libs
- insinto /usr/$(get_libdir)/ocaml/compiler-libs
- doins {utils,typing,parsing}/*.{mli,cmi,cmo}
- use ocamlopt && doins {utils,typing,parsing}/*.{cmx,o}
-
- # Symlink the headers to the right place
- dodir /usr/include
- dosym /usr/$(get_libdir)/ocaml/caml /usr/include/
-
- # Remove ${D} from ld.conf, as the buildsystem isn't $(DESTDIR) aware
- dosed "s:${D}::g" /usr/$(get_libdir)/ocaml/ld.conf
-
- dodoc Changes INSTALL README Upgrading
-
- # Create and envd entry for latex input files (this definitely belongs into
- # CONTENT and not in pkg_postinst.
- if use latex ; then
- echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > "${T}"/99ocamldoc
- doenvd "${T}"/99ocamldoc
- fi
-
- # Install ocaml-rebuild portage set
- insinto /usr/share/portage/config/sets
- doins "${FILESDIR}/ocaml.conf" || die
-}
-
-pkg_postinst() {
- echo
- ewarn "OCaml is not binary compatible from version to version, so you"
- ewarn "need to rebuild all packages depending on it, that are actually"
- ewarn "installed on your system. To do so, you can run:"
- ewarn "emerge @ocaml-rebuild"
- ewarn "Or, (almost) equivalently: emerge -1 /usr/$(get_libdir)/ocaml"
- echo
-}
diff --git a/dev-lang/ocaml/ocaml-4.00.1.ebuild b/dev-lang/ocaml/ocaml-4.00.1.ebuild
deleted file mode 100644
index 6f433645e59a..000000000000
--- a/dev-lang/ocaml/ocaml-4.00.1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-4.00.1.ebuild,v 1.4 2013/02/18 18:09:14 aballier Exp $
-
-EAPI="5"
-
-inherit flag-o-matic eutils multilib versionator toolchain-funcs
-
-PATCHLEVEL="4"
-MY_P="${P/_/+}"
-DESCRIPTION="Fast modern type-inferring functional programming language descended from the ML family"
-HOMEPAGE="http://www.ocaml.org/"
-SRC_URI="ftp://ftp.inria.fr/INRIA/Projects/cristal/ocaml/ocaml-$(get_version_component_range 1-2)/${MY_P}.tar.bz2
- mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
-
-LICENSE="QPL-1.0 LGPL-2"
-# Everytime ocaml is updated to a new version, everything ocaml must be rebuilt,
-# so here we go with the subslot.
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="emacs latex ncurses +ocamlopt tk X xemacs"
-
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
- ncurses? ( sys-libs/ncurses )
- X? ( x11-libs/libX11 x11-proto/xproto )"
-RDEPEND="${DEPEND}"
-
-PDEPEND="emacs? ( app-emacs/ocaml-mode )
- xemacs? ( app-xemacs/ocaml )"
-
-S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- # dev-lang/ocaml creates its own objects but calls gcc for linking, which will
- # results in relocations if gcc wants to create a PIE executable
- if gcc-specs-pie ; then
- append-ldflags -nopie
- ewarn "Ocaml generates its own native asm, you're using a PIE compiler"
- ewarn "We have appended -nopie to ocaml build options"
- ewarn "because linking an executable with pie while the objects are not pic will not work"
- fi
-}
-
-src_prepare() {
- EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
-}
-
-src_configure() {
- export LC_ALL=C
- local myconf=""
-
- # Causes build failures because it builds some programs with -pg,
- # bug #270920
- filter-flags -fomit-frame-pointer
- # Bug #285993
- filter-mfpmath sse
-
- # It doesn't compile on alpha without this LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- use tk || myconf="${myconf} -no-tk"
- use ncurses || myconf="${myconf} -no-curses"
- use X || myconf="${myconf} -no-graph"
-
- # ocaml uses a home-brewn configure script, preventing it to use econf.
- RAW_LDFLAGS="$(raw-ldflags)" ./configure -prefix /usr \
- --bindir /usr/bin \
- --libdir /usr/$(get_libdir)/ocaml \
- --mandir /usr/share/man \
- -host "${CHOST}" \
- -cc "$(tc-getCC)" \
- -as "$(tc-getAS)" \
- -aspp "$(tc-getCC) -c" \
- -partialld "$(tc-getLD) -r" \
- --with-pthread ${myconf} || die "configure failed!"
-}
-
-src_compile() {
- emake -j1 world
-
- # Native code generation can be disabled now
- if use ocamlopt ; then
- # bug #279968
- emake -j1 opt
- emake -j1 opt.opt
- fi
-}
-
-src_install() {
- make BINDIR="${D}"/usr/bin \
- LIBDIR="${D}"/usr/$(get_libdir)/ocaml \
- MANDIR="${D}"/usr/share/man \
- install
-
- # Symlink the headers to the right place
- dodir /usr/include
- dosym /usr/$(get_libdir)/ocaml/caml /usr/include/
-
- dodoc Changes INSTALL README Upgrading
-
- # Create and envd entry for latex input files
- if use latex ; then
- echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > "${T}"/99ocamldoc
- doenvd "${T}"/99ocamldoc
- fi
-
- # Install ocaml-rebuild portage set
- insinto /usr/share/portage/config/sets
- doins "${FILESDIR}/ocaml.conf"
-}
-
-pkg_postinst() {
- echo
- ewarn "OCaml is not binary compatible from version to version, so you"
- ewarn "need to rebuild all packages depending on it, that are actually"
- ewarn "installed on your system. To do so, you can run:"
- if has_version '>=sys-apps/portage-2.2' ; then
- ewarn "emerge @ocaml-rebuild"
- else
- ewarn "emerge -1 /usr/$(get_libdir)/ocaml"
- fi
- echo
-}
diff --git a/dev-lang/ocaml/ocaml-4.01.0_beta1.ebuild b/dev-lang/ocaml/ocaml-4.01.0_beta1.ebuild
deleted file mode 100644
index 32d42e2db322..000000000000
--- a/dev-lang/ocaml/ocaml-4.01.0_beta1.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-4.01.0_beta1.ebuild,v 1.1 2013/08/16 00:28:28 aballier Exp $
-
-EAPI="5"
-
-inherit flag-o-matic eutils multilib versionator toolchain-funcs
-
-PATCHLEVEL="6"
-MY_P="${P/_/+}"
-DESCRIPTION="Fast modern type-inferring functional programming language descended from the ML family"
-HOMEPAGE="http://www.ocaml.org/"
-SRC_URI="ftp://ftp.inria.fr/INRIA/Projects/cristal/ocaml/ocaml-$(get_version_component_range 1-2)/${MY_P}.tar.bz2
- mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
-
-LICENSE="QPL-1.0 LGPL-2"
-# Everytime ocaml is updated to a new version, everything ocaml must be rebuilt,
-# so here we go with the subslot.
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="emacs latex ncurses +ocamlopt tk X xemacs"
-
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
- ncurses? ( sys-libs/ncurses )
- X? ( x11-libs/libX11 x11-proto/xproto )"
-RDEPEND="${DEPEND}"
-
-PDEPEND="emacs? ( app-emacs/ocaml-mode )
- xemacs? ( app-xemacs/ocaml )"
-
-S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- # dev-lang/ocaml creates its own objects but calls gcc for linking, which will
- # results in relocations if gcc wants to create a PIE executable
- if gcc-specs-pie ; then
- append-ldflags -nopie
- ewarn "Ocaml generates its own native asm, you're using a PIE compiler"
- ewarn "We have appended -nopie to ocaml build options"
- ewarn "because linking an executable with pie while the objects are not pic will not work"
- fi
-}
-
-src_prepare() {
- EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
-}
-
-src_configure() {
- export LC_ALL=C
- local myconf=""
-
- # Causes build failures because it builds some programs with -pg,
- # bug #270920
- filter-flags -fomit-frame-pointer
- # Bug #285993
- filter-mfpmath sse
-
- # It doesn't compile on alpha without this LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- use tk || myconf="${myconf} -no-tk"
- use ncurses || myconf="${myconf} -no-curses"
- use X || myconf="${myconf} -no-graph"
-
- # ocaml uses a home-brewn configure script, preventing it to use econf.
- RAW_LDFLAGS="$(raw-ldflags)" ./configure -prefix /usr \
- --bindir /usr/bin \
- --libdir /usr/$(get_libdir)/ocaml \
- --mandir /usr/share/man \
- -host "${CHOST}" \
- -cc "$(tc-getCC)" \
- -as "$(tc-getAS)" \
- -aspp "$(tc-getCC) -c" \
- -partialld "$(tc-getLD) -r" \
- --with-pthread ${myconf} || die "configure failed!"
-
- # http://caml.inria.fr/mantis/view.php?id=4698
- export CCLINKFLAGS="${LDFLAGS}"
-}
-
-src_compile() {
- emake -j1 world
-
- # Native code generation can be disabled now
- if use ocamlopt ; then
- # bug #279968
- emake -j1 opt
- emake -j1 opt.opt
- fi
-}
-
-src_install() {
- make BINDIR="${D}"/usr/bin \
- LIBDIR="${D}"/usr/$(get_libdir)/ocaml \
- MANDIR="${D}"/usr/share/man \
- install
-
- # Symlink the headers to the right place
- dodir /usr/include
- dosym /usr/$(get_libdir)/ocaml/caml /usr/include/caml
-
- dodoc Changes INSTALL README
-
- # Create and envd entry for latex input files
- if use latex ; then
- echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > "${T}"/99ocamldoc
- doenvd "${T}"/99ocamldoc
- fi
-
- # Install ocaml-rebuild portage set
- insinto /usr/share/portage/config/sets
- doins "${FILESDIR}/ocaml.conf"
-}
-
-pkg_postinst() {
- echo
- ewarn "OCaml is not binary compatible from version to version, so you"
- ewarn "need to rebuild all packages depending on it, that are actually"
- ewarn "installed on your system. To do so, you can run:"
- if has_version '>=sys-apps/portage-2.2' ; then
- ewarn "emerge @ocaml-rebuild"
- else
- ewarn "emerge -1 /usr/$(get_libdir)/ocaml"
- fi
- echo
-}
diff --git a/dev-lang/ocaml/ocaml-4.01.0_rc1.ebuild b/dev-lang/ocaml/ocaml-4.01.0_rc1.ebuild
deleted file mode 100644
index 1ac6579923a3..000000000000
--- a/dev-lang/ocaml/ocaml-4.01.0_rc1.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-4.01.0_rc1.ebuild,v 1.1 2013/09/03 18:16:13 aballier Exp $
-
-EAPI="5"
-
-inherit flag-o-matic eutils multilib versionator toolchain-funcs
-
-PATCHLEVEL="6"
-MY_P="${P/_/+}"
-DESCRIPTION="Fast modern type-inferring functional programming language descended from the ML family"
-HOMEPAGE="http://www.ocaml.org/"
-SRC_URI="ftp://ftp.inria.fr/INRIA/Projects/cristal/ocaml/ocaml-$(get_version_component_range 1-2)/${MY_P}.tar.bz2
- mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
-
-LICENSE="QPL-1.0 LGPL-2"
-# Everytime ocaml is updated to a new version, everything ocaml must be rebuilt,
-# so here we go with the subslot.
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="emacs latex ncurses +ocamlopt tk X xemacs"
-
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
- ncurses? ( sys-libs/ncurses )
- X? ( x11-libs/libX11 x11-proto/xproto )"
-RDEPEND="${DEPEND}"
-
-PDEPEND="emacs? ( app-emacs/ocaml-mode )
- xemacs? ( app-xemacs/ocaml )"
-
-S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- # dev-lang/ocaml creates its own objects but calls gcc for linking, which will
- # results in relocations if gcc wants to create a PIE executable
- if gcc-specs-pie ; then
- append-ldflags -nopie
- ewarn "Ocaml generates its own native asm, you're using a PIE compiler"
- ewarn "We have appended -nopie to ocaml build options"
- ewarn "because linking an executable with pie while the objects are not pic will not work"
- fi
-}
-
-src_prepare() {
- EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
-}
-
-src_configure() {
- export LC_ALL=C
- local myconf=""
-
- # Causes build failures because it builds some programs with -pg,
- # bug #270920
- filter-flags -fomit-frame-pointer
- # Bug #285993
- filter-mfpmath sse
-
- # It doesn't compile on alpha without this LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- use tk || myconf="${myconf} -no-tk"
- use ncurses || myconf="${myconf} -no-curses"
- use X || myconf="${myconf} -no-graph"
-
- # ocaml uses a home-brewn configure script, preventing it to use econf.
- RAW_LDFLAGS="$(raw-ldflags)" ./configure -prefix /usr \
- --bindir /usr/bin \
- --libdir /usr/$(get_libdir)/ocaml \
- --mandir /usr/share/man \
- -host "${CHOST}" \
- -cc "$(tc-getCC)" \
- -as "$(tc-getAS)" \
- -aspp "$(tc-getCC) -c" \
- -partialld "$(tc-getLD) -r" \
- --with-pthread ${myconf} || die "configure failed!"
-
- # http://caml.inria.fr/mantis/view.php?id=4698
- export CCLINKFLAGS="${LDFLAGS}"
-}
-
-src_compile() {
- emake -j1 world
-
- # Native code generation can be disabled now
- if use ocamlopt ; then
- # bug #279968
- emake -j1 opt
- emake -j1 opt.opt
- fi
-}
-
-src_install() {
- make BINDIR="${D}"/usr/bin \
- LIBDIR="${D}"/usr/$(get_libdir)/ocaml \
- MANDIR="${D}"/usr/share/man \
- install
-
- # Symlink the headers to the right place
- dodir /usr/include
- dosym /usr/$(get_libdir)/ocaml/caml /usr/include/caml
-
- dodoc Changes INSTALL README
-
- # Create and envd entry for latex input files
- if use latex ; then
- echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > "${T}"/99ocamldoc
- doenvd "${T}"/99ocamldoc
- fi
-
- # Install ocaml-rebuild portage set
- insinto /usr/share/portage/config/sets
- doins "${FILESDIR}/ocaml.conf"
-}
-
-pkg_postinst() {
- echo
- ewarn "OCaml is not binary compatible from version to version, so you"
- ewarn "need to rebuild all packages depending on it, that are actually"
- ewarn "installed on your system. To do so, you can run:"
- if has_version '>=sys-apps/portage-2.2' ; then
- ewarn "emerge @ocaml-rebuild"
- else
- ewarn "emerge -1 /usr/$(get_libdir)/ocaml"
- fi
- echo
-}