summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2010-08-26 07:29:04 +0000
committerKeri Harris <keri@gentoo.org>2010-08-26 07:29:04 +0000
commit0512a80f192ae085f7418235b335f256262b1789 (patch)
tree71f434570f48f8c6d996c688e792c60e9daf489c /dev-lang/mozart
parentuse an existing compiler (diff)
downloadgentoo-2-0512a80f192ae085f7418235b335f256262b1789.tar.gz
gentoo-2-0512a80f192ae085f7418235b335f256262b1789.tar.bz2
gentoo-2-0512a80f192ae085f7418235b335f256262b1789.zip
Mozart ozbison QA tidyups; mention Mozart tests can only be run single-threaded
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/mozart')
-rw-r--r--dev-lang/mozart/ChangeLog7
-rw-r--r--dev-lang/mozart/files/mozart-1.4.0-ozbison-string.patch33
-rw-r--r--dev-lang/mozart/mozart-1.4.0.ebuild4
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-lang/mozart/ChangeLog b/dev-lang/mozart/ChangeLog
index d72246c48c65..b78a78d72ca2 100644
--- a/dev-lang/mozart/ChangeLog
+++ b/dev-lang/mozart/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mozart
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/ChangeLog,v 1.27 2010/08/25 19:06:53 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/ChangeLog,v 1.28 2010/08/26 07:29:03 keri Exp $
+
+ 26 Aug 2010; <keri@gentoo.org> mozart-1.4.0.ebuild,
+ +files/mozart-1.4.0-ozbison-string.patch:
+ Mozart ozbison QA tidyups; mention Mozart tests can only be run
+ single-threaded
25 Aug 2010; <keri@gentoo.org> mozart-1.4.0.ebuild,
+files/mozart-1.4.0-dss-ldflags.patch:
diff --git a/dev-lang/mozart/files/mozart-1.4.0-ozbison-string.patch b/dev-lang/mozart/files/mozart-1.4.0-ozbison-string.patch
new file mode 100644
index 000000000000..1965b60496b1
--- /dev/null
+++ b/dev-lang/mozart/files/mozart-1.4.0-ozbison-string.patch
@@ -0,0 +1,33 @@
+diff -ur mozart-1.4.0.20080704.orig/platform/tools/gump/ozbison/conflicts.c mozart-1.4.0.20080704/platform/tools/gump/ozbison/conflicts.c
+--- mozart-1.4.0.20080704.orig/platform/tools/gump/ozbison/conflicts.c 1998-12-17 02:55:09.000000000 +1300
++++ mozart-1.4.0.20080704/platform/tools/gump/ozbison/conflicts.c 2010-08-25 20:00:30.000000000 +1200
+@@ -18,6 +18,7 @@
+ the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA. */
+
+ #include <stdio.h>
++#include <string.h>
+ #include "system.h"
+ #include "machine.h"
+ #include "new.h"
+diff -ur mozart-1.4.0.20080704.orig/platform/tools/gump/ozbison/print.c mozart-1.4.0.20080704/platform/tools/gump/ozbison/print.c
+--- mozart-1.4.0.20080704.orig/platform/tools/gump/ozbison/print.c 1998-02-07 00:31:08.000000000 +1300
++++ mozart-1.4.0.20080704/platform/tools/gump/ozbison/print.c 2010-08-25 20:00:14.000000000 +1200
+@@ -19,6 +19,7 @@
+
+
+ #include <stdio.h>
++#include <string.h>
+ #include "system.h"
+ #include "machine.h"
+ #include "new.h"
+diff -ur mozart-1.4.0.20080704.orig/platform/tools/gump/ozbison/symtab.c mozart-1.4.0.20080704/platform/tools/gump/ozbison/symtab.c
+--- mozart-1.4.0.20080704.orig/platform/tools/gump/ozbison/symtab.c 1998-02-07 00:31:08.000000000 +1300
++++ mozart-1.4.0.20080704/platform/tools/gump/ozbison/symtab.c 2010-08-25 19:59:28.000000000 +1200
+@@ -19,6 +19,7 @@
+
+
+ #include <stdio.h>
++#include <string.h>
+ #include "system.h"
+ #include "new.h"
+ #include "symtab.h"
diff --git a/dev-lang/mozart/mozart-1.4.0.ebuild b/dev-lang/mozart/mozart-1.4.0.ebuild
index ce1e92391439..d7aed8c58286 100644
--- a/dev-lang/mozart/mozart-1.4.0.ebuild
+++ b/dev-lang/mozart/mozart-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/mozart-1.4.0.ebuild,v 1.8 2010/08/25 19:06:53 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/mozart-1.4.0.ebuild,v 1.9 2010/08/26 07:29:03 keri Exp $
inherit elisp-common eutils
@@ -48,6 +48,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-dss-pic.patch
epatch "${FILESDIR}"/${P}-dss-ldflags.patch
epatch "${FILESDIR}"/${P}-dss-libpath.patch
+ epatch "${FILESDIR}"/${P}-ozbison-string.patch
epatch "${FILESDIR}"/${P}-nostrip.patch
}
@@ -79,6 +80,7 @@ src_compile() {
}
src_test() {
+ # Mozart tests must be run single-threaded
cd "${S}"/share/test
emake -j1 boot-oztest || die "emake boot-oztest failed"
emake -j1 boot-check || die "emake boot-check failed"