summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-05-09 10:31:07 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-05-09 10:31:07 +0000
commitdd9ceefa13185ff8ce969f488d12cf08b86f0f78 (patch)
treeb32a97866daac0395c7b252c82c1e5849e42fc85 /dev-lang/helium/helium-1.1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-dd9ceefa13185ff8ce969f488d12cf08b86f0f78.tar.gz
gentoo-2-dd9ceefa13185ff8ce969f488d12cf08b86f0f78.tar.bz2
gentoo-2-dd9ceefa13185ff8ce969f488d12cf08b86f0f78.zip
new ebuild: Helium, a Haskell-related language with excellent error reporting
Diffstat (limited to 'dev-lang/helium/helium-1.1.ebuild')
-rw-r--r--dev-lang/helium/helium-1.1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-lang/helium/helium-1.1.ebuild b/dev-lang/helium/helium-1.1.ebuild
new file mode 100644
index 000000000000..d44f7569352a
--- /dev/null
+++ b/dev-lang/helium/helium-1.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/helium/helium-1.1.ebuild,v 1.1 2003/05/09 10:31:07 kosmikus Exp $
+
+DESCRIPTION="Helium (for learning Haskell)"
+SRC_URI="http://www.cs.uu.nl/~afie/helium/distr/${P}-src.tar.gz
+ http://www.cs.uu.nl/~afie/helium/distr/Hint.jar"
+HOMEPAGE="http://www.cs.uu.nl/~afie/helium"
+
+DEPEND="virtual/glibc
+ dev-lang/ghc
+ readline? ( sys-libs/readline )"
+RDEPEND="virtual/glibc
+ virtual/jdk
+ dev-libs/gmp
+ readline? ( sys-libs/readline )"
+
+IUSE="readline"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+src_unpack() {
+ unpack ${P}-src.tar.gz
+
+ # patch for readline support if requested
+ if [ "`use readline`" ]; then
+ patch -p0 -i ${FILESDIR}/${P}-readline.patch || die
+ fi
+}
+
+src_compile() {
+ pushd lvm || die
+ pushd src || die
+ ./configure
+ popd
+ popd
+ pushd heliumNT || die
+ econf --without-upx
+ pushd src || die
+ make depend || die
+ make || die # emake doesn't work safely
+}
+
+src_install() {
+ cd heliumNT/src || die
+ make prefix=${D}/usr \
+ bindir=${D}/usr/lib/helium/bin \
+ libdir=${D}/usr/lib/helium/lib \
+ demodir=${D}/usr/lib/helium/demo \
+ install || die
+ # install hint
+ dojar ${DISTDIR}/Hint.jar
+ # create wrappers
+ dobin ${FILESDIR}/helium-wrapper
+ dosym /usr/bin/helium-wrapper /usr/bin/helium
+ dosym /usr/bin/helium-wrapper /usr/bin/lvmrun
+ dosym /usr/bin/helium-wrapper /usr/bin/texthint
+ dosym /usr/bin/helium-wrapper /usr/bin/hint
+}
+
+pkg_postinst() {
+ einfo "hi is now called texthint"
+ einfo "hint is a new GUI-based interpreter"
+}