summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2010-07-09 15:03:24 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2010-07-09 15:03:24 +0000
commit539a7f64c70c7fa3492ca65415e12c6d3b39f5de (patch)
treeaaf312023bf939c3df9c48d668ea8d2ddcb6f5b3 /dev-lang/ghc/ghc-6.12.3.ebuild
parentmarked ~ia64 (diff)
downloadgentoo-2-539a7f64c70c7fa3492ca65415e12c6d3b39f5de.tar.gz
gentoo-2-539a7f64c70c7fa3492ca65415e12c6d3b39f5de.tar.bz2
gentoo-2-539a7f64c70c7fa3492ca65415e12c6d3b39f5de.zip
Marked ~ia64 (as now we have ia64 binaries for ghc)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ghc/ghc-6.12.3.ebuild')
-rw-r--r--dev-lang/ghc/ghc-6.12.3.ebuild35
1 files changed, 21 insertions, 14 deletions
diff --git a/dev-lang/ghc/ghc-6.12.3.ebuild b/dev-lang/ghc/ghc-6.12.3.ebuild
index 9014f2d5aefd..652e5513487a 100644
--- a/dev-lang/ghc/ghc-6.12.3.ebuild
+++ b/dev-lang/ghc/ghc-6.12.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.12.3.ebuild,v 1.4 2010/07/07 22:18:57 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.12.3.ebuild,v 1.5 2010/07/09 15:03:24 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -38,20 +38,15 @@ arch_binaries=""
arch_binaries="$arch_binaries alpha? ( http://code.haskell.org/~slyfox/ghc-alpha/ghc-bin-${PV}-alpha.tbz2 )"
arch_binaries="$arch_binaries x86? ( mirror://gentoo/ghc-bin-${PV}-x86.tbz2 )"
arch_binaries="$arch_binaries amd64? ( mirror://gentoo/ghc-bin-${PV}-amd64.tbz2 )"
+arch_binaries="$arch_binaries ia64? ( http://code.haskell.org/~slyfox/ghc-ia64/ghc-bin-${PV}-ia64.tbz2 )"
#arch_binaries="$arch_binaries sparc? ( http://haskell.org/~duncan/ghc/ghc-bin-${PV}-sparc.tbz2 )"
arch_binaries="$arch_binaries ppc64? ( mirror://gentoo/ghc-bin-${PV}-ppc64.tbz2 )"
-#arch_binaries="$arch_binaries alpha? ( mirror://gentoo/ghc-bin-${PV}-alpha.tbz2 )"
-#arch_binaries="$arch_binaries amd64? ( mirror://gentoo/ghc-bin-${PV}-amd64.tbz2 )"
-#arch_binaries="$arch_binaries ia64? ( mirror://gentoo/ghc-bin-${PV}-ia64.tbz2 )"
-#arch_binaries="$arch_binaries sparc? ( mirror://gentoo/ghc-bin-${PV}-sparc.tbz2 )"
-#arch_binaries="$arch_binaries x86? ( mirror://gentoo/ghc-bin-${PV}-x86.tbz2 )"
-
SRC_URI="!binary? ( http://darcs.haskell.org/download/dist/${PV}/${P}-src.tar.bz2 )
!ghcbootstrap? ( $arch_binaries )"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc64 ~x86"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~x86"
IUSE="binary doc ghcbootstrap"
RDEPEND="
@@ -202,10 +197,15 @@ src_unpack() {
epatch "${FILESDIR}/ghc-6.12.1-configure-CHOST.patch"
epatch "${FILESDIR}/ghc-6.12.2-configure-CHOST-part2.patch"
+ # -r and --relax are incompatible
+ epatch "${FILESDIR}/ghc-6.12.3-ia64-fixed-relax.patch"
+
+ # prevent from wiping upper address bits used in cache lookup
+ epatch "${FILESDIR}/ghc-6.12.3-ia64-storage-manager-fix.patch"
+
# fixes build failure of adjustor code
epatch "${FILESDIR}/ghc-6.12.3-alpha-use-libffi-for-foreign-import-wrapper.patch"
-
- # as we have changed the build system with the readline patch
+ # as we have changed the build system
eautoreconf
fi
}
@@ -242,17 +242,24 @@ src_compile() {
# portage logging) reported as bug #111183
echo "SRC_HC_OPTS+=-w" >> mk/build.mk
- # GHC build system knows to build unregisterised on alpha,
- # but we have to tell it to build unregisterised on some arches
- # ppc64: EvilMangler currently does not understand some TOCs
+ # some arches do not support ELF parsing for ghci module loading
+ # PPC64: never worked (should be easy to implement)
+ # alpha: never worked
if use alpha || use ppc64; then
- echo "GhcUnregisterised=YES" >> mk/build.mk
echo "GhcWithInterpreter=NO" >> mk/build.mk
+ fi
+
+ # we have to tell it to build unregisterised on some arches
+ # ppc64: EvilMangler currently does not understand some TOCs
+ # ia64: EvilMangler bitrot
+ if use alpha || use hppa || use ia64 || use ppc64; then
+ echo "GhcUnregisterised=YES" >> mk/build.mk
echo "GhcWithNativeCodeGen=NO" >> mk/build.mk
echo "SplitObjs=NO" >> mk/build.mk
echo "GhcRTSWays := debug" >> mk/build.mk
echo "GhcNotThreaded=YES" >> mk/build.mk
fi
+
# Have "ld -r --relax" problem with split-objs on sparc:
if use sparc; then
echo "SplitObjs=NO" >> mk/build.mk