summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-08-26 02:46:16 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-08-26 02:46:16 +0000
commita0ddfa810f1b4446b56025f18c00a169f8e7c4ca (patch)
tree14f7e006620fa73081e35f3a0aa3429632ec9e3f /dev-lang/gdl/files
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-a0ddfa810f1b4446b56025f18c00a169f8e7c4ca.tar.gz
gentoo-2-a0ddfa810f1b4446b56025f18c00a169f8e7c4ca.tar.bz2
gentoo-2-a0ddfa810f1b4446b56025f18c00a169f8e7c4ca.zip
Version bump and fixed hdf5 issue (#275388) as well as collision with antlr (#267671).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/gdl/files')
-rw-r--r--dev-lang/gdl/files/gdl-0.9_rc2-antlr.patch40
-rw-r--r--dev-lang/gdl/files/gdl-0.9_rc2-gcc4.4.patch12
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-lang/gdl/files/gdl-0.9_rc2-antlr.patch b/dev-lang/gdl/files/gdl-0.9_rc2-antlr.patch
new file mode 100644
index 000000000000..b644eb2154df
--- /dev/null
+++ b/dev-lang/gdl/files/gdl-0.9_rc2-antlr.patch
@@ -0,0 +1,40 @@
+diff -Naur gdl-0.9rc2/configure.in gdl-0.9rc2.new/configure.in
+--- gdl-0.9rc2/configure.in 2009-01-22 17:31:48.000000000 -0500
++++ gdl-0.9rc2.new/configure.in 2009-08-25 18:38:10.000000000 -0400
+@@ -755,7 +755,7 @@
+ dnl perform program name transformation
+ dnl AC_ARG_PROGRAM
+
+-AC_CONFIG_FILES(Makefile src/Makefile src/antlr/Makefile)
++AC_CONFIG_FILES(Makefile src/Makefile)
+
+ AC_OUTPUT
+
+diff -Naur gdl-0.9rc2/src/Makefile.am gdl-0.9rc2.new/src/Makefile.am
+--- gdl-0.9rc2/src/Makefile.am 2009-01-20 14:33:56.000000000 -0500
++++ gdl-0.9rc2.new/src/Makefile.am 2009-08-25 21:36:55.000000000 -0400
+@@ -1,6 +1,6 @@
+ # set the include path found by configure
+ INCLUDES = $(EXT_INCLUDES) $(all_includes)
+-SUBDIRS = antlr
++SUBDIRS =
+ noinst_HEADERS = gdlwidget.hpp prognode.hpp prognodeexpr.hpp
+
+ cpp_hpp_files = accessdesc.hpp arrayindex.hpp assocdata.cpp assocdata.hpp \
+@@ -53,7 +53,7 @@
+ gdl_CXXFLAGS = $(AM_CXXFLAGS)
+ # the library search path.
+ gdl_LDFLAGS = $(all_libraries)
+-gdl_LDADD = $(top_builddir)/src/antlr/libantlr.a -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
++gdl_LDADD = -lantlr -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
+ endif
+
+ # build as library (for python module)
+@@ -69,6 +69,6 @@
+ libgdl_la_LDFLAGS = $(all_libraries) -Wl,-z,muldefs
+ endif
+
+-libgdl_la_LIBADD = $(top_builddir)/src/antlr/libantlr.la -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
++libgdl_la_LIBADD = -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
+ endif
+
diff --git a/dev-lang/gdl/files/gdl-0.9_rc2-gcc4.4.patch b/dev-lang/gdl/files/gdl-0.9_rc2-gcc4.4.patch
new file mode 100644
index 000000000000..1acd9cf58f7c
--- /dev/null
+++ b/dev-lang/gdl/files/gdl-0.9_rc2-gcc4.4.patch
@@ -0,0 +1,12 @@
+diff -Naur gdl-0.9rc2/src/envt.hpp gdl-0.9rc2.new/src/envt.hpp
+--- gdl-0.9rc2/src/envt.hpp 2009-01-20 14:33:56.000000000 -0500
++++ gdl-0.9rc2.new/src/envt.hpp 2009-08-25 22:18:44.000000000 -0400
+@@ -508,6 +508,8 @@
+ void AssureStringScalarPar( SizeT ix, DString& scalar);
+
+ // to be extended on demand for other data types
++
++ friend class DInterpreter;
+ };
+
+