summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-01-20 22:45:19 +0000
committerChris White <chriswhite@gentoo.org>2005-01-20 22:45:19 +0000
commitb09c25e6aa41c72e6fec69e4b0d27303f3de23a8 (patch)
treef9581188ed92a0388d0247de454e33cba283bc0a /dev-lang/fpc
parentNew version (diff)
downloadgentoo-2-b09c25e6aa41c72e6fec69e4b0d27303f3de23a8.tar.gz
gentoo-2-b09c25e6aa41c72e6fec69e4b0d27303f3de23a8.tar.bz2
gentoo-2-b09c25e6aa41c72e6fec69e4b0d27303f3de23a8.zip
Fixing bug #71677. Renaming fpc-source to fpc.
Diffstat (limited to 'dev-lang/fpc')
-rw-r--r--dev-lang/fpc/ChangeLog27
-rw-r--r--dev-lang/fpc/Manifest4
-rw-r--r--dev-lang/fpc/files/digest-fpc-1.9.5_pre200408201
-rw-r--r--dev-lang/fpc/fpc-1.9.5_pre20040820.ebuild62
-rw-r--r--dev-lang/fpc/metadata.xml8
5 files changed, 102 insertions, 0 deletions
diff --git a/dev-lang/fpc/ChangeLog b/dev-lang/fpc/ChangeLog
new file mode 100644
index 000000000000..e535352eb2d9
--- /dev/null
+++ b/dev-lang/fpc/ChangeLog
@@ -0,0 +1,27 @@
+# ChangeLog for dev-lang/fpc-source
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc/ChangeLog,v 1.12 2005/01/20 22:45:19 chriswhite Exp $
+
+*fpc-1.9.5_pre20040820 (21 Jan 2005)
+
+ 21 Jan 2005; Chris White <chriswhite@gentoo.org> +metadata.xml,
+ +fpc-1.9.5_pre20040820.ebuild:
+ Fixing bug #71677. Renaming fpc-source to fpc.
+
+ 26 Aug 2004; Chris White <chriswhite@gentoo.org>
+ fpc-source-1.9.5_pre20040820.ebuild:
+ FPC asm doesn't go too well with amd64. -arch marking. Used zhen's dev box to verify this.
+
+ 22 Aug 2004; Chris White <chriswhite@gentoo.org>
+ fpc-source-1.9.5_pre20040820.ebuild:
+ Changed to emake -j1 since the makefile apparently doesn't like parallel makes.
+
+ 22 Aug 2004; Chris White <chriswhite@gentoo.org>
+ fpc-source-1.9.5_pre20040820.ebuild:
+ Added fpc blocker.
+
+*fpc-source-1.9.5_pre20040820 (22 Aug 2004)
+
+ 22 Aug 2004; Chris White <chriswhite@gentoo.org> +metadata.xml,
+ +fpc-source-1.9.5_pre20040820.ebuild:
+ Initial package import. Adding myself as maintainer.
diff --git a/dev-lang/fpc/Manifest b/dev-lang/fpc/Manifest
new file mode 100644
index 000000000000..2fe7c11b191b
--- /dev/null
+++ b/dev-lang/fpc/Manifest
@@ -0,0 +1,4 @@
+MD5 5870cac1103486e40803e3b1e1f18f4d ChangeLog 798
+MD5 386f33d41197b2249d8603e9deb21729 fpc-1.9.5_pre20040820.ebuild 1692
+MD5 f5f1522837a3398846f77d381fda47ec metadata.xml 226
+MD5 765515c95e92cbeb5061c5eb1978eb68 files/digest-fpc-1.9.5_pre20040820 58
diff --git a/dev-lang/fpc/files/digest-fpc-1.9.5_pre20040820 b/dev-lang/fpc/files/digest-fpc-1.9.5_pre20040820
new file mode 100644
index 000000000000..5944475cb531
--- /dev/null
+++ b/dev-lang/fpc/files/digest-fpc-1.9.5_pre20040820
@@ -0,0 +1 @@
+MD5 724cf7311ff2c34fa8848f259815a8ef doc-html.zip 7249589
diff --git a/dev-lang/fpc/fpc-1.9.5_pre20040820.ebuild b/dev-lang/fpc/fpc-1.9.5_pre20040820.ebuild
new file mode 100644
index 000000000000..3a2e6a1ade6f
--- /dev/null
+++ b/dev-lang/fpc/fpc-1.9.5_pre20040820.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc/fpc-1.9.5_pre20040820.ebuild,v 1.1 2005/01/20 22:45:19 chriswhite Exp $
+
+inherit eutils
+
+FPC_V="1.9.5"
+
+DESCRIPTION="Source build for the Free Pascal Compiler"
+HOMEPAGE="http://www.us.freepascal.org/fpc.html"
+SRC_URI="doc? ( ftp://ftp.freepascal.org/pub/fpc/docs/doc-html.zip )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -amd64"
+IUSE="doc"
+DEPEND="!dev-lang/fpc-bin"
+S=${WORKDIR}/fpc-${FPC_V}
+
+src_compile() {
+ cd ${S}
+
+ einfo "Building the fpc compiler and units"
+ # have to use -j1 as it doesn't seem to like -j2+
+ emake -j1 \
+ build \
+ OS_TARGET=linux \
+ PP=${S}/ppc386 \
+ PREFIX=${D}/usr \
+ || die "Free Pascal Compiler build process failed!"
+}
+
+src_install() {
+
+ einfo "Installing the fpc compiler and units"
+ emake -j1 \
+ install \
+ OS_TARGET=linux \
+ PP=${S}/ppc386 \
+ PREFIX=${D}/usr \
+ || die "Free Pascal Compiler install failed!"
+
+ if use doc
+ then
+ #install the html docs
+ einfo "Installing html docs"
+ mkdir ${D}/usr/share/doc/fpc-${FPC_V}/html
+ cp -r ${WORKDIR}/doc/* ${D}/usr/share/doc/fpc-${FPC_V}/html
+ fi
+}
+
+config() {
+ #Create our configuration file so fpc
+ #is easier to use
+ /usr/lib/fpc/${FPC_V}/samplecfg /usr/lib/fpc/${FPC_V} /etc
+
+ einfo "The configuration file for fpc has been placed in /etc/fpc.cfg"
+ einfo "Use this to customize your pascal compile flags"
+ einfo "More information on the fpc flags can be found in the fpc manpage"
+ echo
+ einfo "Examples and docs can be found in /usr/share/doc/fpc-${FPC_V}"
+ einfo "Upstream support can be found at: http://community.freepascal.org:10000/"
+}
diff --git a/dev-lang/fpc/metadata.xml b/dev-lang/fpc/metadata.xml
new file mode 100644
index 000000000000..b452dec7e591
--- /dev/null
+++ b/dev-lang/fpc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>chriswhite@gentoo.org</email>
+</maintainer>
+</pkgmetadata>