summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-04-22 12:44:23 +0000
committerMichał Górny <mgorny@gentoo.org>2015-04-22 12:44:23 +0000
commit59b6a531e946d186b97e939325d8cb2a1e5f2212 (patch)
treea76005a8cadc04585cb92f4320369ce0afee6bf0 /dev-lang/ekopath
parentDrop s390 and sh keywords to unstable, wrt bug #545664 (diff)
downloadgentoo-2-59b6a531e946d186b97e939325d8cb2a1e5f2212.tar.gz
gentoo-2-59b6a531e946d186b97e939325d8cb2a1e5f2212.tar.bz2
gentoo-2-59b6a531e946d186b97e939325d8cb2a1e5f2212.zip
Version bump. Upstream fixed a few irritating bugs, including the sandbox violations and lack of AMD k8 support. Cleaned up the ebuild a bit, added RESTRICT=bindist per bug #536262.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-lang/ekopath')
-rw-r--r--dev-lang/ekopath/ChangeLog10
-rw-r--r--dev-lang/ekopath/ekopath-6.0.334_p20150421.ebuild62
-rw-r--r--dev-lang/ekopath/metadata.xml5
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-lang/ekopath/ChangeLog b/dev-lang/ekopath/ChangeLog
index 239b08739f80..a8740f4b4722 100644
--- a/dev-lang/ekopath/ChangeLog
+++ b/dev-lang/ekopath/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/ekopath
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.23 2015/02/28 21:55:22 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.24 2015/04/22 12:44:23 mgorny Exp $
+
+*ekopath-6.0.334_p20150421 (22 Apr 2015)
+
+ 22 Apr 2015; Michał Górny <mgorny@gentoo.org>
+ +ekopath-6.0.334_p20150421.ebuild, metadata.xml:
+ Version bump. Upstream fixed a few irritating bugs, including the sandbox
+ violations and lack of AMD k8 support. Cleaned up the ebuild a bit, added
+ RESTRICT=bindist per bug #536262.
*ekopath-5.0.5_pre20150226 (28 Feb 2015)
diff --git a/dev-lang/ekopath/ekopath-6.0.334_p20150421.ebuild b/dev-lang/ekopath/ekopath-6.0.334_p20150421.ebuild
new file mode 100644
index 000000000000..97d66ca583bc
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-6.0.334_p20150421.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ekopath-6.0.334_p20150421.ebuild,v 1.1 2015/04/22 12:44:23 mgorny Exp $
+
+EAPI=5
+
+inherit versionator multilib pax-utils
+
+MY_PV=$(get_version_component_range 1-3)
+DATE=$(get_version_component_range 4)
+DATE=${DATE#p}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+INSTALLER=${PN}-${DATE}-installer.run
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="!!app-arch/rpm"
+RDEPEND=""
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="
+ opt/${PN}/lib/${MY_PV}/x8664/*
+ opt/${PN}/bin/*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
+ chmod +x "${S}/${INSTALLER}" || die
+}
+
+src_prepare() {
+ cat > 99${PN} <<-EOF
+ PATH=${EROOT%/}/opt/${PN}/bin
+ ROOTPATH=${EROOT%/}/opt/${PN}/bin
+ LDPATH=${EROOT%/}/opt/${PN}/lib:${EROOT%/}/opt/${PN}/lib/${MY_PV}/x8664/64
+ MANPATH=${EROOT%/}/opt/${PN}/docs/man
+ EOF
+}
+
+src_install() {
+ # EI_PAX marking is obsolete and PT_PAX breaks the binary.
+ # We must use XT_PAX to run the installer.
+ if [[ ${PAX_MARKINGS} == "XT" ]]; then
+ pax-mark m "${INSTALLER}"
+ fi
+
+ ./"${INSTALLER}" \
+ --prefix "${ED%/}/opt/${PN}" \
+ --mode unattended || die
+
+ rm -r "${ED}/opt/${PN}"/uninstall* || die
+ doenvd 99${PN}
+}
diff --git a/dev-lang/ekopath/metadata.xml b/dev-lang/ekopath/metadata.xml
index c8c81d4cd1d9..b78884b8579c 100644
--- a/dev-lang/ekopath/metadata.xml
+++ b/dev-lang/ekopath/metadata.xml
@@ -2,6 +2,11 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
+<maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ <description>Co-maintainer</description>
+</maintainer>
<longdescription>
The PathScale EKOPath Compiler Suite offers programmers a rich set of tools and
one of the world's most sophisticated optimization infrastructures to maximize