summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-05-04 04:30:46 +0000
committerMichał Górny <mgorny@gentoo.org>2015-05-04 04:30:46 +0000
commit3633905cec18a7ffd2e7a786b9b59a324933e1f0 (patch)
tree876b858709944221dd891017903ec56b126f9347 /dev-lang/ekopath
parenthandle unstable->experimental (diff)
downloadgentoo-2-3633905cec18a7ffd2e7a786b9b59a324933e1f0.tar.gz
gentoo-2-3633905cec18a7ffd2e7a786b9b59a324933e1f0.tar.bz2
gentoo-2-3633905cec18a7ffd2e7a786b9b59a324933e1f0.zip
Snapshot bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-lang/ekopath')
-rw-r--r--dev-lang/ekopath/ChangeLog8
-rw-r--r--dev-lang/ekopath/ekopath-6.0.348_p20150502.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-lang/ekopath/ChangeLog b/dev-lang/ekopath/ChangeLog
index a8740f4b4722..5436e41a983c 100644
--- a/dev-lang/ekopath/ChangeLog
+++ b/dev-lang/ekopath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ekopath
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.24 2015/04/22 12:44:23 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.25 2015/05/04 04:30:46 mgorny Exp $
+
+*ekopath-6.0.348_p20150502 (04 May 2015)
+
+ 04 May 2015; Michał Górny <mgorny@gentoo.org>
+ +ekopath-6.0.348_p20150502.ebuild:
+ Snapshot bump
*ekopath-6.0.334_p20150421 (22 Apr 2015)
diff --git a/dev-lang/ekopath/ekopath-6.0.348_p20150502.ebuild b/dev-lang/ekopath/ekopath-6.0.348_p20150502.ebuild
new file mode 100644
index 000000000000..7a3882e9b6e7
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-6.0.348_p20150502.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ekopath-6.0.348_p20150502.ebuild,v 1.1 2015/05/04 04:30:46 mgorny Exp $
+
+EAPI=5
+
+inherit versionator multilib pax-utils
+
+MY_PV=$(get_version_component_range 1-3)
+DATE=$(get_version_component_range 4)
+DATE=${DATE#p}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+INSTALLER=${PN}-${DATE}-installer.run
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="!!app-arch/rpm"
+RDEPEND=""
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="
+ opt/${PN}/lib/${MY_PV}/x8664/*
+ opt/${PN}/bin/*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
+ chmod +x "${S}/${INSTALLER}" || die
+}
+
+src_prepare() {
+ cat > 99${PN} <<-EOF
+ PATH=${EROOT%/}/opt/${PN}/bin
+ ROOTPATH=${EROOT%/}/opt/${PN}/bin
+ LDPATH=${EROOT%/}/opt/${PN}/lib:${EROOT%/}/opt/${PN}/lib/${MY_PV}/x8664/64
+ MANPATH=${EROOT%/}/opt/${PN}/docs/man
+ EOF
+}
+
+src_install() {
+ # EI_PAX marking is obsolete and PT_PAX breaks the binary.
+ # We must use XT_PAX to run the installer.
+ if [[ ${PAX_MARKINGS} == "XT" ]]; then
+ pax-mark m "${INSTALLER}"
+ fi
+
+ ./"${INSTALLER}" \
+ --prefix "${ED%/}/opt/${PN}" \
+ --mode unattended || die
+
+ rm -r "${ED}/opt/${PN}"/uninstall* || die
+ doenvd 99${PN}
+}