summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-11-21 16:22:52 +0000
committerJustin Lecher <jlec@gentoo.org>2011-11-21 16:22:52 +0000
commit76fec35b38aa62f50819801c8853fa9e53c488c4 (patch)
treeee24fa5d7a8d581adb2ea74716daa5ebb2d55b34 /dev-lang/R
parentFixed to work with linux-3.2, bug #390627. (diff)
downloadgentoo-2-76fec35b38aa62f50819801c8853fa9e53c488c4.tar.gz
gentoo-2-76fec35b38aa62f50819801c8853fa9e53c488c4.tar.bz2
gentoo-2-76fec35b38aa62f50819801c8853fa9e53c488c4.zip
Version Bump, #391045, cleaned old, moved to bashcompletion-r1.eclass, sorted minor things in ebuild (adopt changes in between versions)
(Portage version: 2.2.0_alpha76/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog10
-rw-r--r--dev-lang/R/R-2.10.1.ebuild24
-rw-r--r--dev-lang/R/R-2.12.1.ebuild167
-rw-r--r--dev-lang/R/R-2.13.0.ebuild21
-rw-r--r--dev-lang/R/R-2.13.1-r1.ebuild37
-rw-r--r--dev-lang/R/R-2.14.0.ebuild (renamed from dev-lang/R/R-2.12.2.ebuild)82
-rw-r--r--dev-lang/R/metadata.xml4
7 files changed, 103 insertions, 242 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index bdb3e34b3029..b9377126b3bd 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.190 2011/10/17 15:34:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.191 2011/11/21 16:22:52 jlec Exp $
+
+*R-2.14.0 (21 Nov 2011)
+
+ 21 Nov 2011; Justin Lecher <jlec@gentoo.org> R-2.10.1.ebuild,
+ -R-2.12.1.ebuild, -R-2.12.2.ebuild, R-2.13.0.ebuild, R-2.13.1-r1.ebuild,
+ +R-2.14.0.ebuild, metadata.xml:
+ Version Bump, #391045, cleaned old, moved to bashcompletion-r1.eclass, sorted
+ minor things in ebuild (adopt changes in between versions)
17 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> R-2.10.1.ebuild:
Fix building with libpng15 wrt #366223. Fix building with sys-libs/zlib >=
diff --git a/dev-lang/R/R-2.10.1.ebuild b/dev-lang/R/R-2.10.1.ebuild
index 03f3516b739f..faea2ca51f45 100644
--- a/dev-lang/R/R-2.10.1.ebuild
+++ b/dev-lang/R/R-2.10.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.10.1.ebuild,v 1.14 2011/10/17 15:34:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.10.1.ebuild,v 1.15 2011/11/21 16:22:52 jlec Exp $
EAPI=2
-inherit bash-completion eutils flag-o-matic fortran-2 versionator
+inherit bash-completion-r1 eutils flag-o-matic fortran-2 versionator
DESCRIPTION="Language and environment for statistical computing and graphics"
HOMEPAGE="http://www.r-project.org/"
@@ -16,7 +16,7 @@ LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="cairo doc java jpeg lapack minimal nls perl png readline threads tk X"
+IUSE="bash-completion cairo doc java jpeg lapack minimal nls perl png readline threads tk X"
# common depends
CDEPEND="
@@ -27,7 +27,7 @@ CDEPEND="
virtual/fortran
cairo? (
x11-libs/cairo[X]
- || ( >=x11-libs/pango-1.20[X] <x11-libs/pango-1.20 ) )
+ >=x11-libs/pango-1.20[X] )
jpeg? ( virtual/jpeg )
lapack? ( virtual/lapack )
perl? ( dev-lang/perl )
@@ -39,9 +39,9 @@ CDEPEND="
DEPEND="${CDEPEND}
dev-util/pkgconfig
doc? (
- virtual/latex-base
- dev-texlive/texlive-fontsrecommended
- )"
+ virtual/latex-base
+ dev-texlive/texlive-fontsrecommended
+ )"
RDEPEND="${CDEPEND}
app-arch/unzip
@@ -68,12 +68,14 @@ src_prepare() {
|| die "sed failed"
# fix Rscript
- sed -i \
+ sed \
-e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_DIR}\"':" \
- src/unix/Makefile.in || die "sed unix Makefile failed"
+ -i src/unix/Makefile.in || die "sed unix Makefile failed"
# fix HTML links to manual (bug #273957)
- sed -i -e 's:\.\./manual/:manual/:g' $(grep -Flr ../manual/ doc) \
+ sed \
+ -e 's:\.\./manual/:manual/:g' \
+ -i $(grep -Flr ../manual/ doc) \
|| die "sed for HTML links to manual failed"
# Fix compability with zlib-1.2.5.1-r1 OF change
@@ -161,7 +163,7 @@ src_install() {
R_HOME=${R_DIR}
EOF
doenvd 99R || die "doenvd failed"
- dobashcompletion "${WORKDIR}"/R.bash_completion
+ use bash-completion && dobashcomp "${WORKDIR}"/R.bash_completion
}
pkg_config() {
diff --git a/dev-lang/R/R-2.12.1.ebuild b/dev-lang/R/R-2.12.1.ebuild
deleted file mode 100644
index bd7afcc0a362..000000000000
--- a/dev-lang/R/R-2.12.1.ebuild
+++ /dev/null
@@ -1,167 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.12.1.ebuild,v 1.5 2011/10/05 19:20:04 aballier Exp $
-
-EAPI=2
-
-inherit bash-completion eutils flag-o-matic fortran-2 versionator
-
-DESCRIPTION="Language and environment for statistical computing and graphics"
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="
- mirror://cran/src/base/R-2/${P}.tar.gz
- bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
-IUSE="cairo doc java jpeg lapack minimal nls perl png profile readline static-libs threads tk X"
-
-# common depends
-CDEPEND="
- app-arch/bzip2
- app-text/ghostscript-gpl
- dev-libs/libpcre
- virtual/blas
- virtual/fortran
- cairo? (
- x11-libs/cairo[X]
- || ( >=x11-libs/pango-1.20[X] <x11-libs/pango-1.20 ) )
- jpeg? ( virtual/jpeg )
- lapack? ( virtual/lapack )
- perl? ( dev-lang/perl )
- png? ( media-libs/libpng )
- readline? ( sys-libs/readline )
- tk? ( dev-lang/tk )
- X? ( x11-libs/libXmu x11-misc/xdg-utils )"
-
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- doc? (
- virtual/latex-base
- dev-texlive/texlive-fontsrecommended
- )"
-
-RDEPEND="${CDEPEND}
- app-arch/unzip
- app-arch/zip
- java? ( >=virtual/jre-1.5 )"
-
-RESTRICT="minimal? ( test )"
-
-R_DIR=/usr/$(get_libdir)/${PN}
-
-pkg_setup() {
- fortran-2_pkg_setup
- filter-ldflags -Wl,-Bdirect -Bdirect
- # avoid using existing R installation
- unset R_HOME
-}
-
-src_prepare() {
- # fix ocasional failure with parallel install (bug #322965)
- epatch "${FILESDIR}"/${PN}-2.11.1-parallel.patch
- # respect ldflags on rscript
- epatch "${FILESDIR}"/${PN}-2.12.1-ldflags.patch
-
- # fix packages.html for doc (bug #205103)
- # check in later versions if fixed
- sed -i \
- -e "s:../../library:../../../../$(get_libdir)/R/library:g" \
- src/library/tools/R/packageshtml.R \
- || die "sed failed"
-
- # fix Rscript
- sed -i \
- -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_DIR}\"':" \
- src/unix/Makefile.in || die "sed unix Makefile failed"
-
- # fix HTML links to manual (bug #273957)
- sed -i -e 's:\.\./manual/:manual/:g' $(grep -Flr ../manual/ doc) \
- || die "sed for HTML links to manual failed"
-
- use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
- if use X; then
- export R_BROWSER="$(type -p xdg-open)"
- export R_PDFVIEWER="$(type -p xdg-open)"
- fi
- use perl && \
- export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
-}
-
-src_configure() {
- econf \
- --enable-R-shlib \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- --with-blas="$(pkg-config --libs blas)" \
- --docdir=/usr/share/doc/${PF} \
- rdocdir=/usr/share/doc/${PF} \
- $(use_enable nls) \
- $(use_enable profile R-profiling) \
- $(use_enable profile memory-profiling) \
- $(use_enable static-libs static) \
- $(use_enable static-libs R-static-lib) \
- $(use_enable threads) \
- $(use_with lapack) \
- $(use_with tk tcltk) \
- $(use_with jpeg jpeglib) \
- $(use_with !minimal recommended-packages) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with cairo) \
- $(use_with X x)
-}
-
-src_compile(){
- export VARTEXFONTS="${T}/fonts"
- emake || die "emake failed"
- RMATH_V=0.0.0
- emake -C src/nmath/standalone \
- libRmath_la_LDFLAGS=-Wl,-soname,libRmath.so.${RMATH_V} \
- || die "emake math library failed"
- if use doc; then
- emake info pdf || die "emake docs failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use doc; then
- emake DESTDIR="${D}" \
- install-info install-pdf || die "emake install docs failed"
- dosym /usr/share/doc/${PF}/manual /usr/share/doc/${PF}/html/manual
- fi
-
- # standalone math lib install (-j1 basically harmless)
- emake \
- -C src/nmath/standalone \
- DESTDIR="${D}" install \
- || die "emake install math library failed"
-
- local mv=$(get_major_version ${RMATH_V})
- mv "${D}"/usr/$(get_libdir)/libRmath.so \
- "${D}"/usr/$(get_libdir)/libRmath.so.${RMATH_V}
- dosym libRmath.so.${RMATH_V} /usr/$(get_libdir)/libRmath.so.${mv}
- dosym libRmath.so.${mv} /usr/$(get_libdir)/libRmath.so
-
- # env file
- cat > 99R <<-EOF
- LDPATH=${R_DIR}/lib
- R_HOME=${R_DIR}
- EOF
- doenvd 99R || die "doenvd failed"
- dobashcompletion "${WORKDIR}"/R.bash_completion
-}
-
-pkg_postinst() {
- if use java; then
- einfo "Re-initializing java paths for ${P}"
- R CMD javareconf
- fi
-}
diff --git a/dev-lang/R/R-2.13.0.ebuild b/dev-lang/R/R-2.13.0.ebuild
index daa0941b73cf..5a5833333c14 100644
--- a/dev-lang/R/R-2.13.0.ebuild
+++ b/dev-lang/R/R-2.13.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.13.0.ebuild,v 1.2 2011/10/05 19:20:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.13.0.ebuild,v 1.3 2011/11/21 16:22:52 jlec Exp $
EAPI=4
-inherit bash-completion eutils flag-o-matic fortran-2 versionator
+inherit bash-completion-r1 eutils flag-o-matic fortran-2 versionator
DESCRIPTION="Language and environment for statistical computing and graphics"
HOMEPAGE="http://www.r-project.org/"
@@ -16,7 +16,7 @@ LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="cairo doc java jpeg lapack minimal nls openmp perl png profile readline static-libs tk X"
+IUSE="bash-completion cairo doc java jpeg lapack minimal nls openmp perl png profile readline static-libs tk X"
# common depends
CDEPEND="
@@ -24,10 +24,10 @@ CDEPEND="
app-text/ghostscript-gpl
dev-libs/libpcre
virtual/blas
- virtual/fortran[openmp?]
+ virtual/fortran
cairo? (
x11-libs/cairo[X]
- || ( >=x11-libs/pango-1.20[X] <x11-libs/pango-1.20 ) )
+ >=x11-libs/pango-1.20[X] )
jpeg? ( virtual/jpeg )
lapack? ( virtual/lapack )
perl? ( dev-lang/perl )
@@ -39,9 +39,9 @@ CDEPEND="
DEPEND="${CDEPEND}
dev-util/pkgconfig
doc? (
- virtual/latex-base
- dev-texlive/texlive-fontsrecommended
- )"
+ virtual/latex-base
+ dev-texlive/texlive-fontsrecommended
+ )"
RDEPEND="${CDEPEND}
app-arch/unzip
@@ -51,7 +51,7 @@ RDEPEND="${CDEPEND}
RESTRICT="minimal? ( test )"
-R_DIR="${EPREFIX}"/usr/$(get_libdir)/${PN}
+R_DIR="${EPREFIX}/usr/$(get_libdir)/${PN}"
pkg_setup() {
if use openmp; then
@@ -161,7 +161,7 @@ src_install() {
R_HOME=${R_DIR}
EOF
doenvd 99R || die "doenvd failed"
- dobashcompletion "${WORKDIR}"/R.bash_completion
+ use bash-completion && dobashcomp "${WORKDIR}"/R.bash_completion
}
pkg_postinst() {
@@ -169,4 +169,5 @@ pkg_postinst() {
einfo "Re-initializing java paths for ${P}"
R CMD javareconf
fi
+ bash-completion-r1_pkg_postinst
}
diff --git a/dev-lang/R/R-2.13.1-r1.ebuild b/dev-lang/R/R-2.13.1-r1.ebuild
index 4e15f1050fdd..f861b046663d 100644
--- a/dev-lang/R/R-2.13.1-r1.ebuild
+++ b/dev-lang/R/R-2.13.1-r1.ebuild
@@ -1,30 +1,31 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.13.1-r1.ebuild,v 1.2 2011/10/05 19:20:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.13.1-r1.ebuild,v 1.3 2011/11/21 16:22:52 jlec Exp $
EAPI=4
-inherit bash-completion eutils flag-o-matic fortran-2 versionator
+inherit bash-completion-r1 eutils flag-o-matic fortran-2 versionator
DESCRIPTION="Language and environment for statistical computing and graphics"
HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz
+SRC_URI="
+ mirror://cran/src/base/R-2/${P}.tar.gz
bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="cairo doc java jpeg lapack minimal nls openmp perl png profile readline static-libs tk X"
+IUSE="bash-completion cairo doc java jpeg lapack minimal nls openmp perl png profile readline static-libs tk X"
# common depends
-CDEPEND="app-arch/bzip2
+CDEPEND="
+ app-arch/bzip2
app-text/ghostscript-gpl
dev-libs/libpcre
|| ( >=net-libs/libtirpc-0.2.2-r1 <sys-libs/glibc-2.14 sys-freebsd/freebsd-lib )
virtual/blas
- cairo? ( x11-libs/cairo[X]
- >=x11-libs/pango-1.20[X] )
+ cairo? ( x11-libs/cairo[X] )
jpeg? ( virtual/jpeg )
lapack? ( virtual/lapack )
perl? ( dev-lang/perl )
@@ -35,8 +36,9 @@ CDEPEND="app-arch/bzip2
DEPEND="${CDEPEND}
dev-util/pkgconfig
- doc? ( virtual/latex-base
- dev-texlive/texlive-fontsrecommended
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsrecommended
)"
RDEPEND="${CDEPEND}
@@ -46,7 +48,7 @@ RDEPEND="${CDEPEND}
RESTRICT="minimal? ( test )"
-R_DIR="${EPREFIX}"/usr/$(get_libdir)/${PN}
+R_DIR="${EPREFIX}/usr/$(get_libdir)/${PN}"
pkg_setup() {
if use openmp; then
@@ -88,12 +90,14 @@ src_prepare() {
|| die "sed failed"
# fix Rscript
- sed -i \
+ sed \
-e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_DIR}\"':" \
- src/unix/Makefile.in || die "sed unix Makefile failed"
+ -i src/unix/Makefile.in || die "sed unix Makefile failed"
# fix HTML links to manual (bug #273957)
- sed -i -e 's:\.\./manual/:manual/:g' $(grep -Flr ../manual/ doc) \
+ sed \
+ -e 's:\.\./manual/:manual/:g' \
+ -i $(grep -Flr ../manual/ doc) \
|| die "sed for HTML links to manual failed"
use lapack && \
@@ -116,8 +120,8 @@ src_configure() {
--with-system-pcre \
--with-system-xz \
--with-blas="$(pkg-config --libs blas)" \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- rdocdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ rdocdir="${EPREFIX}/usr/share/doc/${PF}" \
$(use_enable openmp) \
$(use_enable nls) \
$(use_enable profile R-profiling) \
@@ -169,7 +173,7 @@ src_install() {
R_HOME=${R_DIR}
EOF
doenvd 99R
- dobashcompletion "${WORKDIR}"/R.bash_completion
+ use bash-completion && dobashcomp "${WORKDIR}"/R.bash_completion
}
pkg_postinst() {
@@ -177,4 +181,5 @@ pkg_postinst() {
einfo "Re-initializing java paths for ${P}"
R CMD javareconf
fi
+ bash-completion-r1_pkg_postinst
}
diff --git a/dev-lang/R/R-2.12.2.ebuild b/dev-lang/R/R-2.14.0.ebuild
index fcd5667ffcef..30f7289d0d95 100644
--- a/dev-lang/R/R-2.12.2.ebuild
+++ b/dev-lang/R/R-2.14.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.12.2.ebuild,v 1.4 2011/10/05 19:20:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.14.0.ebuild,v 1.1 2011/11/21 16:22:52 jlec Exp $
-EAPI=3
+EAPI=4
-inherit bash-completion eutils flag-o-matic fortran-2 versionator
+inherit bash-completion-r1 eutils flag-o-matic fortran-2 versionator
DESCRIPTION="Language and environment for statistical computing and graphics"
HOMEPAGE="http://www.r-project.org/"
@@ -12,22 +12,19 @@ SRC_URI="
mirror://cran/src/base/R-2/${P}.tar.gz
bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
-LICENSE="GPL-2 LGPL-2.1"
+LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
-IUSE="cairo doc java jpeg lapack minimal nls perl png profile readline static-libs tk X"
+IUSE="bash-completion cairo doc java jpeg lapack minimal nls openmp perl png profile readline static-libs tk X"
# common depends
CDEPEND="
app-arch/bzip2
app-text/ghostscript-gpl
dev-libs/libpcre
+ || ( >=net-libs/libtirpc-0.2.2-r1 <sys-libs/glibc-2.14 sys-freebsd/freebsd-lib )
virtual/blas
- virtual/fortran
- cairo? (
- x11-libs/cairo[X]
- || ( >=x11-libs/pango-1.20[X] <x11-libs/pango-1.20 ) )
+ cairo? ( x11-libs/cairo[X] )
jpeg? ( virtual/jpeg )
lapack? ( virtual/lapack )
perl? ( dev-lang/perl )
@@ -39,20 +36,24 @@ CDEPEND="
DEPEND="${CDEPEND}
dev-util/pkgconfig
doc? (
- virtual/latex-base
- dev-texlive/texlive-fontsrecommended
- )"
+ virtual/latex-base
+ dev-texlive/texlive-fontsrecommended
+ )"
RDEPEND="${CDEPEND}
- app-arch/unzip
- app-arch/zip
+ ( || ( <sys-libs/zlib-1.2.5.1-r1 >=sys-libs/zlib-1.2.5.1-r2[minizip] ) )
+ app-arch/xz-utils
java? ( >=virtual/jre-1.5 )"
RESTRICT="minimal? ( test )"
-R_DIR="${EPREFIX}"/usr/$(get_libdir)/${PN}
+R_DIR="${EPREFIX}/usr/$(get_libdir)/${PN}"
pkg_setup() {
+ if use openmp; then
+ FORTRAN_NEED_OPENMP=1
+ tc-has-openmp || die "Please enable openmp support in your compiler"
+ fi
fortran-2_pkg_setup
filter-ldflags -Wl,-Bdirect -Bdirect
# avoid using existing R installation
@@ -61,19 +62,30 @@ pkg_setup() {
src_prepare() {
# fix ocasional failure with parallel install (bug #322965)
- # upstream in R-12.3?
+ # upstream in R-2.13?
# https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14505
epatch "${FILESDIR}"/${PN}-2.11.1-parallel.patch
# respect ldflags on rscript
# upstream does not want it, no reasons given
# https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14506
epatch "${FILESDIR}"/${PN}-2.12.1-ldflags.patch
+ # update for zlib header changes (see bug #383431)
+ epatch "${FILESDIR}"/${PN}-2.13.1-zlib_header_fix.patch
+
+ # glibc 2.14 removed rpc
+ if has_version '>=net-libs/libtirpc-0.2.2-r1'; then
+ append-cppflags $($(tc-getPKG_CONFIG) libtirpc --cflags)
+ export LIBS+=" $($(tc-getPKG_CONFIG) libtirpc --libs)"
+ # patching configure.ac would cause way too much work
+ # ugly hack on configure and let upstream do the job
+ sed -i -e "s/'' nsl;/'' tirpc;/" configure || die
+ fi
# fix packages.html for doc (bug #205103)
# check in later versions if fixed
sed -i \
-e "s:../../library:../../../../$(get_libdir)/R/library:g" \
- src/library/tools/R/packageshtml.R \
+ src/library/tools/R/Rd.R \
|| die "sed failed"
# fix Rscript
@@ -98,13 +110,16 @@ src_prepare() {
src_configure() {
econf \
+ --enable-byte-compiled-packages \
--enable-R-shlib \
--with-system-zlib \
--with-system-bzlib \
--with-system-pcre \
+ --with-system-xz \
--with-blas="$(pkg-config --libs blas)" \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- rdocdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ rdocdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable openmp) \
$(use_enable nls) \
$(use_enable profile R-profiling) \
$(use_enable profile memory-profiling) \
@@ -122,30 +137,26 @@ src_configure() {
src_compile(){
export VARTEXFONTS="${T}/fonts"
- emake || die "emake failed"
+ emake
RMATH_V=0.0.0
emake -C src/nmath/standalone \
- libRmath_la_LDFLAGS=-Wl,-soname,libRmath.so.${RMATH_V} \
- || die "emake math library failed"
- if use doc; then
- emake info pdf || die "emake docs failed"
- fi
+ libRmath_la_LDFLAGS="-Wl,-soname,libRmath.so.${RMATH_V}" \
+ libRmath_la_LIBADD="\$(LIBM)" \
+ shared $(use static-libs && echo static)
+ use doc && emake info pdf
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
+ default
if use doc; then
- emake DESTDIR="${D}" \
- install-info install-pdf || die "emake install docs failed"
- dosym /usr/share/doc/${PF}/manual /usr/share/doc/${PF}/html/manual
+ emake DESTDIR="${D}" install-info install-pdf
+ dosym ../manual /usr/share/doc/${PF}/html/manual
fi
# standalone math lib install (-j1 basically harmless)
emake \
-C src/nmath/standalone \
- DESTDIR="${D}" install \
- || die "emake install math library failed"
+ DESTDIR="${D}" install
local mv=$(get_major_version ${RMATH_V})
mv "${ED}"/usr/$(get_libdir)/libRmath.so \
@@ -158,8 +169,8 @@ src_install() {
LDPATH=${R_DIR}/lib
R_HOME=${R_DIR}
EOF
- doenvd 99R || die "doenvd failed"
- dobashcompletion "${WORKDIR}"/R.bash_completion
+ doenvd 99R
+ use bash-completion && dobashcomp "${WORKDIR}"/R.bash_completion
}
pkg_postinst() {
@@ -167,4 +178,5 @@ pkg_postinst() {
einfo "Re-initializing java paths for ${P}"
R CMD javareconf
fi
+ bash-completion-r1_pkg_postinst
}
diff --git a/dev-lang/R/metadata.xml b/dev-lang/R/metadata.xml
index ec8fee50f867..915e03f5b95e 100644
--- a/dev-lang/R/metadata.xml
+++ b/dev-lang/R/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
R is GNU S, a system for statistical computation and graphics. It
consists of a language plus a run-time environment with graphics, a
debugger, access to certain system functions, and the ability to run