summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-03-05 23:29:13 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-03-05 23:29:13 +0000
commitd6db1a6d4792e85660d98d5433ed364ed1739ce8 (patch)
tree8d93e38e2d13411b39a832a6a88339cb9d08df64 /dev-java
parentNew package required by Log4j 2. It would be optional but we cannot (diff)
downloadgentoo-2-d6db1a6d4792e85660d98d5433ed364ed1739ce8.tar.gz
gentoo-2-d6db1a6d4792e85660d98d5433ed364ed1739ce8.tar.bz2
gentoo-2-d6db1a6d4792e85660d98d5433ed364ed1739ce8.zip
New package required by Log4j 2. It would be optional but we cannot
yet skip dependencies at build time. (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 9C6D7DE4)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jackson-dataformat-yaml/ChangeLog10
-rw-r--r--dev-java/jackson-dataformat-yaml/jackson-dataformat-yaml-2.5.1.ebuild63
-rw-r--r--dev-java/jackson-dataformat-yaml/metadata.xml6
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-java/jackson-dataformat-yaml/ChangeLog b/dev-java/jackson-dataformat-yaml/ChangeLog
new file mode 100644
index 000000000000..bb933ab145d0
--- /dev/null
+++ b/dev-java/jackson-dataformat-yaml/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/jackson-dataformat-yaml
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jackson-dataformat-yaml/ChangeLog,v 1.1 2015/03/05 23:29:13 chewi Exp $
+
+*jackson-dataformat-yaml-2.5.1 (05 Mar 2015)
+
+ 05 Mar 2015; James Le Cuirot <chewi@gentoo.org>
+ +jackson-dataformat-yaml-2.5.1.ebuild, +metadata.xml:
+ New package required by Log4j 2. It would be optional but we cannot yet skip
+ dependencies at build time.
diff --git a/dev-java/jackson-dataformat-yaml/jackson-dataformat-yaml-2.5.1.ebuild b/dev-java/jackson-dataformat-yaml/jackson-dataformat-yaml-2.5.1.ebuild
new file mode 100644
index 000000000000..34376a013ddf
--- /dev/null
+++ b/dev-java/jackson-dataformat-yaml/jackson-dataformat-yaml-2.5.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jackson-dataformat-yaml/jackson-dataformat-yaml-2.5.1.ebuild,v 1.1 2015/03/05 23:29:13 chewi Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="YAML data format extension for Jackson"
+HOMEPAGE="https://github.com/FasterXML/jackson-dataformat-yaml"
+SRC_URI="https://github.com/FasterXML/${PN}/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="~dev-java/jackson-${PV}:${SLOT}
+ ~dev-java/jackson-databind-${PV}:${SLOT}
+ dev-java/snakeyaml:0"
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${CDEPEND}
+ test? (
+ ~dev-java/jackson-annotations-${PV}:${SLOT}
+ dev-java/junit:4
+ )"
+
+S="${WORKDIR}/${PN}-${P}/src"
+JAVA_SRC_DIR="main/java"
+JAVA_GENTOO_CLASSPATH="jackson-${SLOT},jackson-databind-${SLOT},snakeyaml"
+
+java_prepare() {
+ sed -e 's:@package@:com.fasterxml.jackson.dataformat.yaml:g' \
+ -e "s:@projectversion@:${PV}:g" \
+ -e 's:@projectgroupid@:com.fasterxml.jackson.dataformat:g' \
+ -e 's:@projectartifactid@:jackson-dataformat-yaml:g' \
+ "${S}/main/java/com/fasterxml/jackson/dataformat/yaml/PackageVersion.java.in" \
+ > "${S}/main/java/com/fasterxml/jackson/dataformat/yaml/PackageVersion.java" || die
+
+ # Requires OPS4J Pax Exam, which isn't packaged yet.
+ rm "${S}/test/java/com/fasterxml/jackson/dataformat/yaml/failsafe/OSGiIT.java" || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc ../README.md ../release-notes/{CREDITS,VERSION}
+}
+
+src_test() {
+ cd test/java || die
+
+ local CP=".:../resources:${S}/${PN}.jar:$(java-pkg_getjars jackson-annotations-${SLOT},junit-4,${JAVA_GENTOO_CLASSPATH})"
+ local TESTS=$(find * -name "*Test*.java" ! -name "*TestBase*" ! -path "*/failing/*")
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -cp "${CP}" -d . $(find * -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}
diff --git a/dev-java/jackson-dataformat-yaml/metadata.xml b/dev-java/jackson-dataformat-yaml/metadata.xml
new file mode 100644
index 000000000000..f5a608100ad9
--- /dev/null
+++ b/dev-java/jackson-dataformat-yaml/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>This project contains Jackson extension component for reading and writing YAML encoded data. SnakeYAML library is used for low-level YAML parsing. This project adds necessary abstractions on top to make things work with other Jackson functionality.</longdescription>
+</pkgmetadata>