summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2014-04-18 14:53:20 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2014-04-18 14:53:20 +0000
commitba01bf0c4d54dc3b75021e9c8037b239a973999b (patch)
tree6ca628bfce48b72ab55bcb7154eb74e0fdbc8f84 /dev-java/tomcat-native
parentadd multilib support wrt #499268 (diff)
downloadgentoo-2-ba01bf0c4d54dc3b75021e9c8037b239a973999b.tar.gz
gentoo-2-ba01bf0c4d54dc3b75021e9c8037b239a973999b.tar.bz2
gentoo-2-ba01bf0c4d54dc3b75021e9c8037b239a973999b.zip
dev-java/tomcat-native: version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key CFE47E2F)
Diffstat (limited to 'dev-java/tomcat-native')
-rw-r--r--dev-java/tomcat-native/ChangeLog8
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.30.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-java/tomcat-native/ChangeLog b/dev-java/tomcat-native/ChangeLog
index a2834aba50f4..30734a7ccff1 100644
--- a/dev-java/tomcat-native/ChangeLog
+++ b/dev-java/tomcat-native/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tomcat-native
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.46 2014/03/03 23:41:37 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.47 2014/04/18 14:53:20 fordfrog Exp $
+
+*tomcat-native-1.1.30 (18 Apr 2014)
+
+ 18 Apr 2014; Miroslav Šulc <fordfrog@gentoo.org>
+ +tomcat-native-1.1.30.ebuild:
+ version bump
03 Mar 2014; Pacho Ramos <pacho@gentoo.org> tomcat-native-1.1.29.ebuild:
amd64 stable, bug #495398
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.30.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.30.ebuild
new file mode 100644
index 000000000000..f8486b5e008f
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.30.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/tomcat-native-1.1.30.ebuild,v 1.1 2014/04/18 14:53:20 fordfrog Exp $
+
+EAPI="5"
+
+inherit base eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE=""
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl
+ >=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src/jni/native
+
+src_configure(){
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+}
+
+src_compile() {
+ base_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}