summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-01-18 15:40:20 +0000
committerVlastimil Babka <caster@gentoo.org>2007-01-18 15:40:20 +0000
commit2180364825ed6183246f571017c6bd379027ab09 (patch)
treef4c991d8eccbbb97e177f4358a7f913db726bf36 /dev-java/jython
parentKeyword ~ppc. (diff)
downloadgentoo-2-2180364825ed6183246f571017c6bd379027ab09.tar.gz
gentoo-2-2180364825ed6183246f571017c6bd379027ab09.tar.bz2
gentoo-2-2180364825ed6183246f571017c6bd379027ab09.zip
Revbump to fix jreload (bug #115551 by Paul T. Darga <pdarga@umich.edu>) and replace bundled part of jakarta-oro with dependency (bug #160861).
(Portage version: 2.1.2)
Diffstat (limited to 'dev-java/jython')
-rw-r--r--dev-java/jython/ChangeLog8
-rw-r--r--dev-java/jython/files/digest-jython-2.1-r113
-rw-r--r--dev-java/jython/jython-2.1-r11.ebuild110
3 files changed, 120 insertions, 1 deletions
diff --git a/dev-java/jython/ChangeLog b/dev-java/jython/ChangeLog
index 882b9e5210cd..f3f443e81364 100644
--- a/dev-java/jython/ChangeLog
+++ b/dev-java/jython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/jython
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/ChangeLog,v 1.44 2007/01/18 06:50:50 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/ChangeLog,v 1.45 2007/01/18 15:40:20 caster Exp $
+
+*jython-2.1-r11 (18 Jan 2007)
+
+ 18 Jan 2007; Vlastimil Babka <caster@gentoo.org> +jython-2.1-r11.ebuild:
+ Revbump to fix jreload (bug #115551 by Paul T. Darga <pdarga@umich.edu>) and
+ replace bundled part of jakarta-oro with dependency (bug #160861).
16 Jan 2007; Stephanie Lockwood-Childs <wormo@gentoo.org>
jython-2.1-r10.ebuild:
diff --git a/dev-java/jython/files/digest-jython-2.1-r11 b/dev-java/jython/files/digest-jython-2.1-r11
new file mode 100644
index 000000000000..430b21a5c3b2
--- /dev/null
+++ b/dev-java/jython/files/digest-jython-2.1-r11
@@ -0,0 +1,3 @@
+MD5 74f21a0185135396c71453bc279c179f jython-2.1.tar.bz2 1301528
+RMD160 94ae22604c1a816af7d066f2ed88b2abaf5c51d1 jython-2.1.tar.bz2 1301528
+SHA256 faa57a55d137268e80221cd628b234ca67de13504b813be1c0499c9f4d5872b2 jython-2.1.tar.bz2 1301528
diff --git a/dev-java/jython/jython-2.1-r11.ebuild b/dev-java/jython/jython-2.1-r11.ebuild
new file mode 100644
index 000000000000..a68607160210
--- /dev/null
+++ b/dev-java/jython/jython-2.1-r11.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/jython-2.1-r11.ebuild,v 1.1 2007/01/18 15:40:20 caster Exp $
+
+inherit base java-pkg-2
+
+DESCRIPTION="An implementation of Python written in Java"
+HOMEPAGE="http://www.jython.org"
+MY_PV="21"
+#SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.class"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="JPython"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="readline source doc"
+# servlet
+
+CDEPEND="=dev-java/jakarta-oro-2.0*
+ readline? ( >=dev-java/libreadline-java-0.8.0 )"
+# servlet? ( >=net-www/tomcat-5.0 )
+RDEPEND=">=virtual/jre-1.4
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ source? ( app-arch/zip )
+ ${CDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PV}-assert.patch
+ epatch ${FILESDIR}/${PV}-assert-SimpleCompiler.py.patch
+
+ # bug #160861
+ rm -rf org/apache
+}
+
+
+src_compile() {
+ local cp="$(java-pkg_getjars jakarta-oro-2.0)"
+ local exclude=""
+
+ if use readline ; then
+ cp=${cp}:$(java-pkg_getjars libreadline-java)
+ else
+ exclude="${exclude} ! -name ReadlineConsole.java"
+ fi
+
+ #if use servlet; then
+ # cp=${cp}:$(java-pkg_getjars servlet)
+ #else
+ exclude="${exclude} ! -name PyServlet.java"
+ #fi
+
+ ejavac -classpath ${cp} -nowarn $(find org -name "*.java" ${exclude})
+
+ find org -name "*.class" | xargs jar cf ${PN}.jar
+
+ # bug 115551
+ cd Lib/jxxload_help
+ ejavac -classpath ${S}/${PN}.jar -nowarn *.java
+ rm -f *.java Makefile
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ dodoc README.txt NEWS ACKNOWLEDGMENTS
+ use doc && java-pkg_dohtml -A .css .jpg .gif -r Doc/*
+
+ java-pkg_dolauncher jythonc \
+ --main "org.python.util.jython" \
+ --java_args "-Dpython.home=/usr/share/jython" \
+ --pkg_args "/usr/share/jython/tools/jythonc/jythonc.py"
+
+ java-pkg_dolauncher jython \
+ --main "org.python.util.jython" \
+ --java_args "-Dpython.home=/usr/share/jython"
+
+ dodir /usr/share/jython/cachedir
+ chmod a+rw ${D}/usr/share/jython/cachedir
+
+ rm Demo/jreload/example.jar
+ insinto /usr/share/${PN}
+ doins -r Lib Demo registry
+
+ insinto /usr/share/${PN}/tools
+ doins -r Tools/*
+
+ use source && java-pkg_dosrc com org
+}
+
+pkg_postinst() {
+ if use readline; then
+ elog "To use readline you need to add the following to your registery"
+ elog
+ elog "python.console=org.python.util.ReadlineConsole"
+ elog "python.console.readlinelib=GnuReadline"
+ elog
+ elog "The global registry can be found in /usr/share/${PN}/registry"
+ elog "User registry in \$HOME/.jython"
+ elog "See http://www.jython.org/docs/registry.html for more information"
+ elog ""
+ fi
+
+ elog "This revision renames org.python.core.Py.assert to assert_."
+ elog "This is the solution that upstream will use in the next release."
+ elog "Just note that this revision is not API compatible with vanilla 2.1."
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=142099"
+}