summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2007-03-11 19:34:03 +0000
committerJoshua Nichols <nichoj@gentoo.org>2007-03-11 19:34:03 +0000
commit510e21f0bfcfe0029a4ca67137406619d6317c92 (patch)
treebfd7e0d78c75a4878284c4e8adc830a13d799d7b /dev-java/jline
parentVersion bump #170385 by Wolfram Schlich. (diff)
downloadgentoo-2-510e21f0bfcfe0029a4ca67137406619d6317c92.tar.gz
gentoo-2-510e21f0bfcfe0029a4ca67137406619d6317c92.tar.bz2
gentoo-2-510e21f0bfcfe0029a4ca67137406619d6317c92.zip
Version bump.
(Portage version: 2.1.2-r12)
Diffstat (limited to 'dev-java/jline')
-rw-r--r--dev-java/jline/ChangeLog7
-rw-r--r--dev-java/jline/files/digest-jline-0.9.913
-rw-r--r--dev-java/jline/jline-0.9.91.ebuild59
3 files changed, 68 insertions, 1 deletions
diff --git a/dev-java/jline/ChangeLog b/dev-java/jline/ChangeLog
index 61eefedf51b0..62da00772b80 100644
--- a/dev-java/jline/ChangeLog
+++ b/dev-java/jline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/jline
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jline/ChangeLog,v 1.12 2007/03/08 00:39:54 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jline/ChangeLog,v 1.13 2007/03/11 19:34:03 nichoj Exp $
+
+*jline-0.9.91 (11 Mar 2007)
+
+ 11 Mar 2007; Joshua Nichols <nichoj@gentoo.org> +jline-0.9.91.ebuild:
+ Version bump.
08 Mar 2007; Joshua Nichols <nichoj@gentoo.org> jline-0.9.9-r1.ebuild:
Stable on amd64. See bug #168849.
diff --git a/dev-java/jline/files/digest-jline-0.9.91 b/dev-java/jline/files/digest-jline-0.9.91
new file mode 100644
index 000000000000..0dc44e5f66a0
--- /dev/null
+++ b/dev-java/jline/files/digest-jline-0.9.91
@@ -0,0 +1,3 @@
+MD5 787330d1975c0d58a94ab84b5378d521 jline-0.9.91.zip 750026
+RMD160 6181274bdc13a196f05990e85dc33d337047bdef jline-0.9.91.zip 750026
+SHA256 c9086800211ba4a55a62055967cb467078c626cad31916270204691f31e4c74b jline-0.9.91.zip 750026
diff --git a/dev-java/jline/jline-0.9.91.ebuild b/dev-java/jline/jline-0.9.91.ebuild
new file mode 100644
index 000000000000..0c4bcb7ed351
--- /dev/null
+++ b/dev-java/jline/jline-0.9.91.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jline/jline-0.9.91.ebuild,v 1.1 2007/03/11 19:34:03 nichoj Exp $
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Java library for handling console input"
+HOMEPAGE="http://jline.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ test? ( dev-java/ant-junit )"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${P}/src"
+
+src_unpack() {
+ unpack ${A}
+ rm ${P}/*.jar
+ cd ${S}
+ # we don't support maven for building yet. this build.xml was generated by:
+ # - mvn ant:ant
+ # - tweak build.xml to not load properties from home dir
+ # - tweak the test target to match the test cases
+ # - change maven.repo.local from ~/.maven to "lib" in .properties
+ # - change classpath definitions to "*.jar"
+ cp ${FILESDIR}/maven-build.xml build.xml || die "failed to copy build.xml"
+ cp ${FILESDIR}/maven-build.properties . || die
+ java-ant_ignore-system-classes
+
+ mkdir lib
+ cd lib
+ use test && java-pkg_jar-from --build-only junit
+}
+
+src_compile() {
+ # precompiled javadocs (needs maven to generate)
+ # -Dmaven.build.finalName is needed to override the one defined in the
+ # build.xml, which because it was generated with 0.9.9, defaults to
+ # jline-0.9.9 -nichoj
+ eant package -Dmaven.build.finalName=${P}
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+ use doc && java-pkg_dojavadoc ../apidocs
+ use source && java-pkg_dosrc src/main/java
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test -Djunit.present=true
+}