summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-12-12 11:36:16 +0000
committerVlastimil Babka <caster@gentoo.org>2010-12-12 11:36:16 +0000
commitce2a25bb533ba0b0cf679be1bf013f5d26151512 (patch)
tree67df59b17d96dddd7bc75fdaa5e2b4ab738485d9 /dev-java/icedtea
parentVersion bump, bug #348376. (diff)
downloadgentoo-2-ce2a25bb533ba0b0cf679be1bf013f5d26151512.tar.gz
gentoo-2-ce2a25bb533ba0b0cf679be1bf013f5d26151512.tar.bz2
gentoo-2-ce2a25bb533ba0b0cf679be1bf013f5d26151512.zip
Add patch for sparc, bug #344659.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/icedtea')
-rw-r--r--dev-java/icedtea/ChangeLog6
-rw-r--r--dev-java/icedtea/files/6.1.9.3-sparc.patch29
-rw-r--r--dev-java/icedtea/icedtea-6.1.9.3.ebuild9
3 files changed, 41 insertions, 3 deletions
diff --git a/dev-java/icedtea/ChangeLog b/dev-java/icedtea/ChangeLog
index b9083244ece2..2eb10a35ce53 100644
--- a/dev-java/icedtea/ChangeLog
+++ b/dev-java/icedtea/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/icedtea
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/ChangeLog,v 1.16 2010/12/02 19:38:54 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/ChangeLog,v 1.17 2010/12/12 11:36:16 caster Exp $
+
+ 12 Dec 2010; Vlastimil Babka <caster@gentoo.org> +files/6.1.9.3-sparc.patch,
+ icedtea-6.1.9.3.ebuild:
+ Add patch for sparc, bug #344659.
02 Dec 2010; Vlastimil Babka <caster@gentoo.org> icedtea-6.1.9.3.ebuild,
metadata.xml:
diff --git a/dev-java/icedtea/files/6.1.9.3-sparc.patch b/dev-java/icedtea/files/6.1.9.3-sparc.patch
new file mode 100644
index 000000000000..e0af5bb0ee9c
--- /dev/null
+++ b/dev-java/icedtea/files/6.1.9.3-sparc.patch
@@ -0,0 +1,29 @@
+diff -Nru icedtea6-1.9.3.old/Makefile.am icedtea6-1.9.3/Makefile.am
+--- icedtea6-1.9.3.old/Makefile.am 2010-12-01 19:09:51.959606503 +0000
++++ icedtea6-1.9.3/Makefile.am 2010-12-07 12:51:29.306308677 +0000
+@@ -317,7 +317,8 @@
+ patches/openjdk/6876282-bigdecimal_divide.patch \
+ patches/f14-fonts.patch \
+ patches/applet_hole.patch \
+- patches/openjdk/7002666-eclipse_cdt_oops_crash.patch
++ patches/openjdk/7002666-eclipse_cdt_oops_crash.patch \
++ patches/g344659-sparc_fscanf_fix.patch
+
+ if WITH_ALT_HSBUILD
+ ICEDTEA_PATCHES += \
+diff -Nru icedtea6-1.9.3.old/patches/g255873-sparc_fscanf_fix.patch icedtea6-1.9.3/patches/g255873-sparc_fscanf_fix.patch
+--- icedtea6-1.9.3.old/patches/g344659-sparc_fscanf_fix.patch 1970-01-01 01:00:00.000000000 +0100
++++ icedtea6-1.9.3/patches/g344659-sparc_fscanf_fix.patch 2010-12-07 12:52:39.213034154 +0000
+@@ -0,0 +1,12 @@
++diff -uNr openjdk.orig/hotspot/src/os_cpu/linux_sparc/vm/vm_version_linux_sparc.cpp openjdk/hotspot/src/os_cpu/linux_sparc/vm/vm_version_linux_sparc.cpp
++--- openjdk.orig/hotspot/src/os_cpu/linux_sparc/vm/vm_version_linux_sparc.cpp 2010-06-21 22:12:15.000000000 +0100
+++++ openjdk/hotspot/src/os_cpu/linux_sparc/vm/vm_version_linux_sparc.cpp 2010-11-29 20:15:36.179541001 +0000
++@@ -35,7 +35,7 @@
++ }
++
++ while (!feof(fp)) {
++- if (fscanf(fp, "cpu\t\t: %100[^\n]", &cpu) == 1) {
+++ if (fscanf(fp, "cpu\t\t: %100[^\n]", &cpu[0]) == 1) {
++ if (strstr(cpu, "Niagara") != NULL) {
++ rv = true;
++ }
diff --git a/dev-java/icedtea/icedtea-6.1.9.3.ebuild b/dev-java/icedtea/icedtea-6.1.9.3.ebuild
index 45e1f8161d8f..bec174be2138 100644
--- a/dev-java/icedtea/icedtea-6.1.9.3.ebuild
+++ b/dev-java/icedtea/icedtea-6.1.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/icedtea-6.1.9.3.ebuild,v 1.2 2010/12/02 19:38:54 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/icedtea-6.1.9.3.ebuild,v 1.3 2010/12/12 11:36:16 caster Exp $
# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
# *********************************************************
@@ -9,7 +9,7 @@
EAPI="2"
-inherit pax-utils java-pkg-2 java-vm-2 versionator
+inherit autotools pax-utils java-pkg-2 java-vm-2 versionator
LICENSE="Apache-1.1 Apache-2.0 GPL-1 GPL-2 GPL-2-with-linking-exception LGPL-2 MPL-1.0 MPL-1.1 public-domain W3C"
SLOT="6"
@@ -169,6 +169,11 @@ unset_vars() {
unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
}
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-sparc.patch"
+ eautoreconf
+}
+
src_configure() {
local config procs rhino_jar
local vm=$(java-pkg_get-current-vm)