summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2014-07-30 18:35:05 +0000
committerRalph Sennhauser <sera@gentoo.org>2014-07-30 18:35:05 +0000
commit9e668706af00a477a47fafb50c9ea0c5a7b9ec2d (patch)
tree4be7ddd566c7a08290ed105e8490c9a5b3b3bece /dev-java/htmlparser
parentStable for amd64 wrt bug #518290 (diff)
downloadgentoo-2-9e668706af00a477a47fafb50c9ea0c5a7b9ec2d.tar.gz
gentoo-2-9e668706af00a477a47fafb50c9ea0c5a7b9ec2d.tar.bz2
gentoo-2-9e668706af00a477a47fafb50c9ea0c5a7b9ec2d.zip
Use recent icu4j
Cleanup ebuild, bump EAPI to 5 Remove old (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 3C5CF75A)
Diffstat (limited to 'dev-java/htmlparser')
-rw-r--r--dev-java/htmlparser/ChangeLog12
-rw-r--r--dev-java/htmlparser/htmlparser-1.3.1.ebuild48
-rw-r--r--dev-java/htmlparser/htmlparser-1.4-r1.ebuild45
-rw-r--r--dev-java/htmlparser/htmlparser-1.4.ebuild48
4 files changed, 55 insertions, 98 deletions
diff --git a/dev-java/htmlparser/ChangeLog b/dev-java/htmlparser/ChangeLog
index 17bc2cd471da..1ec85b093a1c 100644
--- a/dev-java/htmlparser/ChangeLog
+++ b/dev-java/htmlparser/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/htmlparser
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/htmlparser/ChangeLog,v 1.9 2013/07/08 14:11:01 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/htmlparser/ChangeLog,v 1.10 2014/07/30 18:35:05 sera Exp $
+
+*htmlparser-1.4-r1 (30 Jul 2014)
+
+ 30 Jul 2014; Ralph Sennhauser <sera@gentoo.org> -htmlparser-1.3.1.ebuild,
+ -htmlparser-1.4.ebuild, +htmlparser-1.4-r1.ebuild:
+ Use recent icu4j
+ Cleanup ebuild, bump EAPI to 5
+ Remove old
*htmlparser-1.4 (08 Jul 2013)
diff --git a/dev-java/htmlparser/htmlparser-1.3.1.ebuild b/dev-java/htmlparser/htmlparser-1.3.1.ebuild
deleted file mode 100644
index 8d85e7e4c961..000000000000
--- a/dev-java/htmlparser/htmlparser-1.3.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/htmlparser/htmlparser-1.3.1.ebuild,v 1.1 2012/02/23 20:15:28 nelchael Exp $
-
-EAPI=4
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Implementation of the HTML5 parsing algorithm in Java"
-HOMEPAGE="http://about.validator.nu/htmlparser/"
-SRC_URI="http://about.validator.nu/${PN}/${P}.zip"
-
-LICENSE="W3C"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE=""
-
-COMMON_DEP="dev-java/icu4j:4
- dev-java/xom
- dev-java/jchardet"
-
-RDEPEND=">=virtual/jre-1.5
- ${COMMON_DEP}"
-DEPEND=">=virtual/jdk-1.5
- app-arch/unzip
- ${COMMON_DEP}"
-
-src_prepare() {
- rm -f *.jar
- mkdir -p "${S}/build" || die "mkdir failed"
- mkdir -p "${S}/lib" || die "mkdir failed"
-
- cp "${FILESDIR}/build.xml" "${S}" || die "cp failed"
-
- java-pkg_jarfrom --into lib/ icu4j-4
- java-pkg_jarfrom --into lib/ xom
- java-pkg_jarfrom --into lib/ jchardet
-}
-
-src_install() {
- java-pkg_dojar htmlparser.jar
-
- use source && java-pkg_dosrc src/*
- use doc && java-pkg_dojavadoc docs
-}
diff --git a/dev-java/htmlparser/htmlparser-1.4-r1.ebuild b/dev-java/htmlparser/htmlparser-1.4-r1.ebuild
new file mode 100644
index 000000000000..47b7ec7ee013
--- /dev/null
+++ b/dev-java/htmlparser/htmlparser-1.4-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/htmlparser/htmlparser-1.4-r1.ebuild,v 1.1 2014/07/30 18:35:05 sera Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Implementation of the HTML5 parsing algorithm in Java"
+HOMEPAGE="http://about.validator.nu/htmlparser/"
+SRC_URI="http://about.validator.nu/${PN}/${P}.zip"
+
+LICENSE="W3C"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/icu4j:52
+ dev-java/jchardet:0
+ dev-java/xom:0"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.5"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+java_prepare() {
+ find "${WORKDIR}" -name '*.jar' -delete || die
+ mkdir -p build lib || die
+ cp "${FILESDIR}/build.xml" build.xml || die "cp failed"
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+EANT_GENTOO_CLASSPATH="icu4j-52,xom,jchardet"
+
+src_install() {
+ java-pkg_dojar htmlparser.jar
+
+ use source && java-pkg_dosrc src/*
+ use doc && java-pkg_dojavadoc docs
+}
diff --git a/dev-java/htmlparser/htmlparser-1.4.ebuild b/dev-java/htmlparser/htmlparser-1.4.ebuild
deleted file mode 100644
index a43e82b57937..000000000000
--- a/dev-java/htmlparser/htmlparser-1.4.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/htmlparser/htmlparser-1.4.ebuild,v 1.6 2013/07/08 14:11:01 tomwij Exp $
-
-EAPI=4
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Implementation of the HTML5 parsing algorithm in Java"
-HOMEPAGE="http://about.validator.nu/htmlparser/"
-SRC_URI="http://about.validator.nu/${PN}/${P}.zip"
-
-LICENSE="W3C"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE=""
-
-COMMON_DEP="dev-java/icu4j:4
- dev-java/xom
- dev-java/jchardet"
-
-RDEPEND=">=virtual/jre-1.5
- ${COMMON_DEP}"
-DEPEND=">=virtual/jdk-1.5
- app-arch/unzip
- ${COMMON_DEP}"
-
-src_prepare() {
- rm -f *.jar
- mkdir -p "${S}/build" || die "mkdir failed"
- mkdir -p "${S}/lib" || die "mkdir failed"
-
- cp "${FILESDIR}/build.xml" "${S}" || die "cp failed"
-
- java-pkg_jarfrom --into lib/ icu4j-4
- java-pkg_jarfrom --into lib/ xom
- java-pkg_jarfrom --into lib/ jchardet
-}
-
-src_install() {
- java-pkg_dojar htmlparser.jar
-
- use source && java-pkg_dosrc src/*
- use doc && java-pkg_dojavadoc docs
-}