summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-03 02:30:13 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-03 02:30:13 +0000
commitd70b788cf580da480b8ef8f3e7e849296176f0d9 (patch)
tree5c93f30d08b289f57c0aa586a8f373893147bdd3 /dev-java/commons-pool
parentFix use invocation (Manifest recommit) (diff)
downloadgentoo-2-d70b788cf580da480b8ef8f3e7e849296176f0d9.tar.gz
gentoo-2-d70b788cf580da480b8ef8f3e7e849296176f0d9.tar.bz2
gentoo-2-d70b788cf580da480b8ef8f3e7e849296176f0d9.zip
Fix use invocation
Diffstat (limited to 'dev-java/commons-pool')
-rw-r--r--dev-java/commons-pool/ChangeLog5
-rw-r--r--dev-java/commons-pool/commons-pool-1.1.ebuild10
2 files changed, 9 insertions, 6 deletions
diff --git a/dev-java/commons-pool/ChangeLog b/dev-java/commons-pool/ChangeLog
index 6cb7fdd92fff..e1c54dec32f8 100644
--- a/dev-java/commons-pool/ChangeLog
+++ b/dev-java/commons-pool/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-java/commons-pool
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.14 2004/04/17 02:50:45 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.15 2004/06/03 02:30:13 agriffis Exp $
+
+ 02 Jun 2004; Aron Griffis <agriffis@gentoo.org> commons-pool-1.1.ebuild:
+ Fix use invocation
16 Apr 2004; Jason Wever <weeve@gentoo.org> commons-pool-1.1.ebuild:
Stable on sparc.
diff --git a/dev-java/commons-pool/commons-pool-1.1.ebuild b/dev-java/commons-pool/commons-pool-1.1.ebuild
index 7dd08c00c4f4..a9e68460be3a 100644
--- a/dev-java/commons-pool/commons-pool-1.1.ebuild
+++ b/dev-java/commons-pool/commons-pool-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.1.ebuild,v 1.5 2004/05/14 03:18:30 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.1.ebuild,v 1.6 2004/06/03 02:30:13 agriffis Exp $
inherit java-pkg
@@ -25,18 +25,18 @@ src_compile() {
echo "commons-collections.jar=`java-config --classpath=commons-collections`" > build.properties
- if [ -n "`use jikes`" ] ; then
+ if use jikes ; then
myc="${myc} -Dbuild.compiler=jikes"
fi
- if [ -n "`use junit`" ] ; then
+ if use junit ; then
echo "junit.jar=`java-config --classpath=junit`" >> build.properties
ANT_OPTS=${myc} ant || die "Testing Classes Failed"
fi
ANT_OPTS=${myc} ant dist || die "Compilation Failed"
- if [ -n "`use doc`" ] ; then
+ if use doc ; then
ANT_OPTS=${myc} ant javadoc || die "Unable to create documents"
fi
}
@@ -46,7 +46,7 @@ src_install () {
dodoc README.txt
dohtml STATUS.html PROPOSAL.html
- if [ -n "`use doc`" ] ; then
+ if use doc ; then
dohtml -r dist/docs/*
fi
}