summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-11-02 22:04:58 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-11-02 22:04:58 +0000
commit5aa79e1f3052e2686d5c6c982e570127f2e98c96 (patch)
tree6af0bc817dcf198f6a7902995c6efa9bb27686c4 /dev-java/commons-collections/commons-collections-2.1-r1.ebuild
parentFixes #10099. (diff)
downloadgentoo-2-5aa79e1f3052e2686d5c6c982e570127f2e98c96.tar.gz
gentoo-2-5aa79e1f3052e2686d5c6c982e570127f2e98c96.tar.bz2
gentoo-2-5aa79e1f3052e2686d5c6c982e570127f2e98c96.zip
Fixes #10097.
Diffstat (limited to 'dev-java/commons-collections/commons-collections-2.1-r1.ebuild')
-rw-r--r--dev-java/commons-collections/commons-collections-2.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/commons-collections/commons-collections-2.1-r1.ebuild b/dev-java/commons-collections/commons-collections-2.1-r1.ebuild
new file mode 100644
index 000000000000..60f5bd71f4ec
--- /dev/null
+++ b/dev-java/commons-collections/commons-collections-2.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/commons-collections-2.1-r1.ebuild,v 1.1 2002/11/02 22:04:58 karltk Exp $
+
+S=${WORKDIR}/${PN}-${PV}-src
+DESCRIPTION="Jakarta-Commons Collections Component"
+HOMEPAGE="http://jakarta.apache.org/commons/collections.html"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=ant-1.4
+ junit? ( >=junit-3.7 )"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+IUSE="jikes junit"
+
+src_compile() {
+ local myc
+
+ if [ -n "`use jikes`" ] ; then
+ myc="${myc} -Dbuild.compiler=jikes"
+ fi
+
+ if [ -n "`use junit`" ] ; then
+ echo "junit.jar=`java-config --classpath=junit`" > build.properties
+ ANT_OPTS=${myc} ant || die "Testing Classes Failed"
+ fi
+
+ ANT_OPTS=${myc} ant dist-jar || die "Compilation Failed"
+ ANT_OPTS=${myc} ant doc || die "Unable to create documents"
+}
+
+src_install () {
+ dojar dist/${PN}*.jar || die "Unable to Install"
+ dohtml dist/*.html
+ dohtml -r dist/docs/*
+}
+
+pkg_postinst() {
+ einfo "**************** Documentation can be found at ******************\n
+ WEB: ${HOMEPAGE}\n
+ LOCAL: /usr/share/doc/${PF}\n
+ *****************************************************************"
+}