summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-07-22 22:29:27 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-07-22 22:29:27 +0000
commitc31a867670036fb882d27961ad7c73cfe5f2cb05 (patch)
tree6c4bb5c4b6986befc834cf58cf6a9cb12ccce304 /dev-java/commons-codec
parentstable on mips (diff)
downloadgentoo-2-c31a867670036fb882d27961ad7c73cfe5f2cb05.tar.gz
gentoo-2-c31a867670036fb882d27961ad7c73cfe5f2cb05.tar.bz2
gentoo-2-c31a867670036fb882d27961ad7c73cfe5f2cb05.zip
Migrated to Generation 2.
(Portage version: 2.1.1_pre3-r3)
Diffstat (limited to 'dev-java/commons-codec')
-rw-r--r--dev-java/commons-codec/ChangeLog10
-rw-r--r--dev-java/commons-codec/commons-codec-1.3-r1.ebuild51
-rw-r--r--dev-java/commons-codec/files/digest-commons-codec-1.32
-rw-r--r--dev-java/commons-codec/files/digest-commons-codec-1.3-r13
4 files changed, 64 insertions, 2 deletions
diff --git a/dev-java/commons-codec/ChangeLog b/dev-java/commons-codec/ChangeLog
index ed367a8a7a2a..dc904dc2aa0b 100644
--- a/dev-java/commons-codec/ChangeLog
+++ b/dev-java/commons-codec/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-codec
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-codec/ChangeLog,v 1.17 2005/07/10 13:07:12 axxo Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-codec/ChangeLog,v 1.18 2006/07/22 22:29:27 nelchael Exp $
+
+*commons-codec-1.3-r1 (22 Jul 2006)
+
+ 22 Jul 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +commons-codec-1.3-r1.ebuild:
+ Migrated to Generation 2.
10 Jul 2005; Thomas Matthijs <axxo@gentoo.org> commons-codec-1.3.ebuild:
fix deps, cleanup
diff --git a/dev-java/commons-codec/commons-codec-1.3-r1.ebuild b/dev-java/commons-codec/commons-codec-1.3-r1.ebuild
new file mode 100644
index 000000000000..314a888ceb08
--- /dev/null
+++ b/dev-java/commons-codec/commons-codec-1.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-codec/commons-codec-1.3-r1.ebuild,v 1.1 2006/07/22 22:29:27 nelchael Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Common Codecs provides implementations of common encoders and decoders such as Base64, Hex, various phonetic encodings, and URLs"
+HOMEPAGE="http://jakarta.apache.org/commons/codec/"
+SRC_URI="mirror://apache/jakarta/commons/codec/source/${P}-src.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc source"
+
+RDEPEND=">=virtual/jre-1.3
+ =dev-java/avalon-logkit-1.2*
+ dev-java/log4j"
+
+DEPEND=">=virtual/jdk-1.3
+ ${RDEPEND}
+ dev-java/ant-core
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s_../LICENSE_LICENSE.txt_" build.xml || die "sed failed"
+ echo "conf.home=./src/conf" >> build.properties
+ echo "source.home=./src/java" >> build.properties
+ echo "build.home=./output" >> build.properties
+ echo "dist.home=./output/dist" >> build.properties
+ echo "test.home=./src/test" >> build.properties
+ echo "final.name=commons-codec" >> build.properties
+}
+
+src_compile() {
+ local antflags="compile"
+ use doc && antflags="${antflags} javadoc"
+ eant ${antflags} jar || die "compile problem"
+}
+
+src_install() {
+ java-pkg_dojar output/dist/${PN}.jar
+
+ dodoc RELEASE-NOTES.txt
+ use doc && java-pkg_dohtml -r output/dist/docs/
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-codec/files/digest-commons-codec-1.3 b/dev-java/commons-codec/files/digest-commons-codec-1.3
index 83534fa668fb..88533316f5a8 100644
--- a/dev-java/commons-codec/files/digest-commons-codec-1.3
+++ b/dev-java/commons-codec/files/digest-commons-codec-1.3
@@ -1 +1,3 @@
MD5 ac19a5dc22b1293b39d0445ad08c4ce7 commons-codec-1.3-src.tar.gz 88242
+RMD160 84cfc6f02d991b5a7013902637aec5caaa29c823 commons-codec-1.3-src.tar.gz 88242
+SHA256 47e485a942e1f6f3f2a2b526e77667cbccbf507aeb63e129f54dfc77b5b645f4 commons-codec-1.3-src.tar.gz 88242
diff --git a/dev-java/commons-codec/files/digest-commons-codec-1.3-r1 b/dev-java/commons-codec/files/digest-commons-codec-1.3-r1
new file mode 100644
index 000000000000..88533316f5a8
--- /dev/null
+++ b/dev-java/commons-codec/files/digest-commons-codec-1.3-r1
@@ -0,0 +1,3 @@
+MD5 ac19a5dc22b1293b39d0445ad08c4ce7 commons-codec-1.3-src.tar.gz 88242
+RMD160 84cfc6f02d991b5a7013902637aec5caaa29c823 commons-codec-1.3-src.tar.gz 88242
+SHA256 47e485a942e1f6f3f2a2b526e77667cbccbf507aeb63e129f54dfc77b5b645f4 commons-codec-1.3-src.tar.gz 88242