summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-08-13 21:29:23 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-08-13 21:29:23 +0000
commitd825b626c5938d551289be15caa0ad22101e58fe (patch)
treec97e26f3bf7498c26da5c373ec92e426cba3f5bb /dev-java/commons-codec/commons-codec-1.3.ebuild
parentStable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-d825b626c5938d551289be15caa0ad22101e58fe.tar.gz
gentoo-2-d825b626c5938d551289be15caa0ad22101e58fe.tar.bz2
gentoo-2-d825b626c5938d551289be15caa0ad22101e58fe.zip
Version bump
Diffstat (limited to 'dev-java/commons-codec/commons-codec-1.3.ebuild')
-rw-r--r--dev-java/commons-codec/commons-codec-1.3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-java/commons-codec/commons-codec-1.3.ebuild b/dev-java/commons-codec/commons-codec-1.3.ebuild
new file mode 100644
index 000000000000..0fd7fa64620f
--- /dev/null
+++ b/dev-java/commons-codec/commons-codec-1.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-codec/commons-codec-1.3.ebuild,v 1.1 2004/08/13 21:29:23 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Common Codecs provides implementations of common encoders and decoders such as Base64, Hex, various phonetic encodings, and URLs"
+HOMEPAGE="http://jakarta.apache.org/commons/codec/"
+SRC_URI="mirror://apache/jakarta/commons/codec/source/${PN}-${PV}-src.tar.gz"
+
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/log4j-1.2.5
+ dev-java/avalon-logkit-bin
+ >=dev-java/ant-1.4
+ jikes? ( dev-java/jikes )
+ junit? ( >=dev-java/junit-3.7 )"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="doc jikes junit"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp build.xml build.xml.b0rken
+ sed -r "s_../LICENSE_LICENSE.txt_" \
+ < build.xml.b0rken \
+ > build.xml
+ echo "junit.jar=`java-config -p junit`" > build.properties
+ echo "conf.home=./src/conf" >> build.properties
+ echo "source.home=./src/java" >> build.properties
+ echo "build.home=./output" >> build.properties
+ echo "dist.home=./output/dist" >> build.properties
+ echo "test.home=./src/test" >> build.properties
+ echo "final.name=commons-codec" >> build.properties
+}
+
+src_compile() {
+ local antflags="compile"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ use junit && antflags="${antflags} test"
+ echo ${antflags}
+ ant ${antflags} jar || die "compile problem"
+}
+
+src_install() {
+ java-pkg_dojar output/dist/${PN}.jar
+
+ dodoc RELEASE-NOTES.txt
+ use doc && dohtml -r output/dist/docs/
+}