summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-06-02 16:25:12 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-06-02 16:25:12 +0000
commit40f28c47f2f6bc6547f87f8bdad7bac4e1290028 (patch)
treefbcbc68f93a9075c784dd1e9bc23d4734b85f03e /dev-java/ant-core
parentremoved unused digest (diff)
downloadgentoo-2-40f28c47f2f6bc6547f87f8bdad7bac4e1290028.tar.gz
gentoo-2-40f28c47f2f6bc6547f87f8bdad7bac4e1290028.tar.bz2
gentoo-2-40f28c47f2f6bc6547f87f8bdad7bac4e1290028.zip
prune
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/ant-core')
-rw-r--r--dev-java/ant-core/ChangeLog6
-rw-r--r--dev-java/ant-core/ant-core-1.6.3-r1.ebuild74
-rw-r--r--dev-java/ant-core/ant-core-1.6.4.ebuild74
-rw-r--r--dev-java/ant-core/files/1.6.3-ant169
-rw-r--r--dev-java/ant-core/files/1.6.4-ant169
-rw-r--r--dev-java/ant-core/files/digest-ant-core-1.6.3-r11
-rw-r--r--dev-java/ant-core/files/digest-ant-core-1.6.41
7 files changed, 5 insertions, 489 deletions
diff --git a/dev-java/ant-core/ChangeLog b/dev-java/ant-core/ChangeLog
index b33fd7f10806..ee22d8ca62f4 100644
--- a/dev-java/ant-core/ChangeLog
+++ b/dev-java/ant-core/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/ant-core
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ChangeLog,v 1.24 2005/06/02 16:21:30 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ChangeLog,v 1.25 2005/06/02 16:24:48 axxo Exp $
+
+ 02 Jun 2005; Thomas Matthijs <axxo@gentoo.org> -files/1.6.3-ant,
+ -files/1.6.4-ant, -ant-core-1.6.3-r1.ebuild, -ant-core-1.6.4.ebuild:
+ prune
*ant-core-1.6.5 (02 Jun 2005)
diff --git a/dev-java/ant-core/ant-core-1.6.3-r1.ebuild b/dev-java/ant-core/ant-core-1.6.3-r1.ebuild
deleted file mode 100644
index a12d2a55cbdd..000000000000
--- a/dev-java/ant-core/ant-core-1.6.3-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.6.3-r1.ebuild,v 1.1 2005/05/14 16:09:55 luckyduck Exp $
-
-inherit java-pkg eutils
-
-MY_PN=${PN/-core}
-
-MY_PV=${PV/_/}
-
-DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
-HOMEPAGE="http://ant.apache.org/"
-SRC_URI="mirror://apache/ant/source/apache-${MY_PN}-${PV}-src.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~ppc64"
-IUSE="doc"
-
-DEPEND="virtual/libc
- >=virtual/jdk-1.4
- >=dev-java/java-config-1.2"
-RDEPEND=">=virtual/jdk-1.4
- app-shells/bash
- >=dev-java/java-config-1.2"
-
-S="${WORKDIR}/apache-ant-${MY_PV}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # Patch build.sh to die with non-zero exit code in case of errors.
- # This patch may be useful for all ant versions.
- epatch ${FILESDIR}/build.sh-exit-fix.patch.gz
-}
-
-src_compile() {
- addwrite "/proc/self/maps"
- if [ `arch` == "ppc" ] ; then
- # We're compiling _ON_ PPC
- export THREADS_FLAG="green"
- fi
-
-
- local myc
- myc="${myc} -Ddist.dir=${D}/usr/share/${PN}"
- myc="${myc} -Djavac.target=1.4"
- echo $CLASSPATH
- CLASSPATH="." ./build.sh -Ddist.dir=${D}/usr/share/${PN} || die
-
- use doc && ./build.sh dist_javadocs
-}
-
-src_install() {
- newbin ${FILESDIR}/${PV/_*}-ant ant || die "failed to install wrapper"
-
- dodir /usr/share/${PN}/bin
- for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
- dobin ${S}/src/script/${each}
- dosym /usr/bin/${each} /usr/share/${PN}/bin/${each}
- done
-
- dodir /etc/env.d
- echo "ANT_HOME=\"/usr/share/${PN}\"" > ${D}/etc/env.d/20ant
-
- java-pkg_dojar build/lib/ant.jar
- java-pkg_dojar build/lib/ant-launcher.jar
-
- dodoc README WHATSNEW KEYS
- use doc && dohtml welcome.html
- use doc && java-pkg_dohtml -r docs/*
- use doc && java-pkg_dohtml -r dist/docs/manual/api/*
-}
diff --git a/dev-java/ant-core/ant-core-1.6.4.ebuild b/dev-java/ant-core/ant-core-1.6.4.ebuild
deleted file mode 100644
index 21f702302514..000000000000
--- a/dev-java/ant-core/ant-core-1.6.4.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.6.4.ebuild,v 1.1 2005/05/23 15:27:38 axxo Exp $
-
-inherit java-pkg eutils
-
-MY_PN=${PN/-core}
-
-MY_PV=${PV/_/}
-
-DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
-HOMEPAGE="http://ant.apache.org/"
-SRC_URI="mirror://apache/ant/source/apache-${MY_PN}-${PV}-src.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~ppc64"
-IUSE="doc"
-
-DEPEND="virtual/libc
- >=virtual/jdk-1.4
- >=dev-java/java-config-1.2"
-RDEPEND=">=virtual/jdk-1.4
- app-shells/bash
- >=dev-java/java-config-1.2"
-
-S="${WORKDIR}/apache-ant-${MY_PV}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # Patch build.sh to die with non-zero exit code in case of errors.
- # This patch may be useful for all ant versions.
- epatch ${FILESDIR}/build.sh-exit-fix.patch.gz
-}
-
-src_compile() {
- addwrite "/proc/self/maps"
- if [ `arch` == "ppc" ] ; then
- # We're compiling _ON_ PPC
- export THREADS_FLAG="green"
- fi
-
-
- local myc
- myc="${myc} -Ddist.dir=${D}/usr/share/${PN}"
- myc="${myc} -Djavac.target=1.4"
- echo $CLASSPATH
- CLASSPATH="." ./build.sh -Ddist.dir=${D}/usr/share/${PN} || die
-
- use doc && ./build.sh dist_javadocs
-}
-
-src_install() {
- newbin ${FILESDIR}/${PV/_*}-ant ant || die "failed to install wrapper"
-
- dodir /usr/share/${PN}/bin
- for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
- dobin ${S}/src/script/${each}
- dosym /usr/bin/${each} /usr/share/${PN}/bin/${each}
- done
-
- dodir /etc/env.d
- echo "ANT_HOME=\"/usr/share/${PN}\"" > ${D}/etc/env.d/20ant
-
- java-pkg_dojar build/lib/ant.jar
- java-pkg_dojar build/lib/ant-launcher.jar
-
- dodoc README WHATSNEW KEYS
- use doc && dohtml welcome.html
- use doc && java-pkg_dohtml -r docs/*
- use doc && java-pkg_dohtml -r dist/docs/manual/api/*
-}
diff --git a/dev-java/ant-core/files/1.6.3-ant b/dev-java/ant-core/files/1.6.3-ant
deleted file mode 100644
index ddab7a81f17d..000000000000
--- a/dev-java/ant-core/files/1.6.3-ant
+++ /dev/null
@@ -1,169 +0,0 @@
-#! /bin/bash
-
-# Copyright 2001-2004 The Apache Software Foundation
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-# Edited for Gentoo Linux
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/files/1.6.3-ant,v 1.3 2005/05/14 16:09:55 luckyduck Exp $
-
-# Extract launch and ant arguments, (see details below).
-ant_exec_args=
-no_config=false
-use_jikes_default=false
-ant_exec_debug=false
-show_help=false
-for arg in "$@" ; do
- if [ "$arg" = "--noconfig" ] ; then
- no_config=true
- elif [ "$arg" = "--usejikes" ] ; then
- use_jikes_default=true
- elif [ "$arg" = "--execdebug" ] ; then
- ant_exec_debug=true
- elif [ my"$arg" = my"--h" -o my"$arg" = my"--help" ] ; then
- show_help=true
- ant_exec_args="$ant_exec_args -h"
- else
- if [ my"$arg" = my"-h" -o my"$arg" = my"-help" ] ; then
- show_help=true
- fi
- ant_exec_args="$ant_exec_args \"$arg\""
- fi
-done
-
-# Source/default ant configuration
-if $no_config ; then
- rpm_mode=false
- usejikes=$use_jikes_default
-else
- # load system-wide ant configuration
- if [ -f "/etc/ant.conf" ] ; then
- . /etc/ant.conf
- fi
-
- # load user ant configuration
- if [ -f "$HOME/.ant/ant.conf" ] ; then
- . $HOME/.ant/ant.conf
- fi
- if [ -f "$HOME/.antrc" ] ; then
- . "$HOME/.antrc"
- fi
-
- # provide default configuration values
- if [ -z "$rpm_mode" ] ; then
- rpm_mode=false
- fi
- if [ -z "$usejikes" ] ; then
- usejikes=$use_jikes_default
- fi
-fi
-
-
-if [ -z $JAVA_HOME ] ; then
- if [ -f $HOME/.gentoo/java-env ] ; then
- source $HOME/.gentoo/java-env
- else
- JAVA_HOME=`java-config --jdk-home`
- CLASSPATH=`java-config --classpath`:${CLASSPATH}
- fi
-fi
-
-if [ -z $JAVA_HOME ] ; then
- echo "Error: No JDK found!"
- echo "Try using java-config script to set your JDK"
- echo "Remember that you need a JDK not a JRE"
- exit 1
-fi
-
-ANT_HOME=/usr/share/ant-core
-
-# set ANT_LIB location
-ANT_LIB="${ANT_HOME}/lib"
-
-JAVACMD="`java-config --java`"
-
-if [ ! -x "$JAVACMD" ] ; then
- echo "Error: JAVA_HOME is not defined correctly."
- echo " We cannot execute $JAVACMD"
- exit 1
-fi
-
-if [ -z "$LOCALCLASSPATH" ] ; then
- LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar
-else
- LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar:$LOCALCLASSPATH
-fi
-
-# add in the dependency .jar files
-LOCALCLASSPATH="${LOCALCLASSPATH}:`java-config --classpath=ant-core,ant-tasks,log4j,xerces-2,xalan,junit,antlr,bcel,bsh,commons-beanutils-1.6,commons-collections,commons-logging,commons-net,jakarta-oro-2.0,jdepend,jsch,jakarta-regexp-1.3,rhino-1.5,jython,jta,jaf,javamail 2> /dev/null`"
-
-if [ -n "$JAVA_HOME" ] ; then
- if [ -f "$JAVA_HOME/lib/tools.jar" ] ; then
- LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/tools.jar"
- fi
-
- if [ -f "$JAVA_HOME/lib/classes.zip" ] ; then
- LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/classes.zip"
- fi
-
-else
- echo "Warning: JAVA_HOME environment variable is not set (or not exported)."
- echo " If build fails because sun.* classes could not be found"
- echo " you will need to set the JAVA_HOME environment variable"
- echo " to the installation directory of java."
- echo " Try using java-config script"
-fi
-
-# Allow Jikes support (off by default)
-if $usejikes; then
- ANT_OPTS="$ANT_OPTS -Dbuild.compiler=jikes"
-fi
-
-# Show script help if requested
-if $show_help ; then
- echo $0 '[script options] [options] [target [target2 [target3] ..]]'
- echo 'Script Options:'
- echo ' --help, --h print this message and ant help'
- echo ' --noconfig suppress sourcing of /etc/ant.conf,'
- echo ' $HOME/.ant/ant.conf, and $HOME/.antrc'
- echo ' configuration files'
- echo ' --usejikes enable use of jikes by default, unless'
- echo ' set explicitly in configuration files'
- echo ' --execdebug print ant exec line generated by this'
- echo ' launch script'
- echo ' '
-fi
-
-# Execute ant using eval/exec to preserve spaces in paths,
-# java options, and ant args
-ant_sys_opts=
-
-
-if [ -n "$JIKESPATH" ]; then
- ant_sys_opts="-Djikes.class.path=\"$JIKESPATH\""
-fi
-
-# 2002-11-02, karltk@gentoo.org:
-# The Blackdown JDK on PPC hiccups with native threads
-#
-if [ "`arch`" == "ppc" ] ; then
- export THREADS_FLAG="green"
-fi
-
-
-ant_exec_command="exec \"$JAVACMD\" $ANT_OPTS -classpath \"$LOCALCLASSPATH\" -Dant.home=\"$ANT_HOME\" -Dant.library.dir=\"$ANT_LIB\" $ant_sys_opts org.apache.tools.ant.launch.Launcher $ANT_ARGS -lib \"$CLASSPATH\" $ant_exec_args"
-
-if $ant_exec_debug ; then
- echo $ant_exec_command
-fi
-eval $ant_exec_command
diff --git a/dev-java/ant-core/files/1.6.4-ant b/dev-java/ant-core/files/1.6.4-ant
deleted file mode 100644
index eafe25e88985..000000000000
--- a/dev-java/ant-core/files/1.6.4-ant
+++ /dev/null
@@ -1,169 +0,0 @@
-#! /bin/bash
-
-# Copyright 2001-2004 The Apache Software Foundation
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-# Edited for Gentoo Linux
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/files/1.6.4-ant,v 1.1 2005/05/23 15:27:38 axxo Exp $
-
-# Extract launch and ant arguments, (see details below).
-ant_exec_args=
-no_config=false
-use_jikes_default=false
-ant_exec_debug=false
-show_help=false
-for arg in "$@" ; do
- if [ "$arg" = "--noconfig" ] ; then
- no_config=true
- elif [ "$arg" = "--usejikes" ] ; then
- use_jikes_default=true
- elif [ "$arg" = "--execdebug" ] ; then
- ant_exec_debug=true
- elif [ my"$arg" = my"--h" -o my"$arg" = my"--help" ] ; then
- show_help=true
- ant_exec_args="$ant_exec_args -h"
- else
- if [ my"$arg" = my"-h" -o my"$arg" = my"-help" ] ; then
- show_help=true
- fi
- ant_exec_args="$ant_exec_args \"$arg\""
- fi
-done
-
-# Source/default ant configuration
-if $no_config ; then
- rpm_mode=false
- usejikes=$use_jikes_default
-else
- # load system-wide ant configuration
- if [ -f "/etc/ant.conf" ] ; then
- . /etc/ant.conf
- fi
-
- # load user ant configuration
- if [ -f "$HOME/.ant/ant.conf" ] ; then
- . $HOME/.ant/ant.conf
- fi
- if [ -f "$HOME/.antrc" ] ; then
- . "$HOME/.antrc"
- fi
-
- # provide default configuration values
- if [ -z "$rpm_mode" ] ; then
- rpm_mode=false
- fi
- if [ -z "$usejikes" ] ; then
- usejikes=$use_jikes_default
- fi
-fi
-
-
-if [ -z $JAVA_HOME ] ; then
- if [ -f $HOME/.gentoo/java-env ] ; then
- source $HOME/.gentoo/java-env
- else
- JAVA_HOME=`java-config --jdk-home`
- CLASSPATH=`java-config --classpath`:${CLASSPATH}
- fi
-fi
-
-if [ -z $JAVA_HOME ] ; then
- echo "Error: No JDK found!"
- echo "Try using java-config script to set your JDK"
- echo "Remember that you need a JDK not a JRE"
- exit 1
-fi
-
-ANT_HOME=/usr/share/ant-core
-
-# set ANT_LIB location
-ANT_LIB="${ANT_HOME}/lib"
-
-JAVACMD="`java-config --java`"
-
-if [ ! -x "$JAVACMD" ] ; then
- echo "Error: JAVA_HOME is not defined correctly."
- echo " We cannot execute $JAVACMD"
- exit 1
-fi
-
-if [ -z "$LOCALCLASSPATH" ] ; then
- LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar
-else
- LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar:$LOCALCLASSPATH
-fi
-
-# add in the dependency .jar files
-LOCALCLASSPATH="${LOCALCLASSPATH}:`java-config --classpath=ant-core,ant-tasks,log4j,xerces-2,xalan,junit,antlr,bcel,bsh,commons-beanutils-1.6,commons-collections,commons-logging,commons-net,jakarta-oro-2.0,jdepend,jsch,jakarta-regexp-1.3,rhino-1.5,jython,jta,jaf,javamail 2> /dev/null`"
-
-if [ -n "$JAVA_HOME" ] ; then
- if [ -f "$JAVA_HOME/lib/tools.jar" ] ; then
- LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/tools.jar"
- fi
-
- if [ -f "$JAVA_HOME/lib/classes.zip" ] ; then
- LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/classes.zip"
- fi
-
-else
- echo "Warning: JAVA_HOME environment variable is not set (or not exported)."
- echo " If build fails because sun.* classes could not be found"
- echo " you will need to set the JAVA_HOME environment variable"
- echo " to the installation directory of java."
- echo " Try using java-config script"
-fi
-
-# Allow Jikes support (off by default)
-if $usejikes; then
- ANT_OPTS="$ANT_OPTS -Dbuild.compiler=jikes"
-fi
-
-# Show script help if requested
-if $show_help ; then
- echo $0 '[script options] [options] [target [target2 [target3] ..]]'
- echo 'Script Options:'
- echo ' --help, --h print this message and ant help'
- echo ' --noconfig suppress sourcing of /etc/ant.conf,'
- echo ' $HOME/.ant/ant.conf, and $HOME/.antrc'
- echo ' configuration files'
- echo ' --usejikes enable use of jikes by default, unless'
- echo ' set explicitly in configuration files'
- echo ' --execdebug print ant exec line generated by this'
- echo ' launch script'
- echo ' '
-fi
-
-# Execute ant using eval/exec to preserve spaces in paths,
-# java options, and ant args
-ant_sys_opts=
-
-
-if [ -n "$JIKESPATH" ]; then
- ant_sys_opts="-Djikes.class.path=\"$JIKESPATH\""
-fi
-
-# 2002-11-02, karltk@gentoo.org:
-# The Blackdown JDK on PPC hiccups with native threads
-#
-if [ "`arch`" == "ppc" ] ; then
- export THREADS_FLAG="green"
-fi
-
-
-ant_exec_command="exec \"$JAVACMD\" $ANT_OPTS -classpath \"$LOCALCLASSPATH\" -Dant.home=\"$ANT_HOME\" -Dant.library.dir=\"$ANT_LIB\" $ant_sys_opts org.apache.tools.ant.launch.Launcher $ANT_ARGS -lib \"$CLASSPATH\" $ant_exec_args"
-
-if $ant_exec_debug ; then
- echo $ant_exec_command
-fi
-eval $ant_exec_command
diff --git a/dev-java/ant-core/files/digest-ant-core-1.6.3-r1 b/dev-java/ant-core/files/digest-ant-core-1.6.3-r1
deleted file mode 100644
index 3028550c2577..000000000000
--- a/dev-java/ant-core/files/digest-ant-core-1.6.3-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 fab56a0c0ab7bb2875e67c2a84b0a618 apache-ant-1.6.3-src.tar.bz2 6280919
diff --git a/dev-java/ant-core/files/digest-ant-core-1.6.4 b/dev-java/ant-core/files/digest-ant-core-1.6.4
deleted file mode 100644
index 3e14c7c6e4b5..000000000000
--- a/dev-java/ant-core/files/digest-ant-core-1.6.4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 64e99d5c0c51572e7323abf6c497b294 apache-ant-1.6.4-src.tar.bz2 6283215