summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-02-21 00:09:39 +0000
committerVlastimil Babka <caster@gentoo.org>2010-02-21 00:09:39 +0000
commit3693fb4897ea27557d6bb8957277ed233465251f (patch)
treee9d90f66bb6719e8165465a3b4145485b0a0adfd /dev-java/ant-apache-bcel/ant-apache-bcel-1.8.0.ebuild
parentTransfer prefix keywords, bump EAPI (diff)
downloadgentoo-2-3693fb4897ea27557d6bb8957277ed233465251f.tar.gz
gentoo-2-3693fb4897ea27557d6bb8957277ed233465251f.tar.bz2
gentoo-2-3693fb4897ea27557d6bb8957277ed233465251f.zip
Version bump, bug #305929.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/ant-apache-bcel/ant-apache-bcel-1.8.0.ebuild')
-rw-r--r--dev-java/ant-apache-bcel/ant-apache-bcel-1.8.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-java/ant-apache-bcel/ant-apache-bcel-1.8.0.ebuild b/dev-java/ant-apache-bcel/ant-apache-bcel-1.8.0.ebuild
new file mode 100644
index 000000000000..729998db6be7
--- /dev/null
+++ b/dev-java/ant-apache-bcel/ant-apache-bcel-1.8.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bcel/ant-apache-bcel-1.8.0.ebuild,v 1.1 2010/02/21 00:09:39 caster Exp $
+
+EAPI=1
+
+ANT_TASK_DEPNAME="bcel"
+
+inherit ant-tasks
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="~dev-java/ant-nodeps-${PV}
+ >=dev-java/bcel-5.1-r3:0"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ ant-tasks_src_unpack all
+ java-pkg_jar-from ant-nodeps
+}