summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-11-20 14:24:00 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-11-20 14:24:00 +0000
commit6c691330667b17ba3cab69162d5551d3ad0c87c1 (patch)
tree870476326d17c1311540b4f4d235ee8e2a319666 /dev-haskell
parentInitial commit. JSON pretty-printing library and command-line tool. (diff)
downloadgentoo-2-6c691330667b17ba3cab69162d5551d3ad0c87c1.tar.gz
gentoo-2-6c691330667b17ba3cab69162d5551d3ad0c87c1.tar.bz2
gentoo-2-6c691330667b17ba3cab69162d5551d3ad0c87c1.zip
Initial commit. Simple unicode collation as per RFC5051.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/rfc5051/ChangeLog9
-rw-r--r--dev-haskell/rfc5051/metadata.xml27
-rw-r--r--dev-haskell/rfc5051/rfc5051-0.1.0.3.ebuild30
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-haskell/rfc5051/ChangeLog b/dev-haskell/rfc5051/ChangeLog
new file mode 100644
index 000000000000..47518cdaa64b
--- /dev/null
+++ b/dev-haskell/rfc5051/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/rfc5051
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/rfc5051/ChangeLog,v 1.1 2013/11/20 14:24:00 slyfox Exp $
+
+*rfc5051-0.1.0.3 (20 Nov 2013)
+
+ 20 Nov 2013; Sergei Trofimovich <slyfox@gentoo.org> +metadata.xml,
+ +rfc5051-0.1.0.3.ebuild:
+ Initial commit. Simple unicode collation as per RFC5051.
diff --git a/dev-haskell/rfc5051/metadata.xml b/dev-haskell/rfc5051/metadata.xml
new file mode 100644
index 000000000000..86296541f069
--- /dev/null
+++ b/dev-haskell/rfc5051/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name='mkunicodedata'>build codes generator itself</flag>
+ </use>
+ <longdescription>
+ This library implements @i;unicode-casemap@,
+ the simple, non locale-sensitive unicode collation
+ algorithm described in RFC 5051 (&lt;http://www.rfc-editor.org/rfc/rfc5051.txt&gt;).
+ Proper unicode collation can be done using text-icu, but that is a big
+ dependency that depends on a large C library, and rfc5051 might be better
+ for some purposes.
+
+ Here is a list of strings sorted by the Prelude&#39;s @sort@ function:
+
+ @Abe Oeb abe ab&amp;#233; oeb &amp;#193;be &amp;#196;be &amp;#212;eb &amp;#225;be &amp;#228;be &amp;#244;eb@
+
+ Here is the same list sorted by @sortBy compareUnicode@:
+
+ @Abe abe ab&amp;#233; &amp;#193;be &amp;#225;be &amp;#196;be &amp;#228;be Oeb oeb &amp;#212;eb &amp;#244;eb@
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/rfc5051/rfc5051-0.1.0.3.ebuild b/dev-haskell/rfc5051/rfc5051-0.1.0.3.ebuild
new file mode 100644
index 000000000000..983380c9f798
--- /dev/null
+++ b/dev-haskell/rfc5051/rfc5051-0.1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/rfc5051/rfc5051-0.1.0.3.ebuild,v 1.1 2013/11/20 14:24:00 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple unicode collation as per RFC5051."
+HOMEPAGE="http://hackage.haskell.org/package/rfc5051"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="mkunicodedata"
+
+RDEPEND=">=dev-lang/ghc-7.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag mkunicodedata mkunicodedata)
+}