summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-02-21 20:06:31 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-02-21 20:06:31 +0000
commit3c2b3872726b3fb3b781d7f3900f9671553f3b87 (patch)
treeaaa0decc329371538ce972fbe495835d7921e045 /dev-haskell
parentVersion bump. (diff)
downloadgentoo-2-3c2b3872726b3fb3b781d7f3900f9671553f3b87.tar.gz
gentoo-2-3c2b3872726b3fb3b781d7f3900f9671553f3b87.tar.bz2
gentoo-2-3c2b3872726b3fb3b781d7f3900f9671553f3b87.zip
Version bump.
(Portage version: 2.2.8_p51/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/happy/ChangeLog9
-rw-r--r--dev-haskell/happy/happy-1.19.3.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/dev-haskell/happy/ChangeLog b/dev-haskell/happy/ChangeLog
index 2caf18d8f44b..5b2943fa455c 100644
--- a/dev-haskell/happy/ChangeLog
+++ b/dev-haskell/happy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/happy
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.72 2013/03/31 10:03:46 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.73 2014/02/21 20:06:31 slyfox Exp $
+
+*happy-1.19.3 (21 Feb 2014)
+
+ 21 Feb 2014; Sergei Trofimovich <slyfox@gentoo.org> +happy-1.19.3.ebuild:
+ Version bump.
31 Mar 2013; Agostino Sarubbo <ago@gentoo.org> happy-1.18.10.ebuild:
Stable for sparc, wrt bug #456492
diff --git a/dev-haskell/happy/happy-1.19.3.ebuild b/dev-haskell/happy/happy-1.19.3.ebuild
new file mode 100644
index 000000000000..18f2fe2c2f13
--- /dev/null
+++ b/dev-haskell/happy/happy-1.19.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.19.3.ebuild,v 1.1 2014/02/21 20:06:31 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin test-suite"
+inherit haskell-cabal autotools
+
+DESCRIPTION="Happy is a parser generator for Haskell"
+HOMEPAGE="http://www.haskell.org/happy/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ >=dev-haskell/mtl-1.0
+ >=dev-lang/ghc-6.10.4
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets )
+"
+
+src_prepare() {
+ for f in AttrGrammarParser Parser; do
+ # drop broken autogenerated
+ mv "dist/build/happy/happy-tmp/$f.hs" src/ || die
+ # drop depend on itself, otherwise cabal tries to regenerate it
+ rm "src/$f.ly" || die
+ done
+ use doc && cd doc && eautoconf
+}
+
+src_configure() {
+ # '--with-happy=false' allows detecting circular
+ # depends even when 'happy' is installed in system
+ haskell-cabal_src_configure --with-happy=false
+
+ if use doc; then
+ # does not like out-of-source builds
+ cd doc || die
+ econf
+ fi
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+
+ if use doc; then
+ emake -C doc -j1
+ fi
+}
+
+src_install() {
+ haskell-cabal_src_install
+ if use doc; then
+ cd doc || die
+ dohtml -r happy/*
+ doman "${S}/doc/happy.1"
+ fi
+}