summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-12-16 23:05:28 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-12-16 23:05:28 +0000
commit27c31e313da6068845b27304744c50439b79b6ba (patch)
treefecafff9028dea9810057bbff842f3aa17a27bdd /dev-haskell
parentadd new dep, rm unneeded prepare phase. closes bug #532720 (diff)
downloadgentoo-2-27c31e313da6068845b27304744c50439b79b6ba.tar.gz
gentoo-2-27c31e313da6068845b27304744c50439b79b6ba.tar.bz2
gentoo-2-27c31e313da6068845b27304744c50439b79b6ba.zip
Initial import. Library to access Amazon AWS API (used by git-annex).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/aws/ChangeLog9
-rw-r--r--dev-haskell/aws/aws-0.11.ebuild60
-rw-r--r--dev-haskell/aws/metadata.xml8
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-haskell/aws/ChangeLog b/dev-haskell/aws/ChangeLog
new file mode 100644
index 000000000000..41c5181ddd46
--- /dev/null
+++ b/dev-haskell/aws/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/aws
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/aws/ChangeLog,v 1.1 2014/12/16 23:05:28 slyfox Exp $
+
+*aws-0.11 (16 Dec 2014)
+
+ 16 Dec 2014; Sergei Trofimovich <slyfox@gentoo.org> +aws-0.11.ebuild,
+ +metadata.xml:
+ Initial import. Library to access Amazon AWS API (used by git-annex).
diff --git a/dev-haskell/aws/aws-0.11.ebuild b/dev-haskell/aws/aws-0.11.ebuild
new file mode 100644
index 000000000000..7dd83f098b3d
--- /dev/null
+++ b/dev-haskell/aws/aws-0.11.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/aws/aws-0.11.ebuild,v 1.1 2014/12/16 23:05:28 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Amazon Web Services (AWS) for Haskell"
+HOMEPAGE="http://github.com/aristidb/aws"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # needs AWS account
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/attoparsec-0.11:=[profile?] <dev-haskell/attoparsec-0.13:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
+ >=dev-haskell/byteable-0.1:=[profile?] <dev-haskell/byteable-0.2:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/cereal-0.3:=[profile?] <dev-haskell/cereal-0.5:=[profile?]
+ >=dev-haskell/conduit-1.1:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/conduit-extra-1.1:=[profile?] <dev-haskell/conduit-extra-1.2:=[profile?]
+ >=dev-haskell/cryptohash-0.11:=[profile?] <dev-haskell/cryptohash-0.12:=[profile?]
+ >=dev-haskell/data-default-0.5.3:=[profile?] <dev-haskell/data-default-0.6:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?] <dev-haskell/http-conduit-2.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?] <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ >=dev-haskell/network-2:=[profile?] <dev-haskell/network-3:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.8:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-0.4:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?]
+ >=dev-haskell/xml-conduit-1.2:=[profile?] <dev-haskell/xml-conduit-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flags=-examples
+}
diff --git a/dev-haskell/aws/metadata.xml b/dev-haskell/aws/metadata.xml
new file mode 100644
index 000000000000..f801b0343d94
--- /dev/null
+++ b/dev-haskell/aws/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Bindings for Amazon Web Services (AWS), with the aim of supporting all AWS services. To see a high level overview of the library, see the README at &lt;https://github.com/aristidb/aws/blob/master/README.org&gt;.
+ </longdescription>
+</pkgmetadata>