summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-26 12:45:30 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-26 12:45:30 +0000
commita5e9e2961ae1e3fa1dd16709c78c54761ea637ee (patch)
treed4dbd1fd063e282adcaeb82ccce055bee5c8a865 /dev-haskell/yesod/yesod-1.1.9.2.ebuild
parentRemove old versions. (diff)
downloadgentoo-2-a5e9e2961ae1e3fa1dd16709c78c54761ea637ee.tar.gz
gentoo-2-a5e9e2961ae1e3fa1dd16709c78c54761ea637ee.tar.bz2
gentoo-2-a5e9e2961ae1e3fa1dd16709c78c54761ea637ee.zip
dev-haskell/yesod: initial layout
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/yesod/yesod-1.1.9.2.ebuild')
-rw-r--r--dev-haskell/yesod/yesod-1.1.9.2.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/dev-haskell/yesod/yesod-1.1.9.2.ebuild b/dev-haskell/yesod/yesod-1.1.9.2.ebuild
new file mode 100644
index 000000000000..20937c3240bb
--- /dev/null
+++ b/dev-haskell/yesod/yesod-1.1.9.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod/yesod-1.1.9.2.ebuild,v 1.1 2013/08/26 12:45:30 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Creation of type-safe, RESTful web applications."
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/attoparsec-0.10:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?]
+ <dev-haskell/blaze-builder-0.4:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ dev-haskell/cabal:=[profile?]
+ >=dev-haskell/conduit-0.5:=[profile?]
+ <dev-haskell/conduit-1.1:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ =dev-haskell/fsnotify-0.0*:=[profile?]
+ >=dev-haskell/ghc-paths-0.1:=[profile?]
+ =dev-haskell/hamlet-1.1*:=[profile?]
+ dev-haskell/http-conduit:=[profile?]
+ >=dev-haskell/http-reverse-proxy-0.1.1:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ =dev-haskell/monad-control-0.3*:=[profile?]
+ dev-haskell/network:=[profile?]
+ dev-haskell/network-conduit:=[profile?]
+ >=dev-haskell/optparse-applicative-0.4:=[profile?]
+ >=dev-haskell/parsec-2.1:=[profile?]
+ <dev-haskell/parsec-4:=[profile?]
+ >=dev-haskell/project-template-0.1.1:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?]
+ <dev-haskell/resourcet-0.5:=[profile?]
+ >=dev-haskell/shakespeare-1.0.2:=[profile?]
+ <dev-haskell/shakespeare-1.1:=[profile?]
+ >=dev-haskell/shakespeare-css-1.0.2:=[profile?]
+ <dev-haskell/shakespeare-css-1.1:=[profile?]
+ >=dev-haskell/shakespeare-js-1.0.2:=[profile?]
+ <dev-haskell/shakespeare-js-1.2:=[profile?]
+ =dev-haskell/shakespeare-text-1.0*:=[profile?]
+ =dev-haskell/split-0.2*:=[profile?]
+ =dev-haskell/system-fileio-0.3*:=[profile?]
+ =dev-haskell/system-filepath-0.4*:=[profile?]
+ =dev-haskell/tar-0.4*:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?]
+ <dev-haskell/unix-compat-0.5:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-haskell/wai-1.3:=[profile?]
+ <dev-haskell/wai-1.5:=[profile?]
+ =dev-haskell/wai-extra-1.3*:=[profile?]
+ =dev-haskell/warp-1.3*:=[profile?]
+ =dev-haskell/yaml-0.8*:=[profile?]
+ =dev-haskell/yesod-auth-1.1*:=[profile?]
+ >=dev-haskell/yesod-core-1.1.5:=[profile?]
+ <dev-haskell/yesod-core-1.2:=[profile?]
+ >=dev-haskell/yesod-default-1.1.3:=[profile?]
+ <dev-haskell/yesod-default-1.2:=[profile?]
+ >=dev-haskell/yesod-form-1.1:=[profile?]
+ <dev-haskell/yesod-form-1.3:=[profile?]
+ =dev-haskell/yesod-json-1.1*:=[profile?]
+ =dev-haskell/yesod-persistent-1.1*:=[profile?]
+ =dev-haskell/zlib-0.5*:=[profile?]
+ >=dev-lang/ghc-7.0.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ # This is a big hack we just removing all executables
+ # that depend on ghc itself this allowes us to have
+ # stand-alone yesod-cmd
+ sed '/executable /,$ d' -i "${S}"/${PN}.cabal
+}