summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-07-02 14:17:19 +0000
committerMark Wright <gienah@gentoo.org>2014-07-02 14:17:19 +0000
commit42caefdf532ebc003938f56c5a89250d8a9f9a1e (patch)
tree4a73e614b200cd6ce511a6fae1b780d3d28c3a62 /dev-haskell/uuid
parentBump utf8-string to 0.3.8 (diff)
downloadgentoo-2-42caefdf532ebc003938f56c5a89250d8a9f9a1e.tar.gz
gentoo-2-42caefdf532ebc003938f56c5a89250d8a9f9a1e.tar.bz2
gentoo-2-42caefdf532ebc003938f56c5a89250d8a9f9a1e.zip
Loosen quickcheck test dep in uuid-1.3.3-r2
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/uuid')
-rw-r--r--dev-haskell/uuid/ChangeLog9
-rw-r--r--dev-haskell/uuid/uuid-1.3.3-r2.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-haskell/uuid/ChangeLog b/dev-haskell/uuid/ChangeLog
index 2fc86e3dd0dc..7d4fff848dd3 100644
--- a/dev-haskell/uuid/ChangeLog
+++ b/dev-haskell/uuid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/uuid
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/uuid/ChangeLog,v 1.3 2013/12/11 06:37:27 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/uuid/ChangeLog,v 1.4 2014/07/02 14:17:19 gienah Exp $
+
+*uuid-1.3.3-r2 (02 Jul 2014)
+
+ 02 Jul 2014; Mark Wright <gienah@gentoo.org> +uuid-1.3.3-r2.ebuild:
+ Loosen quickcheck test dep in uuid-1.3.3-r2
*uuid-1.3.3-r1 (11 Dec 2013)
diff --git a/dev-haskell/uuid/uuid-1.3.3-r2.ebuild b/dev-haskell/uuid/uuid-1.3.3-r2.ebuild
new file mode 100644
index 000000000000..f5c433d86fb0
--- /dev/null
+++ b/dev-haskell/uuid/uuid-1.3.3-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/uuid/uuid-1.3.3-r2.ebuild,v 1.1 2014/07/02 14:17:19 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
+HOMEPAGE="http://projects.haskell.org/uuid/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ >=dev-haskell/cryptohash-0.7:=[profile?] <dev-haskell/cryptohash-0.12:=[profile?]
+ >=dev-haskell/network-info-0.2:=[profile?] <dev-haskell/network-info-0.3:=[profile?]
+ >=dev-haskell/random-1.0.1:=[profile?] <dev-haskell/random-1.1:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ || ( ( >=dev-haskell/hashable-1.1.1.0:=[profile?] <dev-haskell/hashable-1.2.0:=[profile?] )
+ ( >=dev-haskell/hashable-1.2.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?] ) )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3
+ >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.8
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'QuickCheck >=2.4 && < 2.7' 'QuickCheck >=2.4 && < 2.8'
+}