summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-14 05:38:50 +0000
committerMark Wright <gienah@gentoo.org>2014-12-14 05:38:50 +0000
commit37b8cd3ea99c916c5e380ddae14081734e3a41b8 (patch)
tree985b7bff22751958bbc3f9d0a43e5b174bb54f44 /dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
parentBump pwstore-fast to 2.4.4 (diff)
downloadgentoo-2-37b8cd3ea99c916c5e380ddae14081734e3a41b8.tar.gz
gentoo-2-37b8cd3ea99c916c5e380ddae14081734e3a41b8.tar.bz2
gentoo-2-37b8cd3ea99c916c5e380ddae14081734e3a41b8.zip
Bump quickcheck to 2.7.6
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/quickcheck/quickcheck-2.7.6.ebuild')
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.7.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild b/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
new file mode 100644
index 000000000000..7acb4157eac3
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild,v 1.1 2014/12/14 05:38:50 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="https://github.com/nick8325/quickcheck"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+template_haskell"
+
+RDEPEND="dev-haskell/random:=[profile?]
+ >=dev-haskell/tf-random-0.4:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-base3 \
+ --flag=base4 \
+ $(cabal_flag template_haskell templatehaskell)
+}