summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-04-04 09:06:20 +0000
committerMark Wright <gienah@gentoo.org>2015-04-04 09:06:20 +0000
commitc4e06ed6e02ce1fd81cab4ac7da5addafb888a06 (patch)
treece56566995ac8cd64c91ebd7896bebacf718af2d /dev-haskell/json
parentBump hxt-charproperties to 9.2.0.1 (diff)
downloadgentoo-2-c4e06ed6e02ce1fd81cab4ac7da5addafb888a06.tar.gz
gentoo-2-c4e06ed6e02ce1fd81cab4ac7da5addafb888a06.tar.bz2
gentoo-2-c4e06ed6e02ce1fd81cab4ac7da5addafb888a06.zip
Bump json to 0.9.1
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/json')
-rw-r--r--dev-haskell/json/ChangeLog7
-rw-r--r--dev-haskell/json/json-0.9.1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-haskell/json/ChangeLog b/dev-haskell/json/ChangeLog
index 3f12c6f72d71..72b2f4099ad8 100644
--- a/dev-haskell/json/ChangeLog
+++ b/dev-haskell/json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/json
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/json/ChangeLog,v 1.14 2015/03/05 19:44:09 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/json/ChangeLog,v 1.15 2015/04/04 09:06:20 gienah Exp $
+
+*json-0.9.1 (04 Apr 2015)
+
+ 04 Apr 2015; Mark Wright <gienah@gentoo.org> +json-0.9.1.ebuild:
+ Bump json to 0.9.1
*json-0.9 (05 Mar 2015)
diff --git a/dev-haskell/json/json-0.9.1.ebuild b/dev-haskell/json/json-0.9.1.ebuild
new file mode 100644
index 000000000000..e82b6f9356e7
--- /dev/null
+++ b/dev-haskell/json/json-0.9.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/json/json-0.9.1.ebuild,v 1.1 2015/04/04 09:06:20 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Support for serialising Haskell to and from JSON"
+HOMEPAGE="http://hackage.haskell.org/package/json"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux"
+IUSE="+generic mapdict +parsec +pretty"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ generic? ( >=dev-haskell/syb-0.3.3:=[profile?] )
+ parsec? ( dev-haskell/parsec:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag generic generic) \
+ $(cabal_flag mapdict mapdict) \
+ $(cabal_flag parsec parsec) \
+ $(cabal_flag pretty pretty)
+}