summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-07-28 17:58:47 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-07-28 17:58:47 +0000
commitc61473fd277620c73b55f34ebb8297167c1a783e (patch)
treec1b766598c903ac52d60be6cc8ec61d1b99286d1 /dev-haskell/hxt
parentx86 stable wrt #186899 (diff)
downloadgentoo-2-c61473fd277620c73b55f34ebb8297167c1a783e.tar.gz
gentoo-2-c61473fd277620c73b55f34ebb8297167c1a783e.tar.bz2
gentoo-2-c61473fd277620c73b55f34ebb8297167c1a783e.zip
New version, fixing bug #163547.
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-haskell/hxt')
-rw-r--r--dev-haskell/hxt/ChangeLog7
-rw-r--r--dev-haskell/hxt/files/digest-hxt-7.23
-rw-r--r--dev-haskell/hxt/hxt-7.2.ebuild43
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-haskell/hxt/ChangeLog b/dev-haskell/hxt/ChangeLog
index 123f4d6be80f..3519ff6e050d 100644
--- a/dev-haskell/hxt/ChangeLog
+++ b/dev-haskell/hxt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hxt
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/ChangeLog,v 1.7 2007/03/24 00:30:07 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/ChangeLog,v 1.8 2007/07/28 17:58:47 dcoutts Exp $
+
+*hxt-7.2 (28 Jul 2007)
+
+ 28 Jul 2007; Duncan Coutts <dcoutts@gentoo.org> +hxt-7.2.ebuild:
+ New version, fixing bug #163547.
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-haskell/hxt/files/digest-hxt-7.2 b/dev-haskell/hxt/files/digest-hxt-7.2
new file mode 100644
index 000000000000..ec720da9de33
--- /dev/null
+++ b/dev-haskell/hxt/files/digest-hxt-7.2
@@ -0,0 +1,3 @@
+MD5 2784386a37aabb336d5ebb727b0ea802 HXT-7.2.tar.gz 3589292
+RMD160 9d364c93b30014a7574a8f8499680905a82dae77 HXT-7.2.tar.gz 3589292
+SHA256 ef8e2ebfda6e43240051a7af9417092b2af50ece8b5c6c3fbd908ba91c4fe068 HXT-7.2.tar.gz 3589292
diff --git a/dev-haskell/hxt/hxt-7.2.ebuild b/dev-haskell/hxt/hxt-7.2.ebuild
new file mode 100644
index 000000000000..4682290f4b4e
--- /dev/null
+++ b/dev-haskell/hxt/hxt-7.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-7.2.ebuild,v 1.1 2007/07/28 17:58:47 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit base haskell-cabal
+
+MY_PN="HXT"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A collection of tools for processing XML with Haskell"
+HOMEPAGE="http://www.fh-wedel.de/~si/HXmlToolbox/"
+SRC_URI="http://www.fh-wedel.de/~si/HXmlToolbox/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.4.1
+ >=dev-haskell/http-2006.7.7
+ >=dev-haskell/hunit-1.1
+ >=dev-haskell/network-1.0"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ base_src_unpack
+
+ sed -i \
+ -e 's/-O2/-O/' \
+ "${S}/hxt.cabal"
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc LICENSE README
+ if use doc; then
+ cd ${S}/doc
+ dodoc thesis.pdf
+ fi
+}