summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-01-03 04:39:30 +0000
committerMark Wright <gienah@gentoo.org>2015-01-03 04:39:30 +0000
commit0b2d45450dea562aa3226e8cb20049dbc5192798 (patch)
treecaa308f640c6051f31a3c7f332aa3e64876c1015 /dev-haskell/http-client
parentdigest (diff)
downloadgentoo-2-0b2d45450dea562aa3226e8cb20049dbc5192798.tar.gz
gentoo-2-0b2d45450dea562aa3226e8cb20049dbc5192798.tar.bz2
gentoo-2-0b2d45450dea562aa3226e8cb20049dbc5192798.zip
Bump http-client to 0.4.6.2
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/http-client')
-rw-r--r--dev-haskell/http-client/ChangeLog9
-rw-r--r--dev-haskell/http-client/http-client-0.4.6.2.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-haskell/http-client/ChangeLog b/dev-haskell/http-client/ChangeLog
index 8d1f48371682..fe2334e2ecc2 100644
--- a/dev-haskell/http-client/ChangeLog
+++ b/dev-haskell/http-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/http-client
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http-client/ChangeLog,v 1.7 2014/12/15 14:02:49 mjo Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http-client/ChangeLog,v 1.8 2015/01/03 04:39:30 gienah Exp $
+
+*http-client-0.4.6.2 (03 Jan 2015)
+
+ 03 Jan 2015; Mark Wright <gienah@gentoo.org> +http-client-0.4.6.2.ebuild:
+ Bump http-client to 0.4.6.2
*http-client-0.4.6.1 (15 Dec 2014)
diff --git a/dev-haskell/http-client/http-client-0.4.6.2.ebuild b/dev-haskell/http-client/http-client-0.4.6.2.ebuild
new file mode 100644
index 000000000000..2d967ed8e302
--- /dev/null
+++ b/dev-haskell/http-client/http-client-0.4.6.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http-client/http-client-0.4.6.2.ebuild,v 1.1 2015/01/03 04:39:30 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An HTTP client engine, intended as a base layer for more user-friendly packages"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-1.0:=[profile?]
+ dev-haskell/cookie:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/exceptions-0.4:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ dev-haskell/mime-types:=[profile?]
+ dev-haskell/publicsuffixlist:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.0.2:=[profile?] <dev-haskell/streaming-commons-0.2:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/async
+ dev-haskell/hspec
+ dev-haskell/monad-control
+ >=dev-haskell/streaming-commons-0.1.1
+ dev-haskell/zlib )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}