summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2005-05-08 22:22:06 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2005-05-08 22:22:06 +0000
commit0428f5e4be0b816a94945efd99f9cc42608066cb (patch)
treefe2091df4ae32811b611bd3160b25f973aac8ae3 /dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild
parentstable on ia64 (diff)
downloadgentoo-2-0428f5e4be0b816a94945efd99f9cc42608066cb.tar.gz
gentoo-2-0428f5e4be0b816a94945efd99f9cc42608066cb.tar.bz2
gentoo-2-0428f5e4be0b816a94945efd99f9cc42608066cb.zip
Added new hsshellscript release. First version in the tree that works with ghc6.4
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild')
-rw-r--r--dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild b/dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild
new file mode 100644
index 000000000000..f7d8d7f8197d
--- /dev/null
+++ b/dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild,v 1.1 2005/05/08 22:22:06 araujo Exp $
+
+inherit base eutils ghc-package
+
+DESCRIPTION="A Haskell library for UNIX shell scripting tasks"
+HOMEPAGE="http://www.volker-wysk.de/hsshellscript/"
+SRC_URI="http://www.volker-wysk.de/hsshellscript/dist/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="=virtual/ghc-6.4
+ >=dev-haskell/haddock-0.6"
+RDEPEND=""
+
+src_unpack() {
+ base_src_unpack
+ cd ${S}
+ sed -i -e "/ghc-pkg/d" Makefile
+}
+
+src_compile() {
+ # Fix hsshellscript.cabal library path
+ sed -i "s:@DEST_LIB:$(ghc-libdir):" \
+ ${S}/lib/hsshellscript.cabal
+ sed -i "s:@DEST_IMPORTS:$(ghc-libdir)/imports:" \
+ ${S}/lib/hsshellscript.cabal
+ emake || die "emake failed"
+}
+
+src_install() {
+ # we register the .cabal file generated by make
+ ghc-setup-pkg ${S}/build/hsshellscript.cabal
+ make install \
+ DESTDIR="${D}" \
+ DEST_LIB="$(ghc-libdir)" \
+ DEST_IMPORTS="$(ghc-libdir)/imports" \
+ DEST_DOC="/usr/share/doc/${PF}" \
+ || die "make failed"
+ ghc-makeghcilib ${D}/$(ghc-libdir)/libhsshellscript.a
+ ghc-install-pkg
+}