summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-08-05 10:53:54 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-08-05 10:53:54 +0000
commitea2995f19862c402e5f214ef7b12b40381160705 (patch)
treedc16b2822a03b39cd742b611f360a35bd132a383 /dev-haskell/happy
parentQA: fix obvious typo. (diff)
downloadgentoo-2-ea2995f19862c402e5f214ef7b12b40381160705.tar.gz
gentoo-2-ea2995f19862c402e5f214ef7b12b40381160705.tar.bz2
gentoo-2-ea2995f19862c402e5f214ef7b12b40381160705.zip
Fix build failure for USE=-doc case. Discovered and fixed by Yvan Royon, bug #377827.
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/happy')
-rw-r--r--dev-haskell/happy/ChangeLog6
-rw-r--r--dev-haskell/happy/happy-1.18.6.ebuild10
2 files changed, 12 insertions, 4 deletions
diff --git a/dev-haskell/happy/ChangeLog b/dev-haskell/happy/ChangeLog
index db6bb05ff9e9..e81e148a965c 100644
--- a/dev-haskell/happy/ChangeLog
+++ b/dev-haskell/happy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/happy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.51 2011/08/02 10:15:09 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.52 2011/08/05 10:53:54 slyfox Exp $
+
+ 05 Aug 2011; Sergei Trofimovich <slyfox@gentoo.org> happy-1.18.6.ebuild:
+ Fix build failure for USE=-doc case. Discovered and fixed by Yvan Royon, bug
+ #377827.
*happy-1.18.6 (02 Aug 2011)
diff --git a/dev-haskell/happy/happy-1.18.6.ebuild b/dev-haskell/happy/happy-1.18.6.ebuild
index b0ba2a830a22..57344ee13780 100644
--- a/dev-haskell/happy/happy-1.18.6.ebuild
+++ b/dev-haskell/happy/happy-1.18.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.18.6.ebuild,v 1.1 2011/08/02 10:15:09 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.18.6.ebuild,v 1.2 2011/08/05 10:53:54 slyfox Exp $
# ebuild generated by hackport 0.2.9
@@ -39,13 +39,17 @@ src_prepare() {
src_configure() {
cabal_src_configure
- use doc && cd doc && econf || die "econf failed in /doc"
+ if use doc; then
+ cd doc && econf || die "econf failed in /doc"
+ fi
}
src_compile() {
cabal_src_compile
- use doc && cd doc && emake -j1 || die "emake failed in /doc"
+ if use doc; then
+ cd doc && emake -j1 || die "emake failed in /doc"
+ fi
}
src_test() {