summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-08-01 16:52:59 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-08-01 16:52:59 +0000
commit58d816163d2fe4408544e656aef33f04a907311b (patch)
tree613145d3a3f4429e05543d0e3d633591349aac01 /dev-haskell/gtk
parentAllow ghc-7.10. (diff)
downloadgentoo-2-58d816163d2fe4408544e656aef33f04a907311b.tar.gz
gentoo-2-58d816163d2fe4408544e656aef33f04a907311b.tar.bz2
gentoo-2-58d816163d2fe4408544e656aef33f04a907311b.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/gtk')
-rw-r--r--dev-haskell/gtk/ChangeLog7
-rw-r--r--dev-haskell/gtk/gtk-0.13.7.0.2.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-haskell/gtk/ChangeLog b/dev-haskell/gtk/ChangeLog
index 4ef18e7067ce..bd533687bd09 100644
--- a/dev-haskell/gtk/ChangeLog
+++ b/dev-haskell/gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/gtk
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/ChangeLog,v 1.26 2015/04/05 03:16:57 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/ChangeLog,v 1.27 2015/08/01 16:52:59 slyfox Exp $
+
+*gtk-0.13.7.0.2 (01 Aug 2015)
+
+ 01 Aug 2015; Sergei Trofimovich <slyfox@gentoo.org> +gtk-0.13.7.0.2.ebuild:
+ Version bump.
*gtk-0.13.6.0.2 (05 Apr 2015)
diff --git a/dev-haskell/gtk/gtk-0.13.7.0.2.ebuild b/dev-haskell/gtk/gtk-0.13.7.0.2.ebuild
new file mode 100644
index 000000000000..65f52aa5e21f
--- /dev/null
+++ b/dev-haskell/gtk/gtk-0.13.7.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.13.7.0.2.ebuild,v 1.1 2015/08/01 16:52:59 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+GTK_MAJ_VER="2"
+
+MY_PV="${PV%.0.*}"
+MY_P="${PN}-${MY_PV}"
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Gtk+ graphical user interface library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${MY_PV}/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="${GTK_MAJ_VER}/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples +fmode-binary +gio"
+
+RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
+ >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pango-0.13.0.0:=[profile?] <dev-haskell/pango-0.14:=[profile?]
+ >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+ x11-libs/gtk+:${GTK_MAJ_VER}
+ gio? ( >=dev-haskell/gio-0.13.0:=[profile?] <dev-haskell/gio-0.14:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/gtk2hs-buildtools-0.13.0.3:0=
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # workaround for module order
+ cabal_chdeps \
+ 'other-modules:' 'exposed-modules:'
+ # fix build with gcc 5.1.0 and later https://github.com/gtk2hs/gtk2hs/issues/104
+ sed -e 's@gccProg, "--cppopts=-E"@gccProg, "--cppopts=-E", "--cppopts=-P"@' \
+ -i Gtk2HsSetup.hs || die
+}
+
+src_configure() {
+ # Upstream has this enabled, so we might as well force it enabled to be sure.
+ cabal_src_configure \
+ --flags=deprecated \
+ $(cabal_flag fmode-binary fmode-binary) \
+ $(cabal_flag gio have-gio) \
+ --flags=-have-quartz-gtk
+}