summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-05-09 19:37:00 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-05-09 19:37:00 +0000
commit5db1d8ec6d2621b10bd54c69ec4afcfbf37d134b (patch)
tree96a90d2e02beb00781b65edd2360b57c497c517f /dev-haskell/gtk/gtk-0.12.0.ebuild
parentEapi4 and unify the live and release ebuild. (diff)
downloadgentoo-2-5db1d8ec6d2621b10bd54c69ec4afcfbf37d134b.tar.gz
gentoo-2-5db1d8ec6d2621b10bd54c69ec4afcfbf37d134b.tar.bz2
gentoo-2-5db1d8ec6d2621b10bd54c69ec4afcfbf37d134b.zip
Initial version. Haskell bindings for gtk+.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/gtk/gtk-0.12.0.ebuild')
-rw-r--r--dev-haskell/gtk/gtk-0.12.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/gtk/gtk-0.12.0.ebuild b/dev-haskell/gtk/gtk-0.12.0.ebuild
new file mode 100644
index 000000000000..ae2962b7be45
--- /dev/null
+++ b/dev-haskell/gtk/gtk-0.12.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.0.ebuild,v 1.1 2011/05/09 19:37:00 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell bindings to the Gtk+ graphical user interface library."
+HOMEPAGE="http://www.haskell.org/gtk2hs/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gio"
+
+RDEPEND="=dev-haskell/cairo-0.12*
+ =dev-haskell/glib-0.12*
+ dev-haskell/mtl
+ =dev-haskell/pango-0.12*
+ >=dev-lang/ghc-6.10.1
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ gio? ( =dev-haskell/gio-0.12* )"
+DEPEND="${RDEPEND}
+ dev-haskell/gtk2hs-buildtools"
+
+src_configure() {
+ # Upstream has this enabled, so we might as well force it enabled to be sure.
+ cabal_src_configure \
+ --flags=deprecated \
+ $(cabal_flag gio have-gio)
+}