summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-10-19 11:29:30 +0000
committerMark Wright <gienah@gentoo.org>2013-10-19 11:29:30 +0000
commit18a50e2f67f98eaf09ebfe1d2731dff5bf76c994 (patch)
tree8c0b42708d5ee0804ae28b084a4d6ce745a4300f /dev-haskell/dataenc
parentBump comonad-transformers to 4.0 (diff)
downloadgentoo-2-18a50e2f67f98eaf09ebfe1d2731dff5bf76c994.tar.gz
gentoo-2-18a50e2f67f98eaf09ebfe1d2731dff5bf76c994.tar.bz2
gentoo-2-18a50e2f67f98eaf09ebfe1d2731dff5bf76c994.zip
Loosen the base dependency in dataenc-0.14.0.5-r1 to allow >=ghc-7.7. Used the repoman --force option as --force the repoman complaints about missing KEYWORDS are only on dependencies that are used in the tests, and dev-haskell/test-framework-th may not build on those architectures
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/dataenc')
-rw-r--r--dev-haskell/dataenc/ChangeLog10
-rw-r--r--dev-haskell/dataenc/dataenc-0.14.0.5-r1.ebuild43
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-haskell/dataenc/ChangeLog b/dev-haskell/dataenc/ChangeLog
index 4c2c3bbd8601..969ef37f06f6 100644
--- a/dev-haskell/dataenc/ChangeLog
+++ b/dev-haskell/dataenc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-haskell/dataenc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dataenc/ChangeLog,v 1.35 2013/07/21 17:48:44 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dataenc/ChangeLog,v 1.36 2013/10/19 11:29:30 gienah Exp $
+
+*dataenc-0.14.0.5-r1 (19 Oct 2013)
+
+ 19 Oct 2013; Mark Wright <gienah@gentoo.org> +dataenc-0.14.0.5-r1.ebuild:
+ Loosen the base dependency in dataenc-0.14.0.5-r1 to allow >=ghc-7.7. Used the
+ repoman --force option as --force the repoman complaints about missing
+ KEYWORDS are only on dependencies that are used in the tests, and dev-haskell
+ /test-framework-th may not build on those architectures
21 Jul 2013; Christoph Junghans <ottxor@gentoo.org> dataenc-0.14.0.5.ebuild:
added ~amd64-linux (tested by me)
diff --git a/dev-haskell/dataenc/dataenc-0.14.0.5-r1.ebuild b/dev-haskell/dataenc/dataenc-0.14.0.5-r1.ebuild
new file mode 100644
index 000000000000..4a68df4d82cf
--- /dev/null
+++ b/dev-haskell/dataenc/dataenc-0.14.0.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dataenc/dataenc-0.14.0.5-r1.ebuild,v 1.1 2013/10/19 11:29:30 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Data encoding library"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Library/Data_encoding"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+ test? ( dev-haskell/hunit:=[profile?]
+ >=dev-haskell/quickcheck-2.5:=[profile?] <dev-haskell/quickcheck-2.7:=[profile?]
+ dev-haskell/test-framework:=[profile?]
+ dev-haskell/test-framework-hunit:=[profile?]
+ dev-haskell/test-framework-quickcheck2:=[profile?]
+ dev-haskell/test-framework-th:=[profile?] )
+"
+
+src_prepare() {
+ # allow ghc-7.7.2013+
+ cabal_chdeps \
+ 'base >= 3.0.0 && < 4.7' 'base >= 3' \
+ 'QuickCheck ==2.5.*' 'QuickCheck >=2.5 && <2.7'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test tests)
+}