summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-12-11 05:48:54 +0000
committerMark Wright <gienah@gentoo.org>2013-12-11 05:48:54 +0000
commit4e6e978631590e7a992c7784ecc45dd5a77133c3 (patch)
tree8430b152c57d181046ad747b6f6d499afa3a9b29 /dev-haskell/conduit
parentBump cmdargs to 0.10.7 (diff)
downloadgentoo-2-4e6e978631590e7a992c7784ecc45dd5a77133c3.tar.gz
gentoo-2-4e6e978631590e7a992c7784ecc45dd5a77133c3.tar.bz2
gentoo-2-4e6e978631590e7a992c7784ecc45dd5a77133c3.zip
Bump conduit to 1.0.9.3
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/conduit')
-rw-r--r--dev-haskell/conduit/ChangeLog7
-rw-r--r--dev-haskell/conduit/conduit-1.0.9.3.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-haskell/conduit/ChangeLog b/dev-haskell/conduit/ChangeLog
index 2249f373a2ee..4db56c962f0f 100644
--- a/dev-haskell/conduit/ChangeLog
+++ b/dev-haskell/conduit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/conduit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit/ChangeLog,v 1.5 2013/11/24 19:34:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit/ChangeLog,v 1.6 2013/12/11 05:48:54 gienah Exp $
+
+*conduit-1.0.9.3 (11 Dec 2013)
+
+ 11 Dec 2013; Mark Wright <gienah@gentoo.org> +conduit-1.0.9.3.ebuild:
+ Bump conduit to 1.0.9.3
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> conduit-1.0.8.ebuild:
Stable for x86, wrt bug #488750
diff --git a/dev-haskell/conduit/conduit-1.0.9.3.ebuild b/dev-haskell/conduit/conduit-1.0.9.3.ebuild
new file mode 100644
index 000000000000..6eb6c197c058
--- /dev/null
+++ b/dev-haskell/conduit/conduit-1.0.9.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit/conduit-1.0.9.3.ebuild,v 1.1 2013/12/11 05:48:54 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Streaming data processing library."
+HOMEPAGE="http://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="nohandles"
+
+RDEPEND=">=dev-haskell/lifted-base-0.1:=[profile?]
+ dev-haskell/mmorph:=[profile?]
+ >=dev-haskell/monad-control-0.3.1:=[profile?] <dev-haskell/monad-control-0.4:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/resourcet-0.4.3:=[profile?] <dev-haskell/resourcet-0.5:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/transformers-base-0.4.1:=[profile?] <dev-haskell/transformers-base-0.5:=[profile?]
+ >=dev-haskell/void-0.5.5:=[profile?]
+ >=dev-lang/ghc-7.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.0.0
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag nohandles nohandles)
+}