summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-07-02 14:42:39 +0000
committerMark Wright <gienah@gentoo.org>2014-07-02 14:42:39 +0000
commit30f5e8d9f05307b66f61691cb9415c7f14366f0f (patch)
tree39bed053084f4007a6d81ca2ec121bae99dc0085 /dev-haskell/cipher-aes
parentBump lifted-base to 0.2.3.0 (diff)
downloadgentoo-2-30f5e8d9f05307b66f61691cb9415c7f14366f0f.tar.gz
gentoo-2-30f5e8d9f05307b66f61691cb9415c7f14366f0f.tar.bz2
gentoo-2-30f5e8d9f05307b66f61691cb9415c7f14366f0f.zip
Bump cipher-aes to 0.2.7
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/cipher-aes')
-rw-r--r--dev-haskell/cipher-aes/ChangeLog9
-rw-r--r--dev-haskell/cipher-aes/cipher-aes-0.2.7.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-haskell/cipher-aes/ChangeLog b/dev-haskell/cipher-aes/ChangeLog
index b83be546efae..01fde908b4bf 100644
--- a/dev-haskell/cipher-aes/ChangeLog
+++ b/dev-haskell/cipher-aes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/cipher-aes
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cipher-aes/ChangeLog,v 1.5 2013/12/11 05:16:36 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cipher-aes/ChangeLog,v 1.6 2014/07/02 14:42:39 gienah Exp $
+
+*cipher-aes-0.2.7 (02 Jul 2014)
+
+ 02 Jul 2014; Mark Wright <gienah@gentoo.org> +cipher-aes-0.2.7.ebuild:
+ Bump cipher-aes to 0.2.7
*cipher-aes-0.2.6 (11 Dec 2013)
diff --git a/dev-haskell/cipher-aes/cipher-aes-0.2.7.ebuild b/dev-haskell/cipher-aes/cipher-aes-0.2.7.ebuild
new file mode 100644
index 000000000000..285ab28cdee3
--- /dev/null
+++ b/dev-haskell/cipher-aes/cipher-aes-0.2.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cipher-aes/cipher-aes-0.2.7.ebuild,v 1.1 2014/07/02 14:42:39 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast AES cipher implementation with advanced mode of operations"
+HOMEPAGE="http://github.com/vincenthz/hs-cipher-aes"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.6:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ >=dev-haskell/securemem-0.1.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/crypto-cipher-tests-0.0.8
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"