summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-04-09 18:17:31 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-04-09 18:17:31 +0000
commit4b4e2a53f2ea135cd36d107278f6c6d000152a62 (patch)
treebc411539e502ace9b25920f197e770cae0fbbcfa /dev-haskell/c2hs
parentold (diff)
downloadgentoo-2-4b4e2a53f2ea135cd36d107278f6c6d000152a62.tar.gz
gentoo-2-4b4e2a53f2ea135cd36d107278f6c6d000152a62.tar.bz2
gentoo-2-4b4e2a53f2ea135cd36d107278f6c6d000152a62.zip
Version bump. Remove old.
(Portage version: 2.2.0_alpha96_p5/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/c2hs')
-rw-r--r--dev-haskell/c2hs/ChangeLog8
-rw-r--r--dev-haskell/c2hs/c2hs-0.16.3-r1.ebuild (renamed from dev-haskell/c2hs/c2hs-0.16.2.ebuild)14
-rw-r--r--dev-haskell/c2hs/files/c2hs-0.16.3-language-c-0.4.patch25
3 files changed, 41 insertions, 6 deletions
diff --git a/dev-haskell/c2hs/ChangeLog b/dev-haskell/c2hs/ChangeLog
index 478555511906..7a46cfa48473 100644
--- a/dev-haskell/c2hs/ChangeLog
+++ b/dev-haskell/c2hs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/c2hs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/ChangeLog,v 1.46 2012/03/17 22:06:42 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/ChangeLog,v 1.47 2012/04/09 18:17:31 slyfox Exp $
+
+*c2hs-0.16.3-r1 (09 Apr 2012)
+
+ 09 Apr 2012; Sergei Trofimovich <slyfox@gentoo.org> +c2hs-0.16.3-r1.ebuild,
+ +files/c2hs-0.16.3-language-c-0.4.patch, -c2hs-0.16.2.ebuild:
+ Version bump. Remove old.
17 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org> c2hs-0.16.3.ebuild:
alpha/ia64/sparc stable (bug #399971).
diff --git a/dev-haskell/c2hs/c2hs-0.16.2.ebuild b/dev-haskell/c2hs/c2hs-0.16.3-r1.ebuild
index 75dc807d1f2d..c7aebd6cb050 100644
--- a/dev-haskell/c2hs/c2hs-0.16.2.ebuild
+++ b/dev-haskell/c2hs/c2hs-0.16.3-r1.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/c2hs-0.16.2.ebuild,v 1.8 2011/02/25 12:48:52 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/c2hs-0.16.3-r1.ebuild,v 1.1 2012/04/09 18:17:31 slyfox Exp $
+
+EAPI="3"
CABAL_FEATURES="bin"
-inherit haskell-cabal
+inherit base haskell-cabal
DESCRIPTION="C->Haskell FFI tool that gives some cross-language type safety"
HOMEPAGE="http://www.cse.unsw.edu.au/~chak/haskell/c2hs/"
@@ -11,17 +13,19 @@ SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc"
DEPEND=">=dev-lang/ghc-6.6.1
>=dev-haskell/cabal-1.6
- >=dev-haskell/language-c-0.3.1.1
+ >=dev-haskell/language-c-0.3.1.1 <dev-haskell/language-c-0.5
doc? ( ~app-text/docbook-xml-dtd-4.2
app-text/docbook-xsl-stylesheets
>=dev-libs/libxslt-1.1.2 )"
RDEPEND="dev-libs/gmp"
+PATCHES=("${FILESDIR}/${PN}"-0.16.3-language-c-0.4.patch)
+
src_compile() {
cabal_src_compile
diff --git a/dev-haskell/c2hs/files/c2hs-0.16.3-language-c-0.4.patch b/dev-haskell/c2hs/files/c2hs-0.16.3-language-c-0.4.patch
new file mode 100644
index 000000000000..cdf0fbe547d6
--- /dev/null
+++ b/dev-haskell/c2hs/files/c2hs-0.16.3-language-c-0.4.patch
@@ -0,0 +1,25 @@
+diff --git a/c2hs.cabal b/c2hs.cabal
+index 89f978f..53a96e5 100644
+--- a/c2hs.cabal
++++ b/c2hs.cabal
+@@ -41,7 +41,7 @@ flag base3
+
+ Executable c2hs
+ Build-Depends: base >= 2 && < 5,
+- language-c >= 0.3.1.1 && < 0.4.0,
++ language-c >= 0.3.1.1 && < 0.5,
+ filepath
+
+ if flag(base3)
+diff --git a/src/C2HS/Gen/Bind.hs b/src/C2HS/Gen/Bind.hs
+index 1fd2acc..9c25b42 100644
+--- a/src/C2HS/Gen/Bind.hs
++++ b/src/C2HS/Gen/Bind.hs
+@@ -117,6 +117,7 @@ import Control.Monad (when, unless, liftM, mapAndUnzipM)
+ import Language.C.Data.Position
+ import Language.C.Data.Ident
+ import Language.C.Pretty
++import Language.C.Syntax.AST
+ import Text.PrettyPrint.HughesPJ (render)
+ import Data.Errors
+ import Data.Attributes (newAttrsOnlyPos)