summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-09 10:55:28 +0000
committerMark Wright <gienah@gentoo.org>2014-03-09 10:55:28 +0000
commitd657b7af8d58023caa31bace888c354e2f8f2b19 (patch)
treeed974d0351d0b4da6ca82c074c3bdc49c9a235ae /dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild
parentamd64 stable, bug 499954 (diff)
downloadgentoo-2-d657b7af8d58023caa31bace888c354e2f8f2b19.tar.gz
gentoo-2-d657b7af8d58023caa31bace888c354e2f8f2b19.tar.bz2
gentoo-2-d657b7af8d58023caa31bace888c354e2f8f2b19.zip
Add asn1-encoding
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild')
-rw-r--r--dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild b/dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild
new file mode 100644
index 000000000000..5ad2423c1368
--- /dev/null
+++ b/dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild,v 1.1 2014/03/09 10:55:28 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="ASN1 data reader and writer in RAW, BER and DER forms"
+HOMEPAGE="http://github.com/vincenthz/hs-asn1"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-haskell/asn1-types-0.2.1:=[profile?] <dev-haskell/asn1-types-0.3:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( dev-haskell/hunit:=[profile?]
+ >=dev-haskell/quickcheck-2:=[profile?]
+ >=dev-haskell/test-framework-0.3:=[profile?]
+ >=dev-haskell/test-framework-quickcheck2-0.2:=[profile?] )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test test)
+}