summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-08-05 17:24:07 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-08-05 17:24:07 +0000
commit86c683ad598a6cd77bf009658c21ddcc4fb879c6 (patch)
tree5b1cbaa1a280c12b65ad61cd677e47448dcb18e2 /dev-go
parentDrop pkg_config() as handling the multiple authentication mechanisms is no lo... (diff)
downloadgentoo-2-86c683ad598a6cd77bf009658c21ddcc4fb879c6.tar.gz
gentoo-2-86c683ad598a6cd77bf009658c21ddcc4fb879c6.tar.bz2
gentoo-2-86c683ad598a6cd77bf009658c21ddcc4fb879c6.zip
add support for golang-vcs-snapshot to live ebuild
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-protobuf/ChangeLog5
-rw-r--r--dev-go/go-protobuf/go-protobuf-9999.ebuild33
2 files changed, 6 insertions, 32 deletions
diff --git a/dev-go/go-protobuf/ChangeLog b/dev-go/go-protobuf/ChangeLog
index 28354cbb1ab0..e74f11a673b1 100644
--- a/dev-go/go-protobuf/ChangeLog
+++ b/dev-go/go-protobuf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-go/go-protobuf
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-protobuf/ChangeLog,v 1.3 2015/07/30 09:31:49 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-protobuf/ChangeLog,v 1.4 2015/08/05 17:24:07 williamh Exp $
+
+ 05 Aug 2015; William Hubbs <williamh@gentoo.org> go-protobuf-9999.ebuild:
+ add support for golang-vcs-snapshot to live ebuild
30 Jul 2015; Patrick Lauer <patrick@gentoo.org>
go-protobuf-0_pre20150727.ebuild, go-protobuf-9999.ebuild:
diff --git a/dev-go/go-protobuf/go-protobuf-9999.ebuild b/dev-go/go-protobuf/go-protobuf-9999.ebuild
index 4578bb28466a..1fe02c550738 100644
--- a/dev-go/go-protobuf/go-protobuf-9999.ebuild
+++ b/dev-go/go-protobuf/go-protobuf-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-protobuf/go-protobuf-9999.ebuild,v 1.3 2015/07/30 09:31:49 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-protobuf/go-protobuf-9999.ebuild,v 1.4 2015/08/05 17:24:07 williamh Exp $
EAPI=5
@@ -13,6 +13,7 @@ else
KEYWORDS="~amd64"
EGIT_COMMIT="68c687dc49948540b356a6b47931c9be4fcd0245"
SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
fi
inherit golang-build
@@ -24,37 +25,7 @@ IUSE=""
DEPEND=""
RDEPEND=""
-if [[ ${PV} != *9999* ]]; then
-src_unpack() {
- local f
-
- for f in ${A}
- do
- case "${f}" in
- *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
- local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
- debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
-
- # XXX: check whether the directory structure inside is
- # fine? i.e. if the tarball has actually a parent dir.
- mkdir -p "${destdir}" || die
- tar -C "${destdir}" -x --strip-components 1 \
- -f "${DISTDIR}/${f}" || die
- ;;
- *)
- debug-print "${FUNCNAME}: falling back to unpack for ${f}"
-
- # fall back to the default method
- unpack "${f}"
- ;;
- esac
- done
-}
-fi
-
src_install() {
- rm -rf src/${EGO_SRC}/.git* || die
golang-build_src_install
dobin bin/*
}