summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-24 00:22:44 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-24 00:22:44 +0000
commit8d12df212d8458200c04d14145c2d3996f0769dc (patch)
tree9b4d5c881e2cb2b97cf7c5974808afd7e30dff59 /dev-games
parentsoundconverter version bump (diff)
downloadgentoo-2-8d12df212d8458200c04d14145c2d3996f0769dc.tar.gz
gentoo-2-8d12df212d8458200c04d14145c2d3996f0769dc.tar.bz2
gentoo-2-8d12df212d8458200c04d14145c2d3996f0769dc.zip
Compile fix by Michael Schreckenbauer, bug #178204
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/newton/ChangeLog6
-rw-r--r--dev-games/newton/files/newton-1.53-glut.patch12
-rw-r--r--dev-games/newton/newton-1.53.ebuild42
3 files changed, 35 insertions, 25 deletions
diff --git a/dev-games/newton/ChangeLog b/dev-games/newton/ChangeLog
index 7d1303127401..872fbd445345 100644
--- a/dev-games/newton/ChangeLog
+++ b/dev-games/newton/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/newton
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/newton/ChangeLog,v 1.2 2007/07/22 09:48:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/newton/ChangeLog,v 1.3 2007/07/24 00:22:44 nyhm Exp $
+
+ 24 Jul 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/newton-1.53-glut.patch, newton-1.53.ebuild:
+ Compile fix by Michael Schreckenbauer, bug #178204
22 Jul 2007; Hans de Graaff <graaff@gentoo.org> newton-1.53.ebuild:
Drop virtual/x11 references.
diff --git a/dev-games/newton/files/newton-1.53-glut.patch b/dev-games/newton/files/newton-1.53-glut.patch
new file mode 100644
index 000000000000..f1eebc1cec85
--- /dev/null
+++ b/dev-games/newton/files/newton-1.53-glut.patch
@@ -0,0 +1,12 @@
+diff -Naur ../newtonSDK/samples/toolBox/stdafx.h ./samples/toolBox/stdafx.h
+--- ../newtonSDK/samples/toolBox/stdafx.h 2006-04-04 03:02:14.000000000 +0200
++++ ./samples/toolBox/stdafx.h 2007-05-12 15:40:31.000000000 +0200
+@@ -39,7 +39,7 @@
+ #ifdef _MIPS_ARCH
+ #include <Glut/glut.h>
+ #else
+- #include <glut.h>
++ #include <GL/glut.h>
+ #endif
+ #include <unistd.h>
+ #endif
diff --git a/dev-games/newton/newton-1.53.ebuild b/dev-games/newton/newton-1.53.ebuild
index e4b43d2e6302..4df5ddfe5c2d 100644
--- a/dev-games/newton/newton-1.53.ebuild
+++ b/dev-games/newton/newton-1.53.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/newton/newton-1.53.ebuild,v 1.2 2007/07/22 09:48:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/newton/newton-1.53.ebuild,v 1.3 2007/07/24 00:22:44 nyhm Exp $
+
+inherit eutils
DESCRIPTION="an integrated solution for real time simulation of physics environments"
HOMEPAGE="http://www.physicsengine.com/"
@@ -12,13 +14,11 @@ SLOT="0"
KEYWORDS="~x86"
IUSE="doc"
-RDEPEND="doc? (
- x11-libs/libXmu
- x11-libs/libXi
- virtual/opengl
- virtual/glut )"
-
-DEPEND="${RDEPEND}"
+DEPEND="doc? (
+ virtual/opengl
+ virtual/glu
+ virtual/glut
+ )"
S=${WORKDIR}/newtonSDK
@@ -41,12 +41,11 @@ src_unpack() {
tutorial_06_UtilityFuntionality/makefile \
tutorial_03_UsingCollisionTree/makefile \
|| die "failed fixing sample makefiles"
- # This is commented out because this thing simply does not compile
- # with lots of other CFLAGS and I've been unable to determine exactly
- # what is causing it to fail, but even CFLAGS="-O2" fails.
-# sed -i \
-# -e "s:^FLAGS = -g -O0 -c -Wall:FLAGS = ${CFLAGS}:" \
-# makefile
+ sed -i \
+ -e "/^FLAGS =/s:-g -O0:${CFLAGS}:" \
+ makefile \
+ || die "sed makefile failed"
+ epatch "${FILESDIR}"/${P}-glut.patch
fi
}
@@ -54,27 +53,22 @@ src_compile() {
if use doc; then
cd samples
emake || die "emake samples failed"
+ rm -f */*.elf */*.o
fi
}
src_install() {
- dolib sdk/libNewton.a
+ dolib.a sdk/libNewton.a || die "dolib.a failed"
insinto /usr/include
- doins sdk/Newton.h
+ doins sdk/Newton.h || die "doins failed"
if use doc; then
- find samples -name \*.elf | xargs rm
- find samples -name \*.o | xargs rm
-
insinto /usr/share/${PN}
- doins -r `ls --ignore=bin samples/*`
+ doins -r samples/* || die "doins samples failed"
exeinto /usr/share/${PN}/bin
- dobin samples/bin/tutorial_*
+ doexe samples/bin/tutorial_* || die "doexe failed"
fi
- chmod -x doc/*
dodoc doc/*
-
- prepgamesdirs
}