summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-04 01:44:49 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-04 01:44:49 +0000
commit34a2ab715a20ba662131f9cf520da3f58c6eb7a7 (patch)
tree5ffa4bd39078b3b198a71fe959b7e844b25196b3 /dev-games
parentspread arm/ia64/s390/sh love (diff)
downloadgentoo-2-34a2ab715a20ba662131f9cf520da3f58c6eb7a7.tar.gz
gentoo-2-34a2ab715a20ba662131f9cf520da3f58c6eb7a7.tar.bz2
gentoo-2-34a2ab715a20ba662131f9cf520da3f58c6eb7a7.zip
Version bump, bug #166468
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/ogre/ChangeLog8
-rw-r--r--dev-games/ogre/files/digest-ogre-1.4.03
-rw-r--r--dev-games/ogre/files/ogre-1.4.0-cegui.patch19
-rw-r--r--dev-games/ogre/ogre-1.4.0.ebuild99
4 files changed, 128 insertions, 1 deletions
diff --git a/dev-games/ogre/ChangeLog b/dev-games/ogre/ChangeLog
index 805e7fe5f3c1..4951615d7e55 100644
--- a/dev-games/ogre/ChangeLog
+++ b/dev-games/ogre/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/ogre
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.35 2007/02/14 20:13:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.36 2007/04/04 01:44:49 nyhm Exp $
+
+*ogre-1.4.0 (04 Apr 2007)
+
+ 04 Apr 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/ogre-1.4.0-cegui.patch, +ogre-1.4.0.ebuild:
+ Version bump, bug #166468
14 Feb 2007; Michael Sterrett <mr_bones_@gentoo.org> ogre-1.2.5.ebuild:
warn for USE=threads and die for USE="threads cegui" if cegui-0.5 is installed
diff --git a/dev-games/ogre/files/digest-ogre-1.4.0 b/dev-games/ogre/files/digest-ogre-1.4.0
new file mode 100644
index 000000000000..e9954795e21d
--- /dev/null
+++ b/dev-games/ogre/files/digest-ogre-1.4.0
@@ -0,0 +1,3 @@
+MD5 125d85992d95eda9c5ef2d65c4481a92 ogre-linux_osx-v1-4-0.tar.bz2 28719937
+RMD160 ab8b64e66d56b286a181bfa206adf0c26574872d ogre-linux_osx-v1-4-0.tar.bz2 28719937
+SHA256 8e54ccc9fca82186933d9788559eb877c3ba7e487c198ae62ae1119ad1df9844 ogre-linux_osx-v1-4-0.tar.bz2 28719937
diff --git a/dev-games/ogre/files/ogre-1.4.0-cegui.patch b/dev-games/ogre/files/ogre-1.4.0-cegui.patch
new file mode 100644
index 000000000000..c089164af219
--- /dev/null
+++ b/dev-games/ogre/files/ogre-1.4.0-cegui.patch
@@ -0,0 +1,19 @@
+--- acinclude.m4
++++ acinclude.m4
+@@ -411,6 +411,8 @@
+ ])
+
+ AC_DEFUN([OGRE_CHECK_CEGUI], [
++ AC_ARG_ENABLE(cegui)
++ if test x$enable_cegui != xno; then
+ PKG_CHECK_MODULES(CEGUI, CEGUI >= 0.5.0,
+ [build_cegui_sample=true], [build_cegui_sample=false])
+ if test x$build_cegui_sample = xtrue; then
+@@ -426,6 +428,7 @@
+ else
+ AC_MSG_RESULT([CEGUI not available, Gui and FacialAnimation samples will not be built])
+ fi
++ fi
+ AM_CONDITIONAL([HAVE_CEGUI], [test x$build_cegui_sample = xtrue])
+ ])
+
diff --git a/dev-games/ogre/ogre-1.4.0.ebuild b/dev-games/ogre/ogre-1.4.0.ebuild
new file mode 100644
index 000000000000..fc569da56597
--- /dev/null
+++ b/dev-games/ogre/ogre-1.4.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.4.0.ebuild,v 1.1 2007/04/04 01:44:49 nyhm Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Object-oriented Graphics Rendering Engine"
+HOMEPAGE="http://www.ogre3d.org/"
+SRC_URI="mirror://sourceforge/ogre/ogre-linux_osx-v${PV//./-}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc cegui cg double-precision examples freeimage gtk openexr threads"
+RESTRICT="test" #139905
+
+RDEPEND="dev-libs/zziplib
+ >=media-libs/freetype-2.1.10
+ virtual/opengl
+ virtual/glu
+ x11-libs/libXt
+ x11-libs/libXaw
+ x11-libs/libXrandr
+ x11-libs/libX11
+ cegui? ( >=dev-games/cegui-0.5 )
+ cg? ( media-gfx/nvidia-cg-toolkit )
+ freeimage? ( media-libs/freeimage )
+ gtk? (
+ >=dev-cpp/gtkmm-2.4
+ >=dev-cpp/libglademm-2.4
+ )
+ openexr? ( >=media-libs/openexr-1.2 )
+ threads? ( dev-libs/boost )"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/ogrenew
+
+pkg_setup() {
+ if use threads ; then
+ if ! built_with_use dev-libs/boost threads ; then
+ die "Please emerge dev-libs/boost with USE=threads"
+ fi
+ ewarn "Threads support is experimental in ${PN} and is not recommended."
+ ewarn "See http://bugs.gentoo.org/show_bug.cgi?id=144819"
+ ewarn "Read the man page for portage by typing \"man portage\""
+ ewarn "and read about /etc/portage/package.use for disabling"
+ ewarn "the threads use flag for ${PN} without affecting other packages."
+ ebeep
+ epause 10
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ find -name CVS -print0 | xargs -0 rm -rf
+ if use examples ; then
+ cp -r Samples install-examples || die
+ find install-examples \
+ '(' -name 'Makefile*' -o -name obj -o \
+ -name bin -o -name '*.cbp' -o -name '*.vcproj*' ')' \
+ -print0 | xargs -0 rm -rf
+ fi
+ sed -i '/CPPUNIT/d' configure.in || die "sed failed"
+ epatch "${FILESDIR}"/${P}-cegui.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-ogre-demos \
+ --enable-static \
+ --with-platform=GLX \
+ --with-gui=$(usev gtk || echo Xt) \
+ $(use_enable cegui) \
+ $(use_enable cg) \
+ $(use_enable double-precision double) \
+ $(use_enable freeimage) \
+ $(use_enable openexr) \
+ $(use_enable threads threading) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r Docs/* || die "doins Docs failed"
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/Samples
+ doins -r install-examples/* || die "doins Samples failed"
+ fi
+ dodoc AUTHORS BUGS LINUX.DEV README
+}