summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2015-06-06 03:28:39 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2015-06-06 03:28:39 +0000
commit47855f8f0147b7fc1027ddd93078cf90d58d5bb2 (patch)
treed1995471834b2d0e61e0653c904d24d392d84584 /dev-games/openscenegraph
parentAdd Perl 5.22 version, remove old (diff)
downloadgentoo-2-47855f8f0147b7fc1027ddd93078cf90d58d5bb2.tar.gz
gentoo-2-47855f8f0147b7fc1027ddd93078cf90d58d5bb2.tar.bz2
gentoo-2-47855f8f0147b7fc1027ddd93078cf90d58d5bb2.zip
Properly handle USE=qt4, fixes bug 550206.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key B1E955DB)
Diffstat (limited to 'dev-games/openscenegraph')
-rw-r--r--dev-games/openscenegraph/ChangeLog6
-rw-r--r--dev-games/openscenegraph/files/openscenegraph-3.2.1-cmake.patch42
-rw-r--r--dev-games/openscenegraph/openscenegraph-3.2.1.ebuild15
3 files changed, 13 insertions, 50 deletions
diff --git a/dev-games/openscenegraph/ChangeLog b/dev-games/openscenegraph/ChangeLog
index b18a049a4746..45b3a489de83 100644
--- a/dev-games/openscenegraph/ChangeLog
+++ b/dev-games/openscenegraph/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/openscenegraph
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.61 2015/02/21 12:02:44 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.62 2015/06/06 03:28:39 reavertm Exp $
+
+ 06 Jun 2015; Maciej Mrozowski <reavertm@gentoo.org>
+ files/openscenegraph-3.2.1-cmake.patch, openscenegraph-3.2.1.ebuild:
+ Properly handle USE=qt4, fixes bug 550206.
21 Feb 2015; Agostino Sarubbo <ago@gentoo.org> openscenegraph-3.2.1.ebuild:
Stable for ppc, wrt bug #526372
diff --git a/dev-games/openscenegraph/files/openscenegraph-3.2.1-cmake.patch b/dev-games/openscenegraph/files/openscenegraph-3.2.1-cmake.patch
index 84649e5f3d61..1a85ee8d47ba 100644
--- a/dev-games/openscenegraph/files/openscenegraph-3.2.1-cmake.patch
+++ b/dev-games/openscenegraph/files/openscenegraph-3.2.1-cmake.patch
@@ -70,48 +70,6 @@ diff -ruN OpenSceneGraph-3.2.1/CMakeLists.txt new/CMakeLists.txt
ENDIF()
# Include macro utilities here
-@@ -560,16 +561,16 @@
-
- IF (DESIRED_QT_VERSION)
- IF (DESIRED_QT_VERSION MATCHES 5)
-- FIND_PACKAGE(Qt5Widgets)
-+ MACRO_OPTIONAL_FIND_PACKAGE(Qt5Widgets)
- ELSEIF (DESIRED_QT_VERSION MATCHES 4)
-- FIND_PACKAGE(Qt4)
-+ MACRO_OPTIONAL_FIND_PACKAGE(Qt4)
- ELSE()
-- FIND_PACKAGE(Qt3)
-+ MACRO_OPTIONAL_FIND_PACKAGE(Qt3)
- ENDIF()
-
- ELSE()
-
-- FIND_PACKAGE(Qt5Widgets QUIET)
-+ MACRO_OPTIONAL_FIND_PACKAGE(Qt5Widgets QUIET)
-
- IF ( Qt5Widgets_FOUND )
- # CMake 2.8.8 or greater required
-@@ -585,17 +586,17 @@
- ENDIF( )
-
- IF ( NOT Qt5Widgets_FOUND )
-- FIND_PACKAGE(Qt4)
-+ MACRO_OPTIONAL_FIND_PACKAGE(Qt4)
-
- IF (NOT QT4_FOUND)
-- FIND_PACKAGE(Qt3)
-+ MACRO_OPTIONAL_FIND_PACKAGE(Qt3)
- ENDIF()
- ENDIF()
- ENDIF()
-
- #If we have found Qt5, let's try to top off by getting the webkit as well
- IF ( Qt5Widgets_FOUND )
-- FIND_PACKAGE(Qt5WebKitWidgets QUIET)
-+ MACRO_OPTIONAL_FIND_PACKAGE(Qt5WebKitWidgets QUIET)
- ENDIF()
-
- ENDIF()
@@ -604,12 +605,12 @@
IF (BUILD_OSG_EXAMPLES AND NOT ANDROID)
diff --git a/dev-games/openscenegraph/openscenegraph-3.2.1.ebuild b/dev-games/openscenegraph/openscenegraph-3.2.1.ebuild
index 4a35f11e343c..8d52d5c15508 100644
--- a/dev-games/openscenegraph/openscenegraph-3.2.1.ebuild
+++ b/dev-games/openscenegraph/openscenegraph-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/openscenegraph-3.2.1.ebuild,v 1.4 2015/02/21 12:02:44 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/openscenegraph-3.2.1.ebuild,v 1.5 2015/06/06 03:28:39 reavertm Exp $
EAPI=5
@@ -33,11 +33,6 @@ RDEPEND="
fox? ( x11-libs/fox:1.6[opengl] )
glut? ( media-libs/freeglut )
gtk? ( x11-libs/gtkglext )
- qt4? (
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtopengl:4
- )
sdl? ( media-libs/libsdl )
wxwidgets? ( x11-libs/wxGTK[opengl,X] )
)
@@ -53,6 +48,11 @@ RDEPEND="
openinventor? ( media-libs/coin )
pdf? ( app-text/poppler[cairo] )
png? ( media-libs/libpng:0 )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
svg? (
gnome-base/librsvg
x11-libs/cairo
@@ -90,6 +90,7 @@ src_configure() {
append-cppflags -D__STDC_CONSTANT_MACROS
mycmakeargs=(
+ -DDESIRED_QT_VERSION=4
-DDYNAMIC_OPENSCENEGRAPH=ON
-DWITH_ITK=OFF
-DGENTOO_DOCDIR="/usr/share/doc/${PF}"
@@ -111,7 +112,7 @@ src_configure() {
$(cmake-utils_use_with openinventor Inventor)
$(cmake-utils_use_with pdf Poppler-glib)
$(cmake-utils_use_with png)
- $(cmake-utils_use_with qt4)
+ $(cmake-utils_use qt4 OSG_USE_QT)
$(cmake-utils_use_with sdl)
$(cmake-utils_use_with svg rsvg)
$(cmake-utils_use_with tiff)