summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-02-12 17:56:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-02-12 17:56:05 +0000
commited5985c7f2cfd219581cdb551c0d02e1953e21d0 (patch)
treeb5bd43f0e570d74382c740c077af366f0e0121ea /dev-games/irrlicht
parentAdded int64 use flag for blas-goto (diff)
downloadgentoo-2-ed5985c7f2cfd219581cdb551c0d02e1953e21d0.tar.gz
gentoo-2-ed5985c7f2cfd219581cdb551c0d02e1953e21d0.tar.bz2
gentoo-2-ed5985c7f2cfd219581cdb551c0d02e1953e21d0.zip
old
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-games/irrlicht')
-rw-r--r--dev-games/irrlicht/irrlicht-1.3.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/dev-games/irrlicht/irrlicht-1.3.ebuild b/dev-games/irrlicht/irrlicht-1.3.ebuild
deleted file mode 100644
index a7e8f3d6d598..000000000000
--- a/dev-games/irrlicht/irrlicht-1.3.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.3.ebuild,v 1.1 2007/06/01 21:04:10 nyhm Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="open source high performance realtime 3D engine written in C++"
-HOMEPAGE="http://irrlicht.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc"
-
-RDEPEND="media-libs/jpeg
- media-libs/libpng
- virtual/opengl
- virtual/glu
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- app-arch/unzip
- x11-proto/xproto
- x11-proto/xf86vidmodeproto"
-
-S=${WORKDIR}/${P}/source/Irrlicht
-
-src_unpack() {
- unpack ${A}
- cd ${P}
- epatch \
- "${FILESDIR}"/${P}-config.patch \
- "${FILESDIR}"/${P}-demoMake.patch
-
- cd "${S}"
- # stupid nvidia / xorg GL differences
- # still needed - bug #114335
- if echo -e '#include <GL/glx.h>\nglXGetProcAddress blah;' | \
- $(tc-getCC) -E - | \
- grep -q glXGetProcAddressARB
- then
- epatch "${FILESDIR}"/${P}-opengl.patch
- fi
-
- # use the system zlib/jpeg/png
- sed -i \
- -e '/^CXXFLAGS/s:=:+=:' \
- -e '/^CXXINCS/s:-Izlib -Ijpeglib -Ilibpng::' \
- -e '/^ZLIBOBJ/d' \
- -e '/^JPEGLIBOBJ/d' \
- -e '/^LIBPNGOBJ/d' \
- Makefile || die "sed failed"
-}
-
-src_compile() {
- emake CXX="$(tc-getCXX)" || die "emake failed"
-}
-
-src_install() {
- cd ../..
- dolib.a lib/Linux/libIrrlicht.a || die "dolib.a failed"
- insinto /usr/include/${PN}
- doins include/* || die "doins failed"
- dodoc changes.txt readme.txt
- if use doc ; then
- insinto /usr/share/doc/${PF}
- doins -r examples media || die "doins failed"
- fi
-}